Bug 472875 - Using -m option results in 'select: Invalid argument' messages in the log
Using -m option results in 'select: Invalid argument' messages in the log
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: sysklogd (Show other bugs)
5.1
All Linux
medium Severity medium
: rc
: ---
Assigned To: Peter Vrabec
BaseOS QE
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-25 05:28 EST by Tomas Smetana
Modified: 2010-10-23 02:11 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 625795 (view as bug list)
Environment:
Last Closed: 2010-03-30 04:15:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (849 bytes, patch)
2008-11-25 05:37 EST, Tomas Smetana
no flags Details | Diff

  None (edit)
Description Tomas Smetana 2008-11-25 05:28:29 EST
Description of problem:
Using -m option with nonzero argument will result in the bogus error messages being logged.  This is caused by a bug in sysklogd:  the errno value of select is checked after it has been reset (from EINTR to EINVAL) by the functions that log the "MARK" message.

Version-Release number of selected component (if applicable):
sysklogd-1.4.1-44.el5

How reproducible:
always

Steps to Reproduce:
1. start 'syslogd -m 2 -r -d'
2. let it run for several minutes
3. look into /var/log/messages
  
Actual results:
Nov 25 09:00:18 localhost -- MARK --
Nov 25 09:00:18 localhost syslogd: select: Invalid argument
Nov 25 09:02:18 localhost -- MARK --
Nov 25 09:02:18 localhost syslogd: select: Invalid argument
Nov 25 09:04:18 localhost -- MARK --
Nov 25 09:04:18 localhost syslogd: select: Invalid argument
Nov 25 09:06:18 localhost -- MARK --

Expected results:
Nov 25 09:00:18 localhost -- MARK --
Nov 25 09:02:18 localhost -- MARK --
Nov 25 09:04:18 localhost -- MARK --
Nov 25 09:06:18 localhost -- MARK --
Comment 1 Tomas Smetana 2008-11-25 05:37:04 EST
Created attachment 324585 [details]
Proposed patch

Avoids problem by storing the errno from select to the new variable.
Comment 3 RHEL Product and Program Management 2009-03-26 13:13:39 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 5 Peter Vrabec 2009-11-30 09:46:23 EST
It seems the patch is not needed anymore. I couldn't reproduce this problem on RHEL5.4. I suspect that this issue was fixed by one of glibc updates.
Comment 6 Peter Vrabec 2009-11-30 09:50:32 EST
I'm closing this bug report. If the problem persist, please reopen it.
Comment 17 errata-xmlrpc 2010-03-30 04:15:36 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0211.html

Note You need to log in before you can comment on or make changes to this bug.