Bug 47290 - relocating libpcre.so.*
relocating libpcre.so.*
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: pcre (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Bernhard Rosenkraenzer
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-04 10:17 EDT by Alastair Tse
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-04 10:17:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alastair Tse 2001-07-04 10:17:36 EDT
Description of Problem:
I would like to suggest that libpcre.so.* not be located in /lib but in
/usr/lib. I don't understand why it is in /lib. The reason why I am
suggesting this is because a program I was compiling claled modlogan which
failed because libpcre.so.* was in /lib. I moved it to /usr/lib and reran
ldconfig and it worked.

Maybe I don't know how shared libraries work properly :(
Comment 1 Bernhard Rosenkraenzer 2001-07-05 09:41:07 EDT
We're putting pcre in /lib because (/bin/)grep 2.5 will depend on it.
While we're still at grep 2.4, it isn't obvious, I know. But we'd rather put 
it in the right place(TM) right away than having to move it later (when we 
update grep).

If modlogan doesn't find it there, that's their bug: Any application using 
pcre should use "pcre-config --libs" and "pcre-config --cflags" to get the 
location of pcre.

Note You need to log in before you can comment on or make changes to this bug.