Bug 472987 - Radeon *ERROR*s in dmesg
Radeon *ERROR*s in dmesg
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-25 17:25 EST by Don Zickus
Modified: 2009-10-14 10:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-14 10:51:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of lspci -vvv (20.91 KB, application/octet-stream)
2008-11-25 17:26 EST, Don Zickus
no flags Details

  None (edit)
Description Don Zickus 2008-11-25 17:25:26 EST
Description of problem:

I installed F10 on my laptop and it almost always locks up after about 10 minutes of usage.  One of the issues is displayed below.

I see the following in dmesg right before my desktop locks up

Nov 22 14:30:47 lorax kernel: [drm:radeon_gem_ib_get] *ERROR* Major case fail to allocate IB from freelist ffff
Nov 22 14:30:47 lorax kernel: [drm:radeon_cs2_ioctl] *ERROR* ib_get failed

Version-Release number of selected component (if applicable):
kernel-2.6.27.5-117.fc10.x86_64

How reproducible:
almost always after 10 minutes of use after bootup (assuming I get past my other lockup involving futex_wait).

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Don Zickus 2008-11-25 17:26:42 EST
Created attachment 324676 [details]
output of lspci -vvv

in case this is useful to determine the radeon card i am using
Comment 2 Dave Airlie 2008-11-27 00:37:53 EST
please try xorg-x11-drv-ati-6.9.0-58 from koji or later.
Comment 3 Don Zickus 2008-12-01 16:10:33 EST
Ok I tried -60 and the -132.fc10 kernel too.  After a few hours of light work, my laptop hasn't hung yet.  So something has worked for the better.

As a side note, my laptop also hasn't hung with futex problems either (which usually takes less than 30 minutes), so either your patches fixed that problem too or I haven't stress my laptop hard enough.

I'll bang on it more tonight.
Comment 4 Jérôme Glisse 2009-10-14 06:39:18 EDT
So this issue is fixed ? Please close the bug if it's.
Comment 5 Don Zickus 2009-10-14 08:36:09 EDT
Yeah, I don't see those problems anymore.  Most of my Radeon issues have disappeared, the only lingering one left is resuming from suspend.  But that is opened under a different bz.
Comment 6 Jérôme Glisse 2009-10-14 10:51:56 EDT
Closing this one then.

Note You need to log in before you can comment on or make changes to this bug.