Bug 47300 - javascript/frames problem in konqueror
javascript/frames problem in konqueror
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-04 12:34 EDT by Tim Waugh
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-17 09:50:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
index.html (375 bytes, text/html)
2001-07-04 12:34 EDT, Tim Waugh
no flags Details
otherframe.html (210 bytes, text/html)
2001-07-04 12:35 EDT, Tim Waugh
no flags Details

  None (edit)
Description Tim Waugh 2001-07-04 12:34:30 EDT
Description of Problem:
When a frame has initial src="" (which is dubious to start with, but 
there are sites that do this), and another frame sets the original 
frame's location with some javascript, the original frame remains empty.

How Reproducible:
100%

Steps to Reproduce:
1. Put the attached files in the same directory.
2. View index.html.

Actual Results:
Frame 'main' remains empty.

Expected Results:
Frame 'main' displays www.redhat.com front page.

Additional Information:
Works in other browsers..
Comment 1 Tim Waugh 2001-07-04 12:34:49 EDT
Created attachment 22667 [details]
index.html
Comment 2 Tim Waugh 2001-07-04 12:35:20 EDT
Created attachment 22668 [details]
otherframe.html
Comment 3 Bernhard Rosenkraenzer 2001-07-17 09:50:34 EDT
This is fixed in CVS. Backporting is all but easy though.
Comment 4 Tim Waugh 2001-08-11 05:54:04 EDT
Fixed in 2.2.

Note You need to log in before you can comment on or make changes to this bug.