This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 473008 - 10.2 Enhanced comments/fixes
10.2 Enhanced comments/fixes
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: Grid_User_Guide (Show other bugs)
1.1
All Linux
high Severity high
: 1.1
: ---
Assigned To: Lana Brindley
Jeff Needle
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-25 19:58 EST by William Henry
Modified: 2013-10-23 19:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-05 00:01:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William Henry 2008-11-25 19:58:14 EST
Description of problem:

The section seems to assume that the AMI already has condor on it.  Which is fine perhaps we need to make condor AMIs available. But then we'd probably have the hooks installed too and could skip the install the hooks section.

Step 1.  I'm not sure where to find or get these keys? Are they the AWS ones I already have .. as per the intro?  Be explicit. And simplify this some.

Step 2. I'm assuming these changes are for the condor_local.config. Is that right? It doesn't say it.


Also it doesn't suggest that you remove COLLECTOR, NEGOTIATOR, SCHEDD from the local config. But one should right?  Do we have to change the COLLECTOR_HOST value too? Maybe not but that would be a question.  I guess if the step explicitly says : Make only the following changes to condor_config.local

Maybe a "sample" config file for the AMI would be useful?
Comment 1 Robert Rati 2008-11-26 11:19:12 EST
The feature is designed such that 'yum install condor-ec2-enhanced' will install all components necessary for the feature to run, which includes condor.  However, since all the RPMs aren't in RHN yet, it isn't possible to do this and more manual installation is needed.  From a documentation perspective though, all that should be needed is to say 'yum install condor-ec2-enhanced'.

1. These are just standard public/private RSA keys.  If we need to provide documentation on how to create them, we can add these steps in a note or something:
Create a private key file called 'private key': 'openssl genrsa -out private_key 1024'
Generate a public key file called 'public_key': 'openssl rsa -in private_key -out public_key -pubout'

2. These changes can go in any condor configuration file.  We should use the convention used throughout the document when discussing adding configuration entries to condor's configuration.

There is no need to edit the condor configuration files any more than is documented.  We could reduce the daemons running on the AMI or provide default configs, but this really won't do much other than complicate the installation process.
Comment 2 William Henry 2008-11-26 20:09:12 EST
From Rob's "1" above - yes add the following to step 1 - perhaps in the hint box:

The keys required are NOT the AWS keys needed elsewhere. Generate public and private keys using openssl:

1. openssl genrsa -out private_key 1024
2. openssl rsa -in private_key -out public_key -puboutrs
Comment 3 William Henry 2008-11-26 20:13:58 EST
In response to Rob's points in 2 above:

True changes can go into either configuration file but we should say that and perhaps make a recommendation. (Remembering that elsewhere we recommend few changes to the /etc/condor/condor_config).

The changes described in the following steps (2-5) should be made to a condor configuration file. It is recommended to add these variables to the local configuration (/var/lib/condor/condor_config/local).
Comment 4 William Henry 2008-11-26 20:14:35 EST
woops that's condor_config.local not condor_config/local above.
Comment 5 Lana Brindley 2008-12-04 23:56:03 EST
(In reply to comment #1)
> The feature is designed such that 'yum install condor-ec2-enhanced' will
> install all components necessary for the feature to run, which includes condor.
>  However, since all the RPMs aren't in RHN yet, it isn't possible to do this
> and more manual installation is needed.  From a documentation perspective
> though, all that should be needed is to say 'yum install condor-ec2-enhanced'.
> 
> 1. These are just standard public/private RSA keys.  If we need to provide
> documentation on how to create them, we can add these steps in a note or
> something:
> Create a private key file called 'private key': 'openssl genrsa -out
> private_key 1024'
> Generate a public key file called 'public_key': 'openssl rsa -in private_key
> -out public_key -pubout'

<listitem>
	<para>
		Create a private key file called <parameter>private key</parameter>:
<screen>
$ openssl genrsa -out private_key 1024
</screen>
		Create a public key file called <parameter>public_key</parameter>:
<screen>
$ openssl rsa -in private_key -out public_key -pubout
</screen>
        </para>
	<para>
		The must be placed on the EC2 AMI at <filename>/root/.ec2/rsa_key</filename>. This private key must match the public key set in <filename>set_rsapublickey</filename> for a given route or job.
	</para>
</listitem>

> 
> 2. These changes can go in any condor configuration file.  We should use the
> convention used throughout the document when discussing adding configuration
> entries to condor's configuration.
> 
> There is no need to edit the condor configuration files any more than is
> documented.  We could reduce the daemons running on the AMI or provide default
> configs, but this really won't do much other than complicate the installation
> process.

<listitem>
	<para>
		The following changes can be specified in any condor configuration file:
	</para>
	<para>
		Specify the location of the <command>condor .... [etc]

LKB
Comment 6 Lana Brindley 2008-12-04 23:59:06 EST
(In reply to comment #2)
> From Rob's "1" above - yes add the following to step 1 - perhaps in the hint
> box:
> 
> The keys required are NOT the AWS keys needed elsewhere. Generate public and
> private keys using openssl:
> 
> 1. openssl genrsa -out private_key 1024
> 2. openssl rsa -in private_key -out public_key -puboutrs

<note>
	<para>
		These keys are generated using openssl, and are not the same as the AWS keys needed elsewhere.
	</para>
</note>

LKB
Comment 7 Lana Brindley 2008-12-05 00:01:12 EST
(In reply to comment #3)
> In response to Rob's points in 2 above:
> 
> True changes can go into either configuration file but we should say that and
> perhaps make a recommendation. (Remembering that elsewhere we recommend few
> changes to the /etc/condor/condor_config).
> 
> The changes described in the following steps (2-5) should be made to a condor
> configuration file. It is recommended to add these variables to the local
> configuration (/var/lib/condor/condor_config/local).

<para>
	The following changes can be specified in any condor configuration file, however it is recommended that they are added to the local configuration file at <filename>/var/lib/condor/condor_config/local</filename>:
</para>
<para>
	Specify the location of the <command>condor_sta...[etc]

LKB

Note You need to log in before you can comment on or make changes to this bug.