Bug 473107 - Segmentation fault after dialling
Segmentation fault after dialling
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: ekiga (Show other bugs)
rawhide
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-26 10:33 EST by Steve Hill
Modified: 2008-12-28 07:53 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-28 07:53:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Backtrace (43.31 KB, text/plain)
2008-11-26 10:33 EST, Steve Hill
no flags Details

  None (edit)
Description Steve Hill 2008-11-26 10:33:30 EST
Created attachment 324735 [details]
Backtrace

Description of problem:
I get a segmentation fault after dialling.

Version-Release number of selected component (if applicable):
ekiga-3.0.1-4.fc10.i386

Steps to Reproduce:
1. Dial sip:echo@pabx.nexusuk.org
2. Call connects and starts playing audio
3. About half a second after connecting Ekiga blows up with a segmentation fault
  
Actual results:
Ekiga crashes

Expected results:
Shouldn't crash :)

Additional info:
Comment 1 Peter Robinson 2008-11-26 17:23:02 EST
Can you run ekiga from a terminal with the following debug options "ekiga -d5 -u4"
Comment 2 Steve Hill 2008-11-27 05:21:03 EST
This seems to be related to the video support: I don't have a webcam, so my video input device is set to "Moving Logo".  Disabling all the video codecs (theora and h261) made the problem go away.

However, I have just tried turning the codecs back on and it no longer crashes.  I can't even seem to reproduce this problem after clearing all the Ekiga config out of gconf and reconfiguring from scratch. :(
Comment 3 Peter Robinson 2008-11-27 05:36:16 EST
Nice. I like those sort of fixes :-) There was an issue with libv4l and ekiga with large stack spaces or something like that which was casuing crashes. I noticed a couple of new versions of libv4l make their way through in recent updates so maybe they helped. I'll leave this open for a couple of weeks in case it pops up for others.
Comment 4 Steve Hill 2008-11-27 05:50:21 EST
> Nice. I like those sort of fixes

I don't - they leave me with the feeling that the problem is going to come back unexpectedly at some point and bite me. :)

I don't think I've done any updates since reporting the bug, although I have rebooted, which would mean that previously installed updates to the the X server, etc. will have come into effect.

Oh well, I'll keep my fingers crossed that it stays fixed - thanks for looking at it anyway :)
Comment 5 Peter Robinson 2008-12-18 09:52:12 EST
Hi Steve, have you seen any further issues with segfaults?
Comment 6 Steve Hill 2008-12-28 07:53:38 EST
No, I think this can be closed for now, thanks.

Note You need to log in before you can comment on or make changes to this bug.