Bug 473139 - system-config-services-0.99.28-1.fc10 (noarch) hangs x86_64 system
system-config-services-0.99.28-1.fc10 (noarch) hangs x86_64 system
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: system-config-services (Show other bugs)
10
x86_64 Linux
medium Severity urgent
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-26 13:54 EST by steve
Modified: 2008-12-12 05:46 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-12 05:46:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output following command as root #system-config-services (1.96 KB, text/plain)
2008-12-07 22:39 EST, Kelly-Rand
no flags Details
output from /sbin/service --status-all as "su" not "su -" (4.99 KB, text/plain)
2008-12-11 20:56 EST, Kelly-Rand
no flags Details

  None (edit)
Description steve 2008-11-26 13:54:44 EST
Description of problem:
When clicking Services from System -> Administration menus the Services GUI begins to load and then hangs completely locking up the system.  No combo of keys/buttons will cleanly shut down, a hard power down is required to recover.

Version-Release number of selected component (if applicable):
system-config-services-0.99.28-1.fc10 (noarch)

How reproducible:
100%

Steps to Reproduce:
1.  Open System menu on top bar
2.  Goto Administration menu
3.  Click Services
  
Actual results:
Hung system

Expected results:
Functioning app

Additional info:
3 attempts on a fresh install after performing all updates results in this issue.  Did not test Services before performing updates.
Comment 1 Kelly-Rand 2008-12-07 22:29:50 EST
I have the same symptoms. I will attach the output of the system-config-services command issued in a terminal.
Comment 2 Kelly-Rand 2008-12-07 22:39:20 EST
Created attachment 326076 [details]
Output following command as root #system-config-services
Comment 3 Kelly-Rand 2008-12-07 22:48:30 EST
I am running F10 x86-64. The service GUI command worked till a major update on this same date. I note that dBus was included in the update. 
I installed F10 from the release DVD image.
Comment 4 Tomas Hoger 2008-12-08 09:44:42 EST
(In reply to comment #3)
> I am running F10 x86-64. The service GUI command worked till a major update on
> this same date. I note that dBus was included in the update. 
> I installed F10 from the release DVD image.

The error message in the output you have attached is due to a recent dbus update (see bug #475203), and is probably unrelated to the original report, which pre-dates dbus update by almost 2 weeks.
Comment 5 Kelly-Rand 2008-12-08 15:08:35 EST
So will you link this to bug #475203, or at least the output I posted or is that no longer necessary?
Comment 6 Kelly-Rand 2008-12-08 15:21:27 EST
After reviewing bugs #475200 and #475203 I think this post more closely matches my symptoms which are that system-config-services will not launch either from the commandline or from the GUI launcher, whether by root or regular user. The other posts describe a dBus problem that may be associated with or the cause of my symptoms but I a regular user would not know that.
Comment 7 Klaus Munsteiner 2008-12-10 13:12:49 EST
I have got two x86_64 systems. 

The fault is in the one SINCE the large rpm-update from Sunday 2008-12-07.
In the other I made no update, It's working without any error.

There MUST BE anything in the rpms from Sunday, that blocks the system-config-services.
Comment 8 Nils Philippsen 2008-12-11 09:53:52 EST
All (except the original reporter): your problem is described in bug #475203 and has been fixed since then.

Steve, as I can't recall doing anything in system-config-services which should be able to lock up your machine, I guess that one of the init scripts which get called causes this somehow. Do you see the same problem if you run e.g. the command "/sbin/service --status-all" as root?
Comment 9 steve 2008-12-11 10:28:09 EST
(In reply to comment #8)
> All (except the original reporter): your problem is described in bug #475203
> and has been fixed since then.
> 
> Steve, as I can't recall doing anything in system-config-services which should
> be able to lock up your machine, I guess that one of the init scripts which get
> called causes this somehow. Do you see the same problem if you run e.g. the
> command "/sbin/service --status-all" as root?

Unfortunately I have been forced to wipe that machine due to the system hard locking during random tasks.  My issue may have very well been the same as the others seeing as I never opened system services until AFTER I did the updates.  I will not be installing F10 back on this machine until it/the kernel matures a bit more.  I never had any hard locking issues on F9...
Comment 10 Jan Teichmann 2008-12-11 11:54:01 EST
/usr/bin/system-config-services
ERROR:dbus.proxies:Introspect error on :1.59:/org/fedoraproject/Config/Services/ServiceHerders/SysVServiceHerder: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.AccessDenied: A security policy in place prevents this sender from sending this message to this recipient, see message bus configuration file (rejected message had interface "org.freedesktop.DBus.Introspectable" member "Introspect" error name "(unset)" destination ":1.59")
Traceback (most recent call last):
  File "/usr/bin/system-config-services", line 945, in <module>
    GUI (use_dbus = use_dbus).run ()
  File "/usr/bin/system-config-services", line 900, in __init__
    self.serviceherders.append (cls (bus = self._bus))
  File "/usr/lib/python2.5/site-packages/scservices/dbus/proxy/serviceherders.py", line 53, in __init__
    for service_name in self.list_services ():
  File "/usr/lib/python2.5/site-packages/slip/dbus/polkit.py", line 48, in enable_proxy_wrapper
    return func (*p, **k)
  File "/usr/lib/python2.5/site-packages/scservices/dbus/proxy/serviceherders.py", line 66, in list_services
    return self.dbus_object.list_services (dbus_interface = "org.fedoraproject.Config.Services.ServiceHerder")
  File "/usr/lib/python2.5/site-packages/dbus/proxies.py", line 68, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.5/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.5/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.AccessDenied: A security policy in place prevents this sender from sending this message to this recipient, see message bus configuration file (rejected message had interface "org.fedoraproject.Config.Services.ServiceHerder" member "list_services" error name "(unset)" destination ":1.59")
Comment 11 JX 2008-12-11 14:01:23 EST
[jumbox@jxlnb ~]$ cat /etc/fedora-release 
Fedora release 10 (Cambridge)
[jumbox@jxlnb ~]$ uname -r
2.6.27.7-134.fc10.x86_64
[jumbox@jxlnb ~]$ rpm -q dbus
dbus-1.2.8-1.fc10.x86_64
[jumbox@jxlnb ~]$ rpm -q system-config-services
system-config-services-0.99.28-3.fc10.noarch
[jumbox@jxlnb ~]$ /usr/bin/system-config-services 
Traceback (most recent call last):
  File "/usr/bin/system-config-services", line 945, in <module>
    GUI (use_dbus = use_dbus).run ()
  File "/usr/bin/system-config-services", line 900, in __init__
    self.serviceherders.append (cls (bus = self._bus))
  File "/usr/lib/python2.5/site-packages/scservices/dbus/proxy/serviceherders.py", line 53, in __init__
    for service_name in self.list_services ():
  File "/usr/lib/python2.5/site-packages/slip/dbus/polkit.py", line 48, in enable_proxy_wrapper
    return func (*p, **k)
  File "/usr/lib/python2.5/site-packages/scservices/dbus/proxy/serviceherders.py", line 66, in list_services
    return self.dbus_object.list_services (dbus_interface = "org.fedoraproject.Config.Services.ServiceHerder")
  File "/usr/lib/python2.5/site-packages/dbus/proxies.py", line 68, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.5/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.5/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.AccessDenied: A security policy in place prevents this sender from sending this message to this recipient, see message bus configuration file (rejected message had interface "org.freedesktop.PolicyKit" member "IsSystemBusNameAuthorized" error name "(unset)" destination ":1.65")
Comment 12 Kelly-Rand 2008-12-11 15:12:20 EST
I have two machines running F10. One 64bit and the other 32. Once I get the latest dbus updates from Koji on the 64bit machine and the system-config-services updates from updates-testing on the 32bit machine, I will provide the output you ask for.
Comment 13 Kelly-Rand 2008-12-11 20:53:34 EST
I have updated dbus on F10x86-64 to the latest Koji:

dbus-1.2.8-1.fc10.x86_64.rpm
dbus-devel-1.2.8-1.fc10.x86_64.rpm
dbus-glib-0.76-3.fc10.x86_64.rpm
dbus-libs-1.2.6-1.fc10.i386.rpm
dbus-libs-1.2.8-1.fc10.x86_64.rpm
dbus-python-0.83.0-3.fc10.x86_64.rpm
dbus-x11-1.2.8-1.fc10.x86_64.rpm
python-slip-dbus-0.1.15-1.fc10.noarch.rpm

system-config-services-0.99.28-3.fc10.noarch.rpm

PackageKit-0.3.11-4.fc10.x86_64.rpm
PackageKit-glib-0.3.11-4.fc10.x86_64.rpm
PackageKit-gstreamer-plugin-0.3.11-4.fc10.x86_64.rpm
PackageKit-udev-helper-0.3.11-4.fc10.x86_64.rpm
PackageKit-yum-0.3.11-4.fc10.x86_64.rpm
PackageKit-yum-plugin-0.3.11-4.fc10.x86_64.rpm

When I start s-c-services I get:

# system-config-services
Traceback (most recent call last):
  File "/usr/bin/system-config-services", line 945, in <module>
    GUI (use_dbus = use_dbus).run ()
  File "/usr/bin/system-config-services", line 900, in __init__
    self.serviceherders.append (cls (bus = self._bus))
  File "/usr/lib/python2.5/site-packages/scservices/dbus/proxy/serviceherders.py", line 53, in __init__
    for service_name in self.list_services ():
  File "/usr/lib/python2.5/site-packages/slip/dbus/polkit.py", line 48, in enable_proxy_wrapper
    return func (*p, **k)
  File "/usr/lib/python2.5/site-packages/scservices/dbus/proxy/serviceherders.py", line 66, in list_services
    return self.dbus_object.list_services (dbus_interface = "org.fedoraproject.Config.Services.ServiceHerder")
  File "/usr/lib/python2.5/site-packages/dbus/proxies.py", line 68, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.5/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.5/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.AccessDenied: A security policy in place prevents this sender from sending this message to this recipient, see message bus configuration file (rejected message had interface "org.freedesktop.PolicyKit" member "IsSystemBusNameAuthorized" error name "(unset)" destination ":1.45")

If I login to root "su -" then the service starts without output.
I will attach the output from /sbin/service --status-all

Jim
Comment 14 Kelly-Rand 2008-12-11 20:56:48 EST
Created attachment 326697 [details]
output from /sbin/service --status-all as "su" not "su -"

See the 12/11/08 post from jbk for associated information and system state.
Comment 15 Kelly-Rand 2008-12-11 21:19:09 EST
PolicyKit-0.9-4.fc10.x86_64.rpm                          | 173 kB     00:03     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating       : PolicyKit                                                1/2 
  Cleanup        : PolicyKit                                                2/2 
ERROR:dbus.proxies:Introspect error on :1.23:/org/freedesktop/PackageKit: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.AccessDenied: A security policy in place prevents this sender from sending this message to this recipient, see message bus configuration file (rejected message had interface "org.freedesktop.DBus.Introspectable" member "Introspect" error name "(unset)" destination ":1.23")

Updated:
  PolicyKit.x86_64 0:0.9-4.fc10    

I got the above output when I updated PolicyKit but now s-c-services starts in user mode from command line or GUI w/o output.
Comment 16 Nils Philippsen 2008-12-12 05:46:23 EST
Again: All (except Steve ;-), your problem is a different one, described in bug #475203 and very likely fixed already with the latest (testing) updates of system-config-services and PolicyKit.

Steve, ...

(In reply to comment #9)
> (In reply to comment #8)
> > All (except the original reporter): your problem is described in bug #475203
> > and has been fixed since then.
> > 
> > Steve, as I can't recall doing anything in system-config-services which should
> > be able to lock up your machine, I guess that one of the init scripts which get
> > called causes this somehow. Do you see the same problem if you run e.g. the
> > command "/sbin/service --status-all" as root?
> 
> Unfortunately I have been forced to wipe that machine due to the system hard
> locking during random tasks.  My issue may have very well been the same as the
> others seeing as I never opened system services until AFTER I did the updates. 
> I will not be installing F10 back on this machine until it/the kernel matures a
> bit more.  I never had any hard locking issues on F9...

... in that case I'll assume your problem is not caused by system-config-services and close this as WORKSFORME for now.

Note You need to log in before you can comment on or make changes to this bug.