Bug 47320 - RPM Database corrupted
RPM Database corrupted
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
6.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-04 14:04 EDT by Wayne Walker
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-04 14:04:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wayne Walker 2001-07-04 14:04:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3-1-ww i586)

Description of problem:
iInstalled RH6.2 zoot "Everything".
Grabbed (keep a local mirror) updates.redhat.com/6.2/en/os/i386
  Upgraded popt, rpm, db3.
  Upgraded the rest of the packages.
Installed sendmail and named from latest source hand built (did not remove
rpms for sendmail due to
depencies, just overwrote the 5 executables).

3 weeks later (after "burn-in" ready to go production tomorrow ), today,
the 4th.
   Get dumb idea to use Ximian/Red Carpet to update the machine

Copied the /var/cache/red-carpet directory from home to the server.
  rpm -U *rpm
    Had to rpm -e kdebase and a few others
  ran red-carpet
    Installed all the redhat 6.2 updates (except bind, anonftpd, wu-ftpd)
    Decided (stupid idea number 2) to update the Gnome stuff.
    Installed about 6 packages, then, right before the "Finished" point,
after all packages appeared to
be installed, the app seg faulted.
  rpm --rebuilddb runs for a few seconds and seg faults.


How reproducible:
Sometimes

Steps to Reproduce:
1.Installed RH6.2 zoot "Everything".
Grabbed (keep a local mirror) updates.redhat.com/6.2/en/os/i386
  Upgraded popt, rpm, db3.
  Upgraded the rest of the packages.
Installed sendmail and named from latest source hand built (did not remove
rpms for sendmail due to
depencies, just overwrote the 5 executables).

3 weeks later (after "burn-in" ready to go production tomorrow ), today,
the 4th.
   Get dumb idea to use Ximian/Red Carpet to update the machine

Copied the /var/cache/red-carpet directory from home to the server.
  rpm -U *rpm
    Had to rpm -e kdebase and a few others
  ran red-carpet
    Installed all the redhat 6.2 updates (except bind, anonftpd, wu-ftpd)
    Decided (stupid idea number 2) to update the Gnome stuff.
    Installed about 6 packages, then, right before the "Finished" point,
after all packages appeared to
be installed, the app seg faulted.
  rpm --rebuilddb runs for a few seconds and seg faults.

2.
3.
	

Additional info:
Comment 1 Jeff Johnson 2001-07-04 14:34:42 EDT
You should be fixed now, packages.rpm returned in private e-mail.
Reopen this bug if you need more help.

Note You need to log in before you can comment on or make changes to this bug.