Bug 473212 - Makedumpfile -b Not Documented
Makedumpfile -b Not Documented
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kexec-tools (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Neil Horman
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 574305 970826
  Show dependency treegraph
 
Reported: 2008-11-27 00:34 EST by CAI Qian
Modified: 2018-04-11 10:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 574305 (view as bug list)
Environment:
Last Closed: 2010-03-17 10:28:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description CAI Qian 2008-11-27 00:34:54 EST
Description of problem:
$ makedumpfile --help

Usage:
  Creating DUMPFILE:
  # makedumpfile    [-c|-E] [-d DL] [-x VMLINUX|-i VMCOREINFO] VMCORE DUMPFILE

  Outputting the dump data in the flattened format to the standard output:
  # makedumpfile -F [-c|-E] [-d DL] [-x VMLINUX|-i VMCOREINFO] VMCORE

  Rearranging the dump data in the flattened format to a readable DUMPFILE:
  # makedumpfile -R DUMPFILE

  Generating VMCOREINFO:
  # makedumpfile -g VMCOREINFO -x VMLINUX


  Creating DUMPFILE of Xen:
  # makedumpfile -E [--xen-syms XEN-SYMS|--xen-vmcoreinfo VMCOREINFO] VMCORE DUMPFILE

  Generating VMCOREINFO of Xen:
  # makedumpfile -g VMCOREINFO --xen-syms XEN-SYMS


Available options:
  [-c]:
      Compress dump data by each page.
      A user cannot specify this option with -E option, because the ELF format
      does not support compressed data.
      THIS IS ONLY FOR THE CRASH UTILITY.

  [-d DL]:
      Specify the type of unnecessary page for analysis.
      Pages of the specified type are not copied to DUMPFILE. The page type
      marked in the following table is excluded. A user can specify multiple
      page types by setting the sum of each page type for Dump_Level (DL).
      The maximum of Dump_Level is 31.
      Note that Dump_Level for Xen dump filtering is 0 or 1.

      Dump  |  zero   cache   cache    user    free
      Level |  page   page    private  data    page
     -------+---------------------------------------
         0  |
         1  |  X
         2  |         X
         4  |         X       X
         8  |                          X
        16  |                                  X
        31  |  X      X       X        X       X

  [-E]:
      Create DUMPFILE in the ELF format.
      This option cannot be specified with -c option, because the ELF
      format does not support compressed data.

  [-x VMLINUX]:
      Specify the first kernel's VMLINUX to analyze the first kernel's
      memory usage.
      The page size of the first kernel and the second kernel should match.

  [-i VMCOREINFO]:
      Specify VMCOREINFO instead of VMLINUX for analyzing the first kernel's
      memory usage.
      VMCOREINFO should be made beforehand by makedumpfile with -g option,
      and it contains the first kernel's information. If Dump_Level is 2 or
      more and [-x VMLINUX] is not specified, this option is necessary.

  [-g VMCOREINFO]:
      Generate VMCOREINFO from the first kernel's VMLINUX.
      VMCOREINFO must be generated on the system that is running the first
      kernel. With -i option, a user can specify VMCOREINFO generated on the
      other system that is running the same first kernel. [-x VMLINUX] must
      be specified.

  [-F]:
      Output the dump data in the flattened format to the standard output
      for transporting the dump data by SSH.
      Analysis tools cannot read the flattened format directly. For analysis,
      the dump data in the flattened format should be rearranged to a readable
      DUMPFILE by -R option.

  [-R]:
      Rearrange the dump data in the flattened format from the standard input
      to a readable DUMPFILE.

  [--xen-syms XEN-SYMS]:
      Specify the XEN-SYMS to analyze Xen's memory usage.

  [--xen-vmcoreinfo VMCOREINFO]:
      Specify the VMCOREINFO of Xen to analyze Xen's memory usage.

  [-X]:
      Exclude all the user domain pages from Xen kdump's VMCORE, and extract
      the part of Xen and domain-0.

  [--message-level ML]:
      Specify the message types.
      Users can restrict output printed by specifying Message_Level (ML) with
      this option. The message type marked with an X in the following table is
      printed. For example, according to the table, specifying 7 as ML means
      progress indicator, common message, and error message are printed, and
      this is a default value.
      Note that the maximum value of message_level is 31.

      Message | progress    common    error     debug     report
      Level   | indicator   message   message   message   message
     ---------+------------------------------------------------------
            0 |
            1 |     X
            2 |                X
            4 |                          X
          * 7 |     X          X         X
            8 |                                    X
           16 |                                              X
           31 |     X          X         X         X         X

  [-D]:
      Print debugging message.

  [-f]:
      Overwrite DUMPFILE even if it already exists.

  [-h]:
      Show help message.

  [-v]:
      Show the version of makedumpfile.

  VMLINUX:
      This is a pathname to the first kernel's vmlinux.
      This file must have the debug information of the first kernel to analyze
      the first kernel's memory usage.

  VMCORE:
      This is a pathname to the first kernel's memory core image.
      This argument is generally /proc/vmcore.

  DUMPFILE:
      This is a pathname to a file created by this command.

  XEN-SYMS:
      This is a pathname to the xen-syms.
      This file must have the debug information of Xen to analyze
      Xen's memory usage.


# makedumpfile -b
makedumpfile: option requires an argument -- 'b'
Commandline parameter is invalid.
Try `makedumpfile --help' for more information.

# makedumpfile -b 1 vmcore vmcore-new
[  0 %]
...

# echo $?
0

Version-Release number of selected component (if applicable):
kexec-tools-2.0.0-2.fc10.x86_64

How reproducible:
always

Actual results:
-b works, and returns code 0.

Expected results:
Should return code other than 0.
Comment 1 Matěj Cepl 2008-11-28 14:49:22 EST
There is nothing to triage here.

Switching to ASSIGNED so that developers have responsibility to do whatever they want to do with it.
Comment 2 Matěj Cepl 2008-11-28 15:07:12 EST
Note, yes I can fully reproduce here.
Comment 3 Neil Horman 2008-12-01 11:12:04 EST
https://sourceforge.net/tracker/index.php?func=detail&aid=2371921&group_id=178938&atid=887141

Submitted upstream, and fixed in 2.0.0-6.  Thanks!
Comment 4 Bug Zapper 2009-06-09 05:57:12 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Neil Horman 2010-03-17 10:28:44 EDT
https://sourceforge.net/tracker/?func=detail&aid=2971978&group_id=178938&atid=887141

I've submitted a patch upstream to include the needed documentation.  I'll pull it into rawhide with the next makedumpfile update from upstream

Note You need to log in before you can comment on or make changes to this bug.