This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 473214 - missing dependency on x86_64 architecture
missing dependency on x86_64 architecture
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: wine (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-27 01:12 EST by Warren Spain
Modified: 2008-11-28 11:36 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-28 11:36:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Spain 2008-11-27 01:12:17 EST
Description of problem:
Package 'wine' as installed with 'yum -y install wine' is missing a dependency, causing applications which use sound inside wine to block the sound card. 

Version-Release number of selected component (if applicable):
Fedora Release 10 (Cambridge), x86_64; wine.i386 1.1.7-1.fc10

How reproducible:
Install wine, configure it to use alsa as default sound output, use any application inside wine that requires sound, then try doing anything else on the system that requires sound.

Actual results:
PulseAudio should be performing software mixing of sounds, but due to missing dependency, wine takes over alsa directly, blocking the sound card.

Expected results:
PulseAudio should be performing software mixing of sounds, allowing everything to work as expected.

Additional info:

Machine Specs:
HP Pavilion dv8000 laptop, sound chip is Intel HDA, therefore hardware mixing is not possible.  The missing dependency is "alsa-plugins-pulseaudio.i386". Install that and wine can use PulseAudio and therefore not block the sound card.
Comment 1 Andreas Bierfert 2008-11-28 11:36:37 EST
Wine allows for different sound systems to be used. As wine does not have direct support for pulseaudio there are several ways to make wine use pulseaudio. For more information see the according readme in the fedora package. Thus this is not a missing dependency in wine (as it is not designed to work with pulseaudio primarily) and it cannot be forced upon users to have pulseaudio installed as wine will work fine with normal alsa setups.

If you feel strongly about pulseaudio support in wine contact the wine folks about it (but check the archives before as this was under discussion before).

Note You need to log in before you can comment on or make changes to this bug.