Bug 473243 - Crash on connecting to my Jabber account
Crash on connecting to my Jabber account
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: telepathy-gabble (Show other bugs)
10
x86_64 Linux
medium Severity urgent
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-27 05:45 EST by Jan Kratochvil
Modified: 2009-06-14 17:50 EDT (History)
4 users (show)

See Also:
Fixed In Version: loudmouth-1.4.3-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-02 14:37:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kratochvil 2008-11-27 05:45:11 EST
Description of problem:
Tried Empaty and my <xmpp:lace@jankratochvil.net> account with no luck.

Version-Release number of selected component (if applicable):
telepathy-gabble-0.7.12-1.fc10.x86_64
empathy-2.24.1-1.fc10.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Run Empathy, enter new Jabber account with Login ID "lace@jankratochvil.net".
2. Run: GABBLE_PERSIST=1 GABBLE_DEBUG=all gdb /usr/libexec/telepathy-gabble
3. Enable the account in Empathy, click ->Available.
  
Actual results:
GABBLE_PERSIST=1 GABBLE_DEBUG=all gdb /usr/libexec/telepathy-gabble 
GNU gdb Fedora (6.8-29.fc10)
Copyright (C) 2008 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu"...
(gdb) r
Starting program: /usr/libexec/telepathy-gabble 
warning: "/usr/lib/debug/lib/modules/2.6.25.10-86.fc9.x86_64/vdso/vdso.so.debug": The separate debug info file has no debug info
(telepathy-gabble:16007): tp-glib-DEBUG: started version 0.7.12 (telepathy-glib version 0.7.17)
(telepathy-gabble:16007): tp-glib-DEBUG: tp_cm_param_setter_offset: account = "lace@jankratochvil.net"
(telepathy-gabble:16007): tp-glib-DEBUG: tp_cm_param_setter_offset: password = <hidden>
(telepathy-gabble:16007): tp-glib-DEBUG: parse_parameters: server not given, using default behaviour
(telepathy-gabble:16007): tp-glib-DEBUG: tp_cm_param_setter_offset: resource = "Telepathy"
(telepathy-gabble:16007): tp-glib-DEBUG: tp_cm_param_setter_offset: priority = 0 = 0x0
(telepathy-gabble:16007): tp-glib-DEBUG: parse_parameters: port not given, using default behaviour
(telepathy-gabble:16007): tp-glib-DEBUG: tp_cm_param_setter_offset: old-ssl = FALSE
(telepathy-gabble:16007): tp-glib-DEBUG: tp_cm_param_setter_offset: require-encryption = FALSE
(telepathy-gabble:16007): tp-glib-DEBUG: tp_cm_param_setter_offset: register = FALSE
(telepathy-gabble:16007): tp-glib-DEBUG: tp_cm_param_setter_offset: low-bandwidth = FALSE
(telepathy-gabble:16007): tp-glib-DEBUG: parse_parameters: https-proxy-server not given, using default behaviour
(telepathy-gabble:16007): tp-glib-DEBUG: tp_cm_param_setter_offset: https-proxy-port = 443 = 0x1bb
(telepathy-gabble:16007): tp-glib-DEBUG: tp_cm_param_setter_offset: fallback-conference-server = "conference.jabber.org"
(telepathy-gabble:16007): tp-glib-DEBUG: parse_parameters: stun-server not given, using default behaviour
(telepathy-gabble:16007): tp-glib-DEBUG: tp_cm_param_setter_offset: stun-port = 3478 = 0xd96
(telepathy-gabble:16007): tp-glib-DEBUG: tp_cm_param_setter_offset: ignore-ssl-errors = FALSE
(telepathy-gabble:16007): tp-glib-DEBUG: parse_parameters: alias not given, using default behaviour
(telepathy-gabble:16007): tp-glib-DEBUG: tp_base_connection_class_init: Initializing (TpBaseConnectionClass *)0x69d6a0
** (telepathy-gabble:16007): DEBUG: gabble_connection_class_init: Initializing (GabbleConnectionClass *)0x69f600
(telepathy-gabble:16007): tp-glib-DEBUG: tp_presence_mixin_class_init: called.
(telepathy-gabble:16007): tp-glib-DEBUG: tp_base_connection_init: Initializing (TpBaseConnection *)0x6a60c0
** (telepathy-gabble:16007): DEBUG: gabble_connection_init: Initializing (GabbleConnection *)0x6a60c0
(telepathy-gabble:16007): tp-glib-DEBUG: tp_base_connection_constructor: Post-construction: (TpBaseConnection *)0x6a60c0
(telepathy-gabble:16007): tp-glib-DEBUG: tp_proxy_borrow_interface_by_id: 0x6a3120: org.freedesktop.DBus DBusGProxy is 0x6a3190
(telepathy-gabble:16007): tp-glib-DEBUG: tp_base_connection_constructor: Handle repo for type #0 at (nil)
(telepathy-gabble:16007): tp-glib-DEBUG: tp_base_connection_constructor: Handle repo for type #1 at 0x69f9e0
(telepathy-gabble:16007): tp-glib-DEBUG: tp_base_connection_constructor: Handle repo for type #2 at 0x69fa40
(telepathy-gabble:16007): tp-glib-DEBUG: tp_base_connection_constructor: Handle repo for type #3 at 0x696210
(telepathy-gabble:16007): tp-glib-DEBUG: tp_base_connection_constructor: Handle repo for type #4 at 0x69faa0
** (telepathy-gabble:16007): DEBUG: gabble_roomlist_manager_constructed: 0x69a050
(telepathy-gabble:16007): tp-glib-DEBUG: tp_base_connection_constructor: Channel manager #0 at 0x6a3400
(telepathy-gabble:16007): tp-glib-DEBUG: tp_base_connection_constructor: Channel manager #1 at 0x69a1e0
(telepathy-gabble:16007): tp-glib-DEBUG: tp_base_connection_constructor: Channel manager #2 at 0x69a050
(telepathy-gabble:16007): tp-glib-DEBUG: tp_base_connection_constructor: Channel manager #3 at 0x6a3470
(telepathy-gabble:16007): tp-glib-DEBUG: tp_base_connection_constructor: Channel manager #4 at 0x69a320
(telepathy-gabble:16007): tp-glib-DEBUG: tp_base_connection_constructor: Channel manager #5 at 0x6ad020
(telepathy-gabble:16007): tp-glib-DEBUG: tp_base_connection_constructor: Channel manager #6 at 0x6aa940
** (telepathy-gabble:16007): DEBUG: gabble_connection_constructor: Post-construction: (GabbleConnection *)0x6a60c0
(telepathy-gabble:16007): tp-glib-DEBUG: tp_presence_mixin_init: called.
(telepathy-gabble:16007): tp-glib-DEBUG: tp_base_connection_register: bus name org.freedesktop.Telepathy.Connection.gabble.jabber.lace_40jankratochvil_2enet_2fTelepathy
(telepathy-gabble:16007): tp-glib-DEBUG: tp_base_connection_register: object path /org/freedesktop/Telepathy/Connection/gabble/jabber/lace_40jankratochvil_2enet_2fTelepathy
** (telepathy-gabble:16007): DEBUG: _gabble_connection_connect: letting SRV lookup decide server and port
** (telepathy-gabble:16007): DEBUG: do_connect: calling lm_connection_open
Detaching after fork from child process 16014.
** (telepathy-gabble:16007): DEBUG: do_connect: lm_connection_open failed Failed to resolve server
(telepathy-gabble:16007): tp-glib-DEBUG: tp_base_connection_change_status: was 4294967295, now 2, for reason 2
(telepathy-gabble:16007): tp-glib-DEBUG: tp_base_connection_change_status: emitting status-changed to 2, for reason 2
** (telepathy-gabble:16007): DEBUG: gabble_roster_close_all: closing channels
** (telepathy-gabble:16007): DEBUG: gabble_im_factory_close_all: closing channels
** (telepathy-gabble:16007): DEBUG: connection_status_changed_cb: disconnected, closing room lists
** (telepathy-gabble:16007): DEBUG: gabble_roomlist_manager_close_all: 0x69a050
** (telepathy-gabble:16007): DEBUG: gabble_muc_factory_close_all: closing channels
** (telepathy-gabble:16007): DEBUG: gabble_private_tubes_factory_close_all: closing 1-1 tubes channels
** (telepathy-gabble:16007): DEBUG: gabble_media_factory_close_all: closing channels
** (telepathy-gabble:16007): DEBUG: connection_shut_down: closed; emitting DISCONNECTED
(telepathy-gabble:16007): tp-glib-DEBUG: connection_shutdown_finished_cb: dereferenced connection
** (telepathy-gabble:16007): DEBUG: gabble_connection_dispose: called
** (telepathy-gabble:16007): DEBUG: gabble_bytestream_factory_dispose: dispose called
** (telepathy-gabble:16007): DEBUG: gabble_disco_dispose: dispose called
** (telepathy-gabble:16007): DEBUG: gabble_disco_finalize: called with 0x6aaa00
** (telepathy-gabble:16007): DEBUG: gabble_request_pipeline_dispose: disposing request-pipeline
** (telepathy-gabble:16007): DEBUG: gabble_vcard_manager_dispose: 0x6a34e0
** (telepathy-gabble:16007): DEBUG: gabble_vcard_manager_finalize: 0x6a34e0
** (telepathy-gabble:16007): DEBUG: gabble_presence_cache_dispose: dispose called
** (telepathy-gabble:16007): DEBUG: gabble_presence_cache_finalize: called with 0x69fb00
** (telepathy-gabble:16007): DEBUG: gabble_roster_dispose: dispose called
** (telepathy-gabble:16007): DEBUG: gabble_roster_close_all: closing channels
** (telepathy-gabble:16007): DEBUG: gabble_roster_finalize: called with 0x6a3400
** (telepathy-gabble:16007): DEBUG: gabble_im_factory_dispose: dispose called
** (telepathy-gabble:16007): DEBUG: gabble_roomlist_manager_dispose: running
** (telepathy-gabble:16007): DEBUG: gabble_roomlist_manager_close_all: 0x69a050
** (telepathy-gabble:16007): DEBUG: gabble_muc_factory_dispose: dispose called
** (telepathy-gabble:16007): DEBUG: gabble_muc_factory_close_all: closing channels
** (telepathy-gabble:16007): DEBUG: gabble_private_tubes_factory_dispose: dispose called
** (telepathy-gabble:16007): DEBUG: gabble_private_tubes_factory_close_all: closing 1-1 tubes channels
** (telepathy-gabble:16007): DEBUG: gabble_media_factory_dispose: dispose called
** (telepathy-gabble:16007): DEBUG: gabble_media_factory_close_all: closing channels
** (telepathy-gabble:16007): DEBUG: gabble_olpc_gadget_manager_dispose: running
** (telepathy-gabble:16007): DEBUG: gabble_olpc_gadget_manager_close_all: 0x6aa940
(telepathy-gabble:16007): tp-glib-DEBUG: tp_proxy_signal_connection_lost_weak_ref: 0x6a3270: lost weak ref to 0x69f9e0
(telepathy-gabble:16007): tp-glib-DEBUG: tp_proxy_signal_connection_lost_weak_ref: 0x6a32e0: lost weak ref to 0x69fa40
(telepathy-gabble:16007): tp-glib-DEBUG: tp_proxy_signal_connection_lost_weak_ref: 0x6a3350: lost weak ref to 0x69faa0
** (telepathy-gabble:16007): DEBUG: gabble_connection_finalize: called with 0x6a60c0
(telepathy-gabble:16007): tp-glib-DEBUG: tp_contacts_mixin_finalize: 0x6a60c0
(telepathy-gabble:16007): tp-glib-DEBUG: tp_presence_mixin_finalize: 0x6a60c0
telepathy-gabble: asyncns.c:1101: asyncns_isdone: Assertion `q->asyncns == asyncns' failed.

Program received signal SIGABRT, Aborted.
0x0000003f61632ed5 in raise (sig=<value optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
64	  return INLINE_SYSCALL (tgkill, 3, pid, selftid, sig);
(gdb) bt
#0  0x0000003f61632ed5 in raise (sig=<value optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#1  0x0000003f61634a43 in abort () at abort.c:88
#2  0x0000003f6162bec9 in __assert_fail (assertion=0x331841470d "q->asyncns == asyncns", file=0x3318414703 "asyncns.c", line=1101, 
    function=0x3318414af4 "asyncns_isdone") at assert.c:78
#3  0x000000331840e6ce in asyncns_isdone (asyncns=<value optimized out>, q=<value optimized out>) at asyncns.c:1101
#4  0x000000331840e442 in _lm_socket_resolver_done (source=<value optimized out>, condition=<value optimized out>, 
    data=<value optimized out>) at lm-socket.c:892
#5  0x00007ffff7d3479b in g_main_dispatch () at gmain.c:2144
#6  IA__g_main_context_dispatch (context=0x693d10) at gmain.c:2697
#7  0x00007ffff7d37f6d in g_main_context_iterate (context=0x693d10, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2778
#8  0x00007ffff7d3849d in IA__g_main_loop_run (loop=0x690420) at gmain.c:2986
#9  0x0000003d0467e116 in tp_run_connection_manager (prog_name=0x45f0dc "telepathy-gabble", version=0x45f8dc "0.7.12", 
    construct_cm=0x40ea80 <construct_cm>, argc=<value optimized out>, argv=<value optimized out>) at run.c:261
#10 0x0000003f6161e546 in __libc_start_main (main=0x40e9e0 <main>, argc=1, ubp_av=0x7fffffffd3c8, init=0x45efb0 <__libc_csu_init>, 
    fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fffffffd3b8) at libc-start.c:220
#11 0x000000000040e919 in _start ()
(gdb) info threads 
(gdb) bt full
#0  0x0000003f61632ed5 in raise (sig=<value optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
	pid = <value optimized out>
	selftid = <value optimized out>
#1  0x0000003f61634a43 in abort () at abort.c:88
	act = {__sigaction_handler = {sa_handler = 0x3f6196c860 <_IO_2_1_stderr_>, sa_sigaction = 0x3f6196c860 <_IO_2_1_stderr_>}, 
  sa_mask = {__val = {272217901518, 140737488342992, 1101, 140737488343232, 272217046070, 206158430232, 140737488343248, 140737488343024, 
      272216948744, 206158430256, 140737488343272, 6963696, 129, 6963680, 272220215808, 140737488344821}}, sa_flags = 1634961870, 
  sa_restorer = 0x3318414703 <lm_message_get_sub_type+59939>}
	sigs = {__val = {32, 0 <repeats 15 times>}}
#2  0x0000003f6162bec9 in __assert_fail (assertion=0x331841470d "q->asyncns == asyncns", file=0x3318414703 "asyncns.c", line=1101, 
    function=0x3318414af4 "asyncns_isdone") at assert.c:78
	buf = 0x6a41f0 "`�\226a?"
	errstr = "Unexpected error.\n"
#3  0x000000331840e6ce in asyncns_isdone (asyncns=<value optimized out>, q=<value optimized out>) at asyncns.c:1101
	__PRETTY_FUNCTION__ = "asyncns_isdone"
#4  0x000000331840e442 in _lm_socket_resolver_done (source=<value optimized out>, condition=<value optimized out>, 
    data=<value optimized out>) at lm-socket.c:892
	socket = <value optimized out>
	ans = <value optimized out>
	srv_ans = <value optimized out>
	err = <value optimized out>
	result = <value optimized out>
	__PRETTY_FUNCTION__ = "_lm_socket_resolver_done"
#5  0x00007ffff7d3479b in g_main_dispatch () at gmain.c:2144
No locals.
#6  IA__g_main_context_dispatch (context=0x693d10) at gmain.c:2697
No locals.
#7  0x00007ffff7d37f6d in g_main_context_iterate (context=0x693d10, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2778
	max_priority = 200
	timeout = 0
	some_ready = 1
	nfds = 2
	allocated_nfds = <value optimized out>
	fds = (GPollFD *) 0x69bb40
	__PRETTY_FUNCTION__ = "g_main_context_iterate"
#8  0x00007ffff7d3849d in IA__g_main_loop_run (loop=0x690420) at gmain.c:2986
	self = (GThread *) 0x69ba80
	__PRETTY_FUNCTION__ = "IA__g_main_loop_run"
#9  0x0000003d0467e116 in tp_run_connection_manager (prog_name=0x45f0dc "telepathy-gabble", version=0x45f8dc "0.7.12", 
    construct_cm=0x40ea80 <construct_cm>, argc=<value optimized out>, argv=<value optimized out>) at run.c:261
	fatal_mask = <value optimized out>
	connection = <value optimized out>
#10 0x0000003f6161e546 in __libc_start_main (main=0x40e9e0 <main>, argc=1, ubp_av=0x7fffffffd3c8, init=0x45efb0 <__libc_csu_init>, 
    fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fffffffd3b8) at libc-start.c:220
	result = <value optimized out>
	unwind_buf = {cancel_jmp_buf = {{jmp_buf = {4583344, 6341275974423807427, 4253936, 140737488344000, 0, 0, -6341275975388494397, 
        6376672821866792387}, mask_was_saved = 0}}, priv = {pad = {0x0, 0x0, 0x1, 0x40e9e0}, data = {prev = 0x0, cleanup = 0x0, 
      canceltype = 1}}}
	not_first_call = <value optimized out>
#11 0x000000000040e919 in _start ()
No symbol table info available.
(gdb) 

Expected results:
No crash.

Additional info:
Comment 1 Brian Pepple 2008-12-02 14:14:32 EST
I believe this should be fixed with 1.4.3-1.fc10.  Can you verify that this works for you (it's pending but should be going to testing soon)?

https://admin.fedoraproject.org/updates/loudmouth-1.4.3-1.fc10
Comment 2 Jan Kratochvil 2008-12-02 14:37:50 EST
Yes, thanks, confirming with loudmouth-1.4.3-1.fc10 it logs in.
(with the Google server it refuses TLS/SSL-required login but it either is not a bug or it is a different bug)
Comment 3 Matěj Cepl 2009-06-14 17:50:58 EDT
Somehow when I switched back and forth with requiring secure connection, I somehow managed to make it log-in to both jabber.cz and my personal ejabberd with TLS with loudmouth-1.4.3-5.fc11.x86_64

Note You need to log in before you can comment on or make changes to this bug.