This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 473248 - PHP built without expat
PHP built without expat
Status: CLOSED DUPLICATE of bug 473231
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-27 06:04 EST by Cliff Stanford
Modified: 2008-11-27 06:14 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-27 06:14:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
PHP Bug Tracker 45996 None None None Never

  None (edit)
Description Cliff Stanford 2008-11-27 06:04:52 EST
Description of problem:
There is a mistake in the build of php.  The flag --with-expat-dir=/usr should read --with-libexpat-dir=/usr.  This means that expat-type functions are built against libexpat2 which has known and reported bugs.

Version-Release number of selected component (if applicable):
PHP Version 5.2.6

How reproducible:
Use phpinfo().

Steps to Reproduce:
1. echo '<?php phpinfo();' | php | grep -i expat
  
Actual results:
Erroneous flag is displayed.

Expected results:
EXPAT Version => expat_2.0.1

Additional info:
http://bugs.php.net/bug.php?id=45996 refers to the libxml2 bug and how it affects php.
Comment 1 Joe Orton 2008-11-27 06:14:18 EST

*** This bug has been marked as a duplicate of bug 473231 ***

Note You need to log in before you can comment on or make changes to this bug.