Bug 473349 - Loading a very large image into Firefox is extremely slow
Loading a very large image into Firefox is extremely slow
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
10
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-27 17:03 EST by Denis Tumpic
Modified: 2018-04-11 12:07 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-28 02:37:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Denis Tumpic 2008-11-27 17:03:27 EST
Description of problem:
Loading a very large image into Firefox is extremely slow

Version-Release number of selected component (if applicable):
3.0.4

How reproducible:
Find a JPG that is about 3000x2000 pixels and 2.3 MB in size. Have it on your local file system.

The auto resizing should be OFF but if it isn't then it will be even slower.

Steps to Reproduce:
1. Point Firefox to the local image
2. "Watch the paint dry" ;-)
3. Scroll around until it pauses.
  
Actual results:
It loads and then it locks a bit... checking with top: the xorg process is at ~100% for a very long time... almost as if it is in a spin-lock of some sort.

Expected results:
It should load the image and one should be able to scroll around without any problems and pauses. The same image works fine by using both gimp 2.6 and gthumb 2.10.10.

Additional info:
I had Minefield3.0 compiled under F8 and it did not behave the same.

Non F10 package used:
NVIDIA-Linux-x86_64-177.82
Comment 1 Denis Tumpic 2008-11-27 17:06:56 EST
Right... this is on a M3N78-Pro, 8300 video ram set at 512MB , 4GB memory (including the 512 MB video ram), Quad Core Phenom 9950.
Comment 2 Matěj Cepl 2008-11-27 17:56:07 EST
OK, I am suspicious -- we had similar bug reports which were fixed by using nv driver. I know everything about nv's capabilities, so I am not surprised people want to use nvidia binary-only stuff, but could you please try to clean up your system of nvidia binary stuff (https://fedoraproject.org/wiki/Xorg/3rd_Party_Video_Drivers) and try to reproduce.

Also, if you are able to reproduce it, could we get URL with the particular image which makes you problems, please?

Thank you very much
Comment 4 Denis Tumpic 2008-11-27 18:26:08 EST
xorg is definitely loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so (nvidia proprietary driver) and I have full 3D support no problem.

I don't know the difference in how Firefox allocates video ram in comparison to gthumb and gimp for instance.

I am running gnome... BUT if I start a KDE app like k3b then the locking on Firefox starts as soon as I focus on the window regardless of page (default google page locks as well.) I am running with 8 workspaces and have for the last 13 years.
Comment 5 Denis Tumpic 2008-11-27 18:51:22 EST
Just tested it with the vesa driver and it is magnitudes faster so I guess this is a nvidia driver issue.
Comment 6 Matěj Cepl 2008-11-28 02:37:37 EST
I am really truly sorry, but we cannot help you. When checking with my intel (and intel driver) the image got loaded reasonably fast. 

If you would be able to reproduce this issue using only open source software, please, reopen this bug with the additional information, but in meantime I have no choice than to close this bug as CANTFIX (because we really cannot fix it).

For users who are experiencing problems installing, configuring, or using the unsupported 3rd party proprietary "nvidia" video driver, Nvidia provides indirect customer support via an online web based support forum.  Nvidia monitors these web forums for commonly reported problems and passes them on to Nvidia engineers for investigation.  Once they've isolated a particular problem, it is often fixed in a future video driver update.

The NVNews Nvidia Linux driver forum is located at:

    http://www.nvnews.net/vbulletin/forumdisplay.php?s=&forumid=14

Once you have reported this issue in the Nvidia web forums, others who may have experienced the particular problem may be able to assist.  If there is a real bug occuring, Nvidia will be able to determine this, and will likely resolve the issue in a future driver update for the operating system releases that they officially support.

While Red Hat does not support the proprietary nvidia driver, users requiring technical support may also find the various X.Org, XFree86, and Red Hat mailing lists helpful in finding assistance:

X.Org mailing lists:
    http://www.freedesktop.org/XOrg/XorgMailingLists

XFree86 mailing lists:
    http://www.xfree86.org/sos/lists.html

Red Hat mailing lists:
    https://listman.redhat.com/mailman/listinfo
Comment 7 Denis Tumpic 2008-11-28 10:40:27 EST
No problem. I was "more" after some hard evidence that it was indeed the nvidia driver and the vesa test that was an implicit result from me reading https://fedoraproject.org/wiki/Xorg/3rd_Party_Video_Drivers delivered that.

Thanks for Fedora *.

Note You need to log in before you can comment on or make changes to this bug.