Bug 473375 - <screen> & <programlisting> in tables overhang the right side of their cell in PDF
<screen> & <programlisting> in tables overhang the right side of their cell i...
Status: CLOSED DUPLICATE of bug 467654
Product: Publican
Classification: Community
Component: publican (Show other bugs)
2.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Fearn
Content Services Development
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-28 01:14 EST by Darrin Mison
Modified: 2010-11-23 22:58 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-30 16:55:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
example of output from pre-release publican (7.46 KB, image/png)
2008-11-30 16:56 EST, Jeff Fearn
no flags Details

  None (edit)
Description Darrin Mison 2008-11-28 01:14:49 EST
Description of problem:
<screen> & <programlisting> in table cells "overhang" to the right, either into the next cell or outside the table in PDF

Version-Release number of selected component (if applicable):
0.38

How reproducible:
everytime

Steps to Reproduce:
1.
<table><title>test table</title>
<tgroup align="left" cols="2" colsep="1" rowsep="1">
<thead><row><entry>Database</entry> <entry>JDBC Driver</entry></row></thead>
<tbody>
<row>
  <entry><screen>java -jar SomeJar.jar</screen></entry>
  <entry>some text here</entry>
</row>
<row>
  <entry>some text here</entry>
  <entry><programlisting language="java">someClass.someMethod();</programlisting></entry>
</row>
</tbody></tgroup></table>

2.
make clean pdf-en-US

Actual results:
The contents of both the <programlisting> and <screen> tags extend slighting beyond the righthand wall of their respective cells.  Screenshot attached.

Expected results:
The contents should be contained in each cell with even cell padding.
Comment 1 Jeff Fearn 2008-11-30 16:55:15 EST

*** This bug has been marked as a duplicate of bug 467654 ***
Comment 2 Jeff Fearn 2008-11-30 16:56:19 EST
Created attachment 325150 [details]
example of output from pre-release publican

Note You need to log in before you can comment on or make changes to this bug.