Bug 473390 - Insert->object->video and Insert->object->sound are never available
Insert->object->video and Insert->object->sound are never available
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-28 04:04 EST by Vivian Bian
Modified: 2008-12-08 07:56 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-08 07:56:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
a spreadsheet demo (8.25 KB, application/vnd.oasis.opendocument.spreadsheet)
2008-11-28 04:34 EST, Caolan McNamara
no flags Details
picture of it working (186.68 KB, image/png)
2008-12-01 03:36 EST, Caolan McNamara
no flags Details
raw video, lets make sure that this works (3.69 MB, application/ogg)
2008-12-01 03:37 EST, Caolan McNamara
no flags Details
video displayed on my machine (110.26 KB, image/png)
2008-12-01 05:00 EST, Vivian Bian
no flags Details
the situation when try to insert via the Insert->object->video (121.05 KB, image/png)
2008-12-01 05:02 EST, Vivian Bian
no flags Details
patch to totem to give us something we can use (3.60 KB, patch)
2008-12-05 10:44 EST, Caolan McNamara
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 434510 None None None Never
OpenOffice.org 96970 None None None Never

  None (edit)
Description Vivian Bian 2008-11-28 04:04:46 EST
Description of problem:
OOo can't insert sound and video object into document

Version-Release number of selected component (if applicable):
OOo-3.0.0-9.10.fc10.x86_64


How reproducible:
Always

Steps to Reproduce:
1.Launch the OOCalc or OOWriter
2.Click where you want to insert the file.
3.Choose Insert - > Object ->Sound/Video.
  
Actual results:
The Sound and Video item can not be used

Expected results:
The Sound and Video could be insert into document

Additional info:
In the old version of the openoffice,there is also this problem.Such as in f9,and rhel4 etc.
Comment 1 Caolan McNamara 2008-11-28 04:34:05 EST
Created attachment 324958 [details]
a spreadsheet demo

There might be some specific problems, but it should work for all formats that gstreamer supports. So if it plays in the supplied fedora totem it should play in OOo. Same should be true for F-9 and RHEL-5 (though there is a RHEL-5 gstreamer bug IIRC that is either fixed in 5.3 or scheduled for 5.4)
Comment 2 Caolan McNamara 2008-11-28 04:38:09 EST
So, does this document work for you ?
Comment 3 Vivian Bian 2008-11-30 21:13:01 EST
vbian->Caolan
what is the effort of this attachment?Could it play the sound or video?If so,this document seems not work for me,I can only see a graphic in the document.
Please provide more information about how to use this document.
Thank you!!
Comment 4 Caolan McNamara 2008-12-01 03:36:40 EST
Created attachment 325186 [details]
picture of it working

Yes, its an example that works for me. For me I just open it in calc, there is a video in it visible. Click on the video, and the play controls appear. Click play.

Attached is a screenshot of it in action.
Comment 5 Caolan McNamara 2008-12-01 03:37:51 EST
Created attachment 325187 [details]
raw video, lets make sure that this works

Attached is the raw video, can you play this video in totem ?
Comment 6 Vivian Bian 2008-12-01 05:00:20 EST
Created attachment 325196 [details]
video displayed on my machine

In the Totem,the video could be played well,but when insert it via the Insert->Movie and Sound,the video could be played in the document.If insert the video via the Insert->Object->Video,the option seems not available
Comment 7 Vivian Bian 2008-12-01 05:02:17 EST
Created attachment 325197 [details]
the situation when try to insert via the Insert->object->video

Is it the same in your machine?
Comment 8 Caolan McNamara 2008-12-01 08:09:56 EST
Ah, I see the "Can't insert sound and video into document" led me astray. We *can* insert sound and video, the problem is "insert->object->sound|video" is always greyed out so we can't ever use it.

I see a *number* of problems looking at what should happen from that menu.

a) These insert->object->sound and video are mechanisms (under unix) to make use of netscape/plugins to handle sound/video etc. But they only look in /usr/lib/netscape, they need to also look in /usr/lib/mozilla

b) They always look in /usr/lib, not in /usr/lib64 on multilib machines

c) It isn't 64bit clean, so wouldn't work on x86_64 anyway

d) And even with all of that, when those are fixed and e.g. totem-mozplugin is installed, then it still doesn't work and the helper app crashes.

Good bit of work to do here to make that "just work"
Comment 9 Caolan McNamara 2008-12-05 08:56:56 EST
An initial part of getting this working is http://qa.openoffice.org/issues/show_bug.cgi?id=434510
Comment 10 Caolan McNamara 2008-12-05 10:44:34 EST
Created attachment 325863 [details]
patch to totem to give us something we can use
Comment 11 Caolan McNamara 2008-12-06 11:36:58 EST
And that's the rest of what we need to get this working on our side.
Comment 12 Caolan McNamara 2008-12-08 07:56:31 EST
So in rawhide 3.0.1-12.3 this should work.

To see it working you need a mozilla plugin which supports video. The one it is designed to work for is the proprietary adobe flash plugin. So the menu entry should become enabled if adobe flash is installed.

But I've logged a patch against totem as https://bugzilla.redhat.com/show_bug.cgi?id=475187 which if it was applied would also provide a better test case for this

Note You need to log in before you can comment on or make changes to this bug.