Bug 473409 - iwl3945 is not re-enabled automatically following power failure
iwl3945 is not re-enabled automatically following power failure
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
10
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-28 06:42 EST by Stephen Rowles
Modified: 2009-11-10 19:39 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-10 19:39:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lshal output (147.18 KB, text/plain)
2009-03-05 14:49 EST, Stephen Rowles
no flags Details
dmesg (42.68 KB, text/plain)
2009-03-05 14:49 EST, Stephen Rowles
no flags Details
/var/log/messages (78.25 KB, text/plain)
2009-03-05 14:50 EST, Stephen Rowles
no flags Details

  None (edit)
Description Stephen Rowles 2008-11-28 06:42:53 EST
Description of problem:

Follow on bug from:

https://bugzilla.redhat.com/show_bug.cgi?id=455509

In Fedora 10 it is now possible to enable wireless after power failure however this does not happen automatically on boot; hence this bug.

During boot dmesg shows that the wireless card is off due to "rf kill switch" or possibly "hardward kill switch" (or similar, unfortunately I don't have the actual dmesg output to copy/paste from). Fedora 10 continues with boot and presents the desktop. When selecting the NetworkManager in the bottom right of the screen both Ethernet and Wireless networking are ticked, but no light is shown on the laptop which indicates that wireless is actually turned off. No wireless networks are listed and no connection attempts are made.

Using the NetworkManager disable and then re-enable wireless, this causes the card to wake up and become usable, wireless light is switched on and wireless networks are listed and can be connected to.

Version-Release number of selected component (if applicable):

Fedora 10, Live CD, KDE version.

How reproducible:


Steps to Reproduce:
1. Allow laptop to power fail
2. Attach power to laptop
3. Boot into Fedora 10 from Live CD.
  
Actual results:
Wireless is disabled, no light shown on the laptop, no wireless networks listed despite NetworkManager showing wireless as being enabled.

Expected results:
Wireless turned on, light shown on laptop indicating that wireless is working, wireless networks should be listed and should be able to connect to networks, no other intervention should be required.

Additional info:

Acer Aspire 5920 with Intel iwl3945 wireless card.
Comment 1 Matthias Saou 2008-12-22 13:05:17 EST
I've only got two comments :
 * Is this a firmware problem? I don't think so, so it would be best to update the report to be against the kernel.
 * Are you sure you don't have a button or key combo no enable/disable wireless? (and usually bluetooth at the same time)
Comment 2 Stephen Rowles 2008-12-22 13:48:40 EST
I originally raised this against the firmware component but have since realised that this is most likely a Network Manager bug, hence it currently being assigned to that component.

The problem is that following a power failure, the wireless card is not automatically re-enabled, despite the "Enable Wireless" check box being ticked when I right click on the Network Manager icon.

As reported above if I disable and then re-enable wireless networking then Network Manager is capable of switching the card back on and successfully connecting to a wireless network.

The bug here is that Network Manager should do one of 2 things that it isn't currently doing:

Either:
A) Re-enable wireless automatically.
or
B) Not tick the "Enable Wireless" check box in the menu if wireless is not actually enabled.

From my point of view as an end user either would be acceptable, but I think that A is probably the preferable solution in terms of making it easiest to use.

I do have key combos but they are completely irrelevant to this scenario as the problem is shown up simply through using the Network Manager software.
Comment 3 Matthias Saou 2008-12-24 10:45:27 EST
You forgot to reassign to the default owner when changing component. Doing that now.
Comment 4 Dan Williams 2009-02-14 16:33:22 EST
When this happens, can you grab /var/log/messages for me so I can see what NM is trying to do on bootup?  Also good would be the output of "dmesg" and "lshal".
Comment 5 Stephen Rowles 2009-03-05 14:47:16 EST
Apologies it has taken so long to get the re-create with diagnostics but I try not to let the laptop power fail ;)

I finally have re-create and grab the logs which I will attach. The following is what happens with in-line exerts from the log.

On boot wireless fails with the following is in /var/log/messages:

Mar  5 19:32:01 mini-manicminer NetworkManager: <info>  (wlan0): bringing up device.
Mar  5 19:32:01 mini-manicminer kernel: iwl3945 0000:06:00.0: PCI INT A -> GSI 19 (level, low) -> IRQ 19
Mar  5 19:32:01 mini-manicminer kernel: firmware: requesting iwlwifi-3945-1.ucode
Mar  5 19:32:01 mini-manicminer kernel: iwl3945: Radio disabled by HW RF Kill switch
Mar  5 19:32:01 mini-manicminer kernel: iwl3945 0000:06:00.0: PCI INT A disabled
Mar  5 19:32:01 mini-manicminer NetworkManager: <WARN>  nm_device_hw_bring_up(): (wlan0): device not up after timeout!
Mar  5 19:32:01 mini-manicminer NetworkManager: <info>  (wlan0): deactivating device (reason: 2).

Right clicking on the network manager icon shows both "Enable Networking" and "Enable Wireless" as ticked but I have no connectivity and the wireless light on the laptop is off.

If I disabling and enabling wireless via the network manager icon doesn't help:

Mar  5 19:37:26 mini-manicminer NetworkManager: <info>  (wlan0): device state change: 3 -> 2
Mar  5 19:37:26 mini-manicminer NetworkManager: <info>  (wlan0): deactivating device (reason: 0).
Mar  5 19:37:31 mini-manicminer NetworkManager: <WARN>  nm_device_wifi_set_enabled(): not in expected unavailable state!
Mar  5 19:37:31 mini-manicminer NetworkManager: <info>  (wlan0): bringing up device.                                    
Mar  5 19:37:31 mini-manicminer kernel: iwl3945 0000:06:00.0: PCI INT A -> GSI 19 (level, low) -> IRQ 19                
Mar  5 19:37:31 mini-manicminer kernel: iwl3945: Radio disabled by HW RF Kill switch                                    
Mar  5 19:37:31 mini-manicminer kernel: iwl3945 0000:06:00.0: PCI INT A disabled                                        
Mar  5 19:37:31 mini-manicminer NetworkManager: <WARN>  nm_device_hw_bring_up(): (wlan0): device not up after timeout!  

I then try disabling networking and enabling - this brings the wireless back to life and turns the light on on the laptop:

Mar  5 19:37:56 mini-manicminer NetworkManager: <info>  (wlan0): device state change: 1 -> 2
Mar  5 19:37:56 mini-manicminer NetworkManager: <info>  (wlan0): bringing up device.
Mar  5 19:37:56 mini-manicminer kernel: iwl3945 0000:06:00.0: PCI INT A -> GSI 19 (level, low) -> IRQ 19
Mar  5 19:37:57 mini-manicminer kernel: Registered led device: iwl-phy0:radio
Mar  5 19:37:57 mini-manicminer kernel: Registered led device: iwl-phy0:assoc
Mar  5 19:37:57 mini-manicminer kernel: Registered led device: iwl-phy0:RX
Mar  5 19:37:57 mini-manicminer kernel: Registered led device: iwl-phy0:TX
Mar  5 19:37:57 mini-manicminer kernel: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Mar  5 19:37:57 mini-manicminer NetworkManager: <info>  (wlan0): preparing device.
Mar  5 19:37:57 mini-manicminer NetworkManager: <info>  (wlan0): deactivating device (reason: 2).

I then disable and enable wireless again, and it finally starts correctly and associates with my wireless access point:

Mar  5 19:39:27 mini-manicminer NetworkManager: <WARN>  nm_device_wifi_set_enabled(): not in expected unavailable state!
Mar  5 19:39:27 mini-manicminer NetworkManager: <info>  (wlan0): device state change: 2 -> 3                            
Mar  5 19:39:27 mini-manicminer NetworkManager: <info>  (wlan0): supplicant interface state:  starting -> ready         
Mar  5 19:39:30 mini-manicminer NetworkManager: <info>  Activation (wlan0) starting connection 'Auto ManicMiner'        

Full /var/log/messages output, dmesg and lshal are attached.
Comment 6 Stephen Rowles 2009-03-05 14:49:24 EST
Created attachment 334194 [details]
lshal output
Comment 7 Stephen Rowles 2009-03-05 14:49:44 EST
Created attachment 334195 [details]
dmesg
Comment 8 Stephen Rowles 2009-03-05 14:50:09 EST
Created attachment 334196 [details]
/var/log/messages
Comment 9 Dan Williams 2009-04-08 21:55:03 EDT
When this happens, can you post the output of:

cat /sys/class/net/wlan0/device/rf_kill

and also:

nm-tool

and also:

dbus-send --system --print-reply --dest=org.freedesktop.Hal /org/freedesktop/Hal/devices/iwl_wlan_switch org.freedesktop.Hal.Device.KillSwitch.GetPower

and also:

dbus-send --system --print-reply --dest=org.freedesktop.Hal /org/freedesktop/Hal/devices/pci_8086_4222_rfkill_3945ABG_wlan
 org.freedesktop.Hal.Device.KillSwitch.GetPower
Comment 10 Dan Williams 2009-11-10 19:39:24 EST
Seems to be rfkill problems and is likely fixed by the latest NM update in updates-testing:

NetworkManager-0.7.1.998-1.fc11 has been pushed to the Fedora
11 testing repository.  If problems still persist, please make note of it in
this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager'.  You can provide feedback for this update
here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-10546  

Please re-open if it still happens with latest kernel and that NM update, thanks!

Note You need to log in before you can comment on or make changes to this bug.