Bug 47341 - gcc 2.96 fails to compile kernel 2.4.6 sg driver
Summary: gcc 2.96 fails to compile kernel 2.4.6 sg driver
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-04 21:35 UTC by Laurent CREPET
Modified: 2007-04-18 16:34 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-12 13:47:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Laurent CREPET 2001-07-04 21:35:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
[lct@tealc lct]$ rpm -qa | grep gcc
gcc-java-2.96-85
gcc-c++-2.96-85
gcc-chill-2.96-85
gcc-g77-2.96-85
gcc-2.96-85
gcc-objc-2.96-85


How reproducible:
Always

Steps to Reproduce:
1. make menuconfig
2. make dep
3. make bzImage

=> it fails on sg driver...
	

Actual Results:  gcc -D__KERNEL__
-I/home/lct/build/linux-kernel/2.4.x/include -Wall -Wstrict-prototypes
-Wno-trigraphs -O2 -fomit-frame-pointer -fno-strict-aliasing -pipe
-mpreferred-stack-boundary=2 -march=i686    -c -o sg.o sg.c
sg.c: In function `sg_proc_dressz_read':
sg.c:2567: Internal error: Segmentation fault.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[3]: *** [sg.o] Error 2
make[3]: Leaving directory
`/home/lct/build/linux-kernel/2.4.x/drivers/scsi'
make[2]: *** [first_rule] Error 2
make[2]: Leaving directory
`/home/lct/build/linux-kernel/2.4.x/drivers/scsi'
make[1]: *** [_subdir_scsi] Error 2
make[1]: Leaving directory `/home/lct/build/linux-kernel/2.4.x/drivers'
make: *** [_dir_drivers] Error 2


Expected Results:  ...compiling...

Additional info:

Comment 1 Jakub Jelinek 2001-07-12 09:56:59 UTC
Is it always reproducible on the same file/function?
If not, it is probably hardware problem, if yes, then please mail me exact
preprocessor output (add -save-temps to the above and attach here sg.i;
though AFAIK we are compiling 2.4.6's sg just fine here with that compiler).

Comment 2 Laurent CREPET 2001-07-12 12:36:37 UTC
Yes, it seems to be reproductible. I tried 3 or 4 to compile, than every try has
failed on sg.o !
That what I set:
> How reproducible:
> Always
when I submit the problem.

What kind of hardware problem do you think off ? Bad memory chip ?
I think I'll download and run memtest86 to check.

Comment 3 Laurent CREPET 2001-07-12 13:47:46 UTC
Done again from:
  - my old kernel tree
  - a new one, extracted from linux-2.4.6.tar.bz2 from www.kernel.org
  - a new one, made with 2.4.0 sources, plus all 2.4.1 to 2.4.6 patches
     (using scripts/patch_kernel <kernel tree path> <patches path>

All compile ! Don't understand.
I'll run memtest86 to check if it is something with bad memory chip.
The main problem is that I don't remember what was running when I tried to
compile the kernel, and the compilation failed... Don't remember if the system
was heavy loaded or not...




Note You need to log in before you can comment on or make changes to this bug.