Bug 473446 - [nvidia driver] FolderView stalls my computer
[nvidia driver] FolderView stalls my computer
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-28 10:41 EST by Linuxguy123
Modified: 2009-01-27 11:49 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-04 12:20:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Linuxguy123 2008-11-28 10:41:19 EST
Description of problem:  My computer slows and becomes unstable if I put a folderview widget on my desktop. 

Version-Release number of selected component (if applicable):

$ uname -a
Linux localhost.localdomain 2.6.27.5-117.fc10.i686 #1 SMP Tue Nov 18 12:19:59 EST 2008 i686 i686 i386 GNU/Linux

 yum list *kde*                                                                            
Loaded plugins: kmdl, priorities, refresh-packagekit                                                           
0 packages excluded due to repository priority protections                                                     
Installed Packages                                                                                             
PyKDE4.i386                                                 4.1.3-1.fc10                                    installed
kde-filesystem.noarch                                       4-20.fc10                                       installed
kde-settings.noarch                                         4.1-4.20081031svn.fc10                          installed
kde-settings-kdm.noarch                                     4.1-4.20081031svn.fc10                          installed
kdeaddons-atlantikdesigner.i386                             3.5.10-2.fc10                                   installed
kdeadmin.i386                                               7:4.1.3-1.fc10                                  installed
kdeartwork.i386                                             4.1.3-2.fc10                                    installed
kdeartwork-extras.i386                                      4.1.3-2.fc10                                    installed
kdeartwork-kxs.i386                                         4.1.3-2.fc10                                    installed
kdebase.i386                                                6:4.1.3-2.fc10                                  installed
kdebase-libs.i386                                           6:4.1.3-2.fc10                                  installed
kdebase-runtime.i386                                        4.1.3-1.fc10                                    installed
kdebase-runtime-libs.i386                                   4.1.3-1.fc10                                    installed
kdebase-workspace.i386                                      4.1.3-6.fc10                                    installed
kdebase-workspace-libs.i386                                 4.1.3-6.fc10                                    installed
kdebase3.i386                                               3.5.10-2.fc10                                   installed
kdebase3-libs.i386                                          3.5.10-2.fc10                                   installed
kdebase3-pim-ioslaves.i386                                  3.5.10-2.fc10                                   installed
kdegames.i386                                               6:4.1.3-1.fc10                                  installed
kdegames-libs.i386                                          6:4.1.3-1.fc10                                  installed
kdegames3.i386                                              3.5.10-2.fc10                                   installed
kdegames3-libs.i386                                         3.5.10-2.fc10                                   installed
kdegraphics.i386                                            7:4.1.3-2.fc10                                  installed
kdegraphics-libs.i386                                       7:4.1.3-2.fc10                                  installed
kdelibs.i386                                                6:4.1.3-3.fc10                                  installed
kdelibs-common.i386                                         6:4.1.3-3.fc10                                  installed
kdelibs3.i386                                               3.5.10-1.fc10                                   installed
kdemultimedia.i386                                          6:4.1.3-1.fc10                                  installed
kdemultimedia-extras-freeworld.i386                         6:3.5.10-1.fc8                                  installed
kdemultimedia-libs.i386                                     6:4.1.3-1.fc10                                  installed
kdenetwork.i386                                             7:4.1.3-1.fc10                                  installed
kdenetwork-libs.i386                                        7:4.1.3-1.fc10                                  installed
kdepim.i386                                                 6:4.1.3-1.fc10                                  installed
kdepim-libs.i386                                            6:4.1.3-1.fc10                                  installed
kdepimlibs.i386                                             4.1.3-1.fc10                                    installed
kdeplasma-addons.i386                                       4.1.3-1.fc10                                    installed
kdetoys.i386                                                7:4.1.3-1.fc10                                  installed
kdeutils.i386                                               6:4.1.3-1.fc10                                  installed
lockdev.i386                                                1.0.1-13.fc10                                   installed
lockdev-devel.i386                                          1.0.1-13.fc10                                   installed
solar-kde-theme.noarch                                      0.1.16-2.fc10                                   installed

How reproducible:

Every time.

Steps to Reproduce:
1. Install F10.  Put a panel on the bottom fo the desktop and another at the top.
2.Right click -> Add Widgets-> Folder View-> OK
  
Actual results:

The folderview widget appears and it shows the contents of my home folder as it should. 

Desktop gets wonky.  It slows way down and doesn't respond to mouse clicks without a huge time delay.  5 seconds or more.   Desktop icons get moved around.  The panels get messed up.  The top panel, which has taskmanager and pager on it, usually disappears.  THe bottom panel gets resized. I run it centered and it has application icons and widgets on it.   The app icons disappear.

The only way I can get my computer to work well again is to delete the folderview.  It takes about 2 minutes of pressing the red X to get it to disappear.  The video flashes several times to a white screen and then a blue screen when I am closing the folderview.

Expected results:

The folderview should just appear and be OK.  None of the other desktop elements should be disturbed.

Additional info:

1) I am not sure my installation always did this.  I think when I first installed it, folderview worked OK.  I didn't need any folderviews, so I removed them all and then didn't use them for a while.  When I tried to use them again, I had this behavior.  I am wondering if this isn't an initialization problem, ie if one deletes all folderviews and reboots and then tries to add one, you get this behavior.   That is just a guess.

These next 2 things might be unrelated, but I will mention them anyway:

2) Even when I don't install a folderview, my lower panel loses its width settings and the objects in the panel (icons and widgets) continually move around.

3) When I shut down, a message flashes breifly in a KDE like window about some desktopish process that doesn't want to shut down nicely.   I happens so fast on my machine that I can't get a good read on what it is.

 Thanks
Comment 1 Linuxguy123 2008-12-04 12:14:49 EST
I think this an Nvidia related issue.  See here:
http://userbase.kde.org/GPU-Performance

=========================================================
Plasma performance is bad 
Explanation 
 Unfortunately the reasons for plasma being choppy seem to be numerous so it's hard to tell where your choppiness comes from. 
Test 
 Usually plasma performance problems can be seen best on the Folder View plasmoid. Moving it or scrolling inside the folder might be pretty slow. 
 General 
 Please make sure this is not (only) related to the ARGB Visuals mentioned in the above section. 
 NVIDIA 
 You can set the IntialPixmapPlacement and the GlyphCache option with the nvidia-settings utility: 
$ nvidia-settings -a InitialPixmapPlacement=2 -a GlyphCache=1
 This works for some (but unfortunately not all) NVIDIA cards. Some cards reportedly work better using InitialPixmapPlacement=1 (or maybe even 3) 
 Options that are said to work well on 8xxx cards but are untested (by me) 
 Option "RenderAccel" "True" 
 enabled by default 
 Option "TripleBuffer" "True" 
 Enables triple buffering. "Decreases the time an application stalls while waiting for vblank events, but increases latency slightly" (NVIDIA Readme) 
 Option "DamageEvents" "True" 
 Recommended by NVIDIA if running composite+glx, increases performance, enabled by default 
 Option "UseCompositeWrapper" "True" 
 Enables the X server's composite wrapper instead of the builtin one. 
 Option "AllowIndirectPixmaps" "True" 
 Could improve hardware rendering on G80+ cards with more than 256 MB of video memory. 
 Option "BackingStore" "True" 
 Cache overlayed areas in case they get redisplayed later 
 Option "PixmapCacheSize" "200000" 
 allocate said number of pixels for pixmap caches 
 Option "OnDemandVBlankInterrupts" "True" 
 only fire VBlank interrupts in modes where they are needed
=====================================================================

$ yum list *nvidia*
Loaded plugins: kmdl, priorities, refresh-packagekit
0 packages excluded due to repository priority protections
Installed Packages                                        
kmod-nvidia.i686                                                                  177.82-1.fc10.4                                    installed        
kmod-nvidia-2.6.27.5-117.fc10.i686.i686                                           177.82-1.fc10.4                                    installed        
xorg-x11-drv-nvidia.i386                                                          177.82-1.fc10                                      installed        
xorg-x11-drv-nvidia-libs.i386                                                     177.82-1.fc10                                      installed 

I don't have time to fool with all this stuff.  Unfortunately that means that I won't have a useable folder view.   This kind of defeats the whole paradigm of KDE4 !

hwbrowser shows my video card as being a "nVidia Corporation GeForce 8800M GTS"  The driver is "nvidia".  GL works fine on my computer.

I think the nvidia-settings application should figure out what nvidia driver options work with what cards and either apply them or allow the user to apply them.
Comment 2 Rex Dieter 2008-12-04 12:35:36 EST
> I don't have time to fool with all this stuff... defeats the whole paradigm 
> of KDE4 !

Not much fedora or kde can do to workaround poor 3rd-party drivers (ie, we don't have time to deal with stuff we CANTFIX either).

Imo, Comments, complaints about nvidia's drivers should go to nvidia.

Now, are these issues reproducible with fedora's nv, nouveau, or even, vesa X
drivers?  (If so, we can reopen this).

> I think the nvidia-settings application should figure out ...

Good suggestion, but that's not something shipped with fedora either.
Comment 3 Kevin Kofler 2008-12-07 16:13:10 EST
Just for the record:
> Imo, Comments, complaints about nvidia's drivers should go to nvidia.

That's not just your opinion, it's common sense.

Linuxguy123, please report your issue to NVidia instead of trolling on the fedora-list. It's the ONLY way your bug will EVER get fixed.
Comment 4 Arthur Pemberton 2008-12-14 17:07:56 EST
I have had a folder view on my desktop for quite some time since this issue was first brought up on the list. I have experienced no additional stability issues since adding it.
Comment 5 Linuxguy123 2009-01-27 11:49:11 EST
I run the F10 update this morning and folderview now works well.   The update contained kmod-nvidia.i686 180.22-1.fc10.1.  I'm not saying that is what fixed it, just that it was in the update.

Anyway, I am happy to have a folderview that works now.

Thanks to those that made this happen.

Note You need to log in before you can comment on or make changes to this bug.