Bug 473496 - Performance regression in broker management
Performance regression in broker management
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
1.1
All Linux
urgent Severity high
: 1.1
: ---
Assigned To: Ted Ross
Kim van der Riet
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-28 15:55 EST by Gordon Sim
Modified: 2009-02-04 10:35 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-04 10:35:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gordon Sim 2008-11-28 15:55:35 EST
A 40-50% regression in performance of the broker was introduced by r719699[1]. It is an issue with the management and can be avoided by turning management off (-m false).

(My guess - speculative - is that its due to more frequent use of the qpid::sys::now() function).

[1] http://svn.apache.org/viewvc?rev=719699&view=rev
Comment 1 Ted Ross 2008-12-01 12:16:00 EST
This regression has been fixed in the upstream revision r722120.
Comment 3 Frantisek Reznicek 2008-12-05 06:02:16 EST
Performance issue has been fixed. Running qpidd with and without management enabled provide now close comparable perftest results:

RHEL 5.2 (dhcp-lab-200)
starting qpidd with management on
starting qpidd with management off
summary
.with management
78004.3 72638.1 146076 142.652
.without management
78203 76793.5 153621 150.02


RHEL 4.7 (nec-em15)
starting qpidd with management on
starting qpidd with management off
summary
.with management
25815.3 25703.2 51603.2 50.3938
.without management
27150.8 27026.8 54270 52.9981


Validated on RHEL 5.2 / 4.7, i386 / x86_64 on packages: qpidd-0.3.722891-2.el5, rhm-0.3.2913-1.el5

->VERIFIED
Comment 5 errata-xmlrpc 2009-02-04 10:35:54 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0035.html

Note You need to log in before you can comment on or make changes to this bug.