Bug 473586 - sample file in /usr/share/doc/bind-9.5.1/sample/etc is very out of date
sample file in /usr/share/doc/bind-9.5.1/sample/etc is very out of date
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
10
All Linux
medium Severity low
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-29 11:07 EST by Bevis King
Modified: 2013-04-30 19:42 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-14 21:59:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
improved sample named.conf (7.43 KB, text/plain)
2008-12-01 11:05 EST, Adam Tkac
no flags Details

  None (edit)
Description Bevis King 2008-11-29 11:07:29 EST
Description of problem:
[This is almost certainly one for upstream - hope you can submit it to the right people].
The bind sample configuration file in /usr/share/doc/bind which is referred to in the template file provided with the bind RPM appears to be very out of date omitting for instance any mention of:

- the "listen-on port" directive and how it's formatted
- the "allow-query" directive

both of which I believe have become mandatory and both of which need to be changed by anyone setting up anything more than a simple caching nameserver (something the example file appears to show, except it doesn't because of these new directives which enhance security.)

Version-Release number of selected component (if applicable):
bind-9.5.1-0.8.b2.fc10.x86_64

How reproducible:
Every time!

Steps to Reproduce:
1.   Compare the sample file with the pre-installed template file.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Adam Tkac 2008-12-01 11:03:57 EST
Thanks for report, improved sample config file is commited in CVS, will be available in next update.
Comment 2 Adam Tkac 2008-12-01 11:05:25 EST
Created attachment 325243 [details]
improved sample named.conf
Comment 3 Bevis King 2008-12-02 06:11:27 EST
Looks great.  Thank you very much Adam.  Regards, Bevis.
Comment 4 Fedora Update System 2009-01-08 09:39:12 EST
bind-9.5.1-1.P1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/bind-9.5.1-1.P1.fc10
Comment 5 Fedora Update System 2009-01-14 21:59:30 EST
bind-9.5.1-1.P1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.