Bug 473655 - firstaidkit : Unowned directories
firstaidkit : Unowned directories
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firstaidkit (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Martin Sivák
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-29 14:12 EST by Michael Schwendt
Modified: 2009-03-19 15:21 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-19 15:21:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2008-11-29 14:12:11 EST
One or more directories are not included within this
package and/or its sub-packages:

=> firstaidkit-0.2.2-1.fc11.noarch (rawhide-development-i386)
/usr/share/doc/firstaidkit-0.2.2
/etc/firstaidkit

=> firstaidkit-devel-0.2.2-1.fc11.noarch (rawhide-development-i386)
/usr/lib/firstaidkit
/usr/lib/firstaidkit/plugins

=> firstaidkit-gui-0.2.2-1.fc11.noarch (rawhide-development-i386)
/usr/lib/firstaidkit
/usr/lib/firstaidkit/frontend

=> firstaidkit-plugin-grub-0.2.2-1.fc11.noarch (rawhide-development-i386)
/usr/lib/firstaidkit
/usr/lib/firstaidkit/plugins
/usr/lib/firstaidkit/plugins/grub

=> firstaidkit-plugin-passwd-0.2.2-1.fc11.noarch (rawhide-development-i386)
/usr/lib/firstaidkit
/usr/lib/firstaidkit/plugins

=> firstaidkit-plugin-xserver-0.2.2-1.fc11.noarch (rawhide-development-i386)
/usr/lib/firstaidkit
/usr/lib/firstaidkit/plugins

Note: I've fixed them before in cvs, but you reverted my changes! Why?

[...]

Further information:

https://fedoraproject.org/wiki/Packaging/ReviewGuidelines

MUST: A package must own all directories that it creates. If it does not
create a directory that it uses, then it should require a package which
does create that directory.

https://fedoraproject.org/wiki/Packaging/Guidelines#FileAndDirectoryOwnership
https://fedoraproject.org/wiki/Packaging/UnownedDirectories
Comment 1 Joel Andres Granados 2008-11-30 13:11:19 EST
This is because we handle the spec file in the src and whenever we make the release we overwrite most of the spec file.  I noticed the difference but was in such a hurry that I just commented them :)
thx for the report.  This should be fixed in rawhide.
Comment 2 Michael Schwendt 2008-12-07 14:39:23 EST
=> firstaidkit-plugin-grub-0.2.2-5.fc11.noarch (rawhide)
/usr/lib/firstaidkit/plugins/grub

[...]

The script to find unowned directories is not complete yet, but
still quite usable: http://mschwendt.fedorapeople.org/dircheck-remote.py
$ ./dircheck-remote.py -r rawhide -n ^firstaidkit
Comment 3 Michael Schwendt 2008-12-07 14:47:30 EST
Plus this one which went missing when I did cut'n'paste:

=> firstaidkit-0.2.2-5.fc11.src.rpm
=> firstaidkit-0.2.2-5.fc11.noarch (rawhide)
/etc/firstaidkit
Comment 4 Joel Andres Granados 2009-03-19 08:13:39 EDT
This is fixed in current firsaidkit spec file. firstaidkit-0_2_2-8_fc11
Comment 5 Michael Schwendt 2009-03-19 09:22:45 EDT
%dir statement for  %_libdir/firstaidkit/plugins/grub  is broken due to wrong wildcard
Comment 6 Joel Andres Granados 2009-03-19 15:21:04 EDT
fixed in next version firstaidkit-0_2_2-9_fc11. thx for looking after the package :)

Note You need to log in before you can comment on or make changes to this bug.