Bug 473666 - spu-binutils : Unowned directories
spu-binutils : Unowned directories
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: spu-binutils (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jochen Roth
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-29 15:35 EST by Michael Schwendt
Modified: 2008-12-02 20:18 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-02 20:18:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2008-11-29 15:35:14 EST
One or more directories are not included within this
package and/or its sub-packages:

=> spu-binutils-2.18.50.0.9-7.fc10.i386 (rawhide-development-i386)
/usr/spu

Note: A "spu" directory directly below /usr is strange with regard to the
FHS. I would expect that tree to be place in %{_libdir}/spu/ instead.

[...]

Further information:

https://fedoraproject.org/wiki/Packaging/ReviewGuidelines

MUST: A package must own all directories that it creates. If it does not
create a directory that it uses, then it should require a package which
does create that directory.

https://fedoraproject.org/wiki/Packaging/Guidelines#FileAndDirectoryOwnership
https://fedoraproject.org/wiki/Packaging/UnownedDirectories
Comment 1 Jochen Roth 2008-12-01 06:44:18 EST
(In reply to comment #0)
> Note: A "spu" directory directly below /usr is strange with regard to the
> FHS. I would expect that tree to be place in %{_libdir}/spu/ instead.

Yes, indeed it is strange. But this is the way current cross packages are being handled in Fedora. Have a look for avr-binutils for example.
 
> MUST: A package must own all directories that it creates. If it does not
> create a directory that it uses, then it should require a package which
> does create that directory.

Thanks, I'll update the package soon.  
The problem is that we are still missing some packages to complete the cross toolchain for SPE. Therefore I can't set the dependencies correct. 
spu-gcc and spu-newlib are still under review.
Comment 2 Fedora Update System 2008-12-01 12:12:28 EST
spu-binutils-2.18.50.0.9-10.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/spu-binutils-2.18.50.0.9-10.fc10
Comment 3 Fedora Update System 2008-12-02 20:18:16 EST
spu-binutils-2.18.50.0.9-10.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.