Bug 473691 - Upper/lower case mixup with Eclipse yum entry
Upper/lower case mixup with Eclipse yum entry
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-29 19:49 EST by Linuxguy123
Modified: 2014-01-21 18:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-01 14:19:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Linuxguy123 2008-11-29 19:49:09 EST
Description of problem:

The yum entry for Eclipse is a bit confusing.  yum operations for eclipse packages needs an upper case E sometimes and lower case other times.

Version-Release number of selected component (if applicable):

eclipse-platform.i386                                1:3.4.1-5.fc10   
yum.noarch                                        3.2.20-3.fc10  


How reproducible:
Everytime


Steps to Reproduce:


This doesn't work, and it probably should:
# yum list eclipse*
Loaded plugins: kmdl, priorities, refresh-packagekit
0 packages excluded due to repository priority protections
Error: No matching Packages to list

This works.  Not sure why.
# yum list Eclipse*                                                                       
Loaded plugins: kmdl, priorities, refresh-packagekit                                                            
0 packages excluded due to repository priority protections                                                      
Available Packages                                                                                               
eclipse-cdt.i386                                     1:5.0.0-10.fc10                                    fedora   
eclipse-cdt-mylyn.i386                               1:5.0.0-10.fc10                                    fedora   
eclipse-cdt-sdk.i386                                 1:5.0.0-10.fc10                                    fedora   
eclipse-changelog.i386                               1:2.6.3-1.fc10                                     fedora 

However, if I install a bunch of eclipse packages, yum remove Eclipse* doesn't work and nor does yum remove eclipse*

Expected results:

I thought that yum list <package> should return <package>.

Additional info:

Its absolutely great that Eclipse is packaged as rpms and available for installation via yum.  Its so much better than fooling around with zips and you can uninstall them if you need to.
Comment 1 Linuxguy123 2008-11-30 10:13:17 EST
# yum list Eclipse*
Loaded plugins: kmdl, priorities, refresh-packagekit
0 packages excluded due to repository priority protections
Installed Packages                                        
eclipse-ecj.i386                                     1:3.4.1-5.fc10                                     installed
eclipse-platform.i386                                1:3.4.1-5.fc10                                     installed
eclipse-rcp.i386                                     1:3.4.1-5.fc10                                     installed
eclipse-swt.i386                                     1:3.4.1-5.fc10                                     installed

# yum remove Eclipse*
Loaded plugins: kmdl, priorities, refresh-packagekit
Setting up Remove Process
No Match for argument: Eclipse*
0 packages excluded due to repository priority protections
No package Eclipse* available.
  * Maybe you meant: eclipse-rcp, eclipse-ecj, eclipse-platform, eclipse-swt
No Packages marked for removal

# yum remove eclipse*
Loaded plugins: kmdl, priorities, refresh-packagekit
Setting up Remove Process
No Match for argument: eclipse_application
0 packages excluded due to repository priority protections
No Packages marked for removal

The packages can be removed one by one by yum remove <package>
Comment 2 Andrew Overholt 2008-12-01 10:36:19 EST
I have no idea what's going on here.  All eclipse packages (plugins, the SDK itself, etc.) have lower case names.  Seth?
Comment 3 seth vidal 2008-12-01 10:48:07 EST
non-destructive operations (yum list/info/search) are case insensitive so you can more easily find things.

destructive operations (yum install/remove/update) are case sensitive so you cannot accidentally destroy something.



also if you're at a shell and you do not escape the *'s then you're going to expand out whatever is in the current directory.

so if you run yum remove eclipse\*

you'll get better results than yum remove eclipse* depending on what is in the dir you're running the command from.
Comment 4 Linuxguy123 2008-12-01 13:25:58 EST
==============================================================================
non-destructive operations (yum list/info/search) are case insensitive so you
can more easily find things.

destructive operations (yum install/remove/update) are case sensitive so you
cannot accidentally destroy something.
=============================================================================

That explanation doesn't make any sense because:

a) The yum list operation isn't case insensitive as you state.   Yum list eclipse* doesn't return anything.  Only yum list Eclipse* does.  According to your explanation, that is a bug right there.

The FlightGear package is case insensitive though.  

yum list FlightGear
Loaded plugins: kmdl, priorities, refresh-packagekit
0 packages excluded due to repository priority protections
Installed Packages
FlightGear.i386                                      1.0.0-4.fc10                                       installed

# yum list flightgear
Loaded plugins: kmdl, priorities, refresh-packagekit
0 packages excluded due to repository priority protections
Installed Packages
FlightGear.i386                                      1.0.0-4.fc10                                       installed


b) yum asks for confirmation before anything is removed, so there is no need for the actual yum command to protect the user from anything.  The command doesn't complete without further acknowledgement.

c) it doesn't provide any protection for packages that don't have upper and lower case names.  Its inconsistent protection at best.

d) Even if it is protection, that protection shouldn't prevent a user from accomplishing a goal.  Ie rm -f is valid, where is the option for yum ?  Advanced users don't need "protection by case sensitivity", especially when yum asks for confirmation later on.

This issue needs to be looked at.   I spent a couple days on the weekend installing and uninstalling Eclipse with yum to troubleshoot an installation bug.  Not being able to yum remove eclipse* was a huge pain in the butt.

So how does one remove or install all the eclipse packages on a machine without naming each one ?  (There are about 60 Eclipse packages in F10 stable.)  

I'm changing this to assigned so that it gets another look.  I don't know who to assign it to, so Andrew gets to be the lucky person.
Comment 5 seth vidal 2008-12-01 13:54:02 EST
Right, if you read the last part of my comment, you need to escape wildcards on the shell prompt b/c the shell will try to expand them out before passing them to the program.

You have a file or a dir named eclipse_application in the dir where you were trying to run: yum remove eclipse* from.

if you run:

 yum remove eclipse\*

I think you'll find it works.
Comment 6 Linuxguy123 2008-12-01 14:13:19 EST
That does work. Thanks

Note You need to log in before you can comment on or make changes to this bug.