Bug 473748 - pgadmin3 missing from Fedora 10
pgadmin3 missing from Fedora 10
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pgadmin3 (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Devrim GÜNDÜZ
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-30 02:46 EST by David Rees
Modified: 2009-07-02 01:53 EDT (History)
8 users (show)

See Also:
Fixed In Version: 1.10.0-1.fc10
Doc Type: Bug Fix
Doc Text:
pgadmin3 has been removed and blocked because of a license issue (Artistic 1.0) from Fedora until this issue is solved by upstream. For now, the package is available in PGSQLRPMS and RPM Fusion for end users.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-02 01:53:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
redhat: fedora_requires_release_note?
tibbs: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description David Rees 2008-11-30 02:46:13 EST
pgadmin3 is not available in any repo for Fedora 10. It appears to build OK according to koji, I'm not sure why it hasn't been released.  Would be extremely useful to get this pushed out as an update.
Comment 1 Robert Scheck 2008-12-30 08:40:48 EST
As the package maintainer seems to be less active (when thinking to #229054);
I'm hereby requesting the branching of pgadmin3 for F-10, because I need it
as well as David. I would like to leave the owners same as they are currently,
it looks like the non-branching for F-10 happened as a mistake such as for a
few other packages in Fedora...unluckily.


Package Change Request
======================
Package Name: pgadmin3
New Branches: F-10
Owners: ghenry, devrim
Comment 2 Kevin Fenzi 2008-12-31 00:39:23 EST
cvs done.
Comment 3 Robert Scheck 2008-12-31 05:57:41 EST
See https://fedorahosted.org/fedora-infrastructure/ticket/1096 - not yet
solved, need some admin action first.
Comment 4 Robert Scheck 2008-12-31 06:06:03 EST
Well, https://fedorahosted.org/rel-eng/ticket/1216 is the correct ticket. I
had to move it to another tracker.
Comment 5 Robert Scheck 2009-01-04 17:34:54 EST
Since Artistic 1.0 is not free enough for Fedora, I've created a review
request for pgadmin3 in RPM Fusion. Maybe Devrim is interested to get the
co-maintainer there? https://bugzilla.rpmfusion.org/show_bug.cgi?id=300
is the review request at RPM Fusion.
Comment 6 Devrim GUNDUZ 2009-01-04 17:42:10 EST
(In reply to comment #5)
> Maybe Devrim is interested to get the co-maintainer there?

Thanks, but I'm not interested in contributing 3rd party repositories (except yum.pgsqlrpms.org, which is my project)


Devrim.
Comment 7 Robert Scheck 2009-01-08 16:00:37 EST
pgadmin3 has succeeded the review for RPM Fusion and is now available there
for Fedora 9 and 10 in testing (stable push will take a bit time as usual).
The package got also cleaned up a lot and fixes several packaging issues...

Maybe Devrim takes some of the cleanups into his own repository, it will
enhance the packaging quality, if he has not already done it (I didn't look
to it).

As we can't to anything for the moment and the next time at Fedora here, I
will close this bug report - it references everything needed above.
Comment 8 Robert Scheck 2009-01-08 16:00:37 EST
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
pgadmin3 has been removed and blocked because of a license issue (Artistic 1.0) from Fedora until this issue is solved by upstream. For now, the package is available in PGSQLRPMS and RPM Fusion for end users.
Comment 9 David Rees 2009-01-08 17:54:53 EST
Thanks to all for helping to make this package available.
Comment 10 David Rees 2009-02-05 14:49:39 EST
Reopening bug, pgadmin3 is changing their license to the Artistic License 2.0 on Feb 26th, so we should be able to get this back into Fedora once that is complete.

http://pgsnake.blogspot.com/2009/02/pgadmin-change-of-licence.html
Comment 11 Bob Gustafson 2009-02-17 12:31:53 EST
The chunk of code for pgadmin3 in rpmfusion seems to be missing some files.

I installed pgadmin3 from rpmfusion on a system which did not previously have postgresql (also installed postgresql..) and got:

[root@hoho0 postgres-new]# ls -l /usr/share/pgadmin3
total 48
drwxr-xr-x 2 root root  4096 2009-02-17 00:44 i18n
-rw-r--r-- 1 root root  1203 2008-06-04 03:19 pgadmin3.xpm
-rw-r--r-- 1 root root 26556 2009-01-07 07:41 pgagent.sql
[root@hoho0 postgres-new]# /usr/bin/postmaster -V -v
postgres (PostgreSQL) 8.3.6
[root@hoho0 postgres-new]# 

----

On an older system, which had older versions of pgadmin3 and postgresql installed, but then had pgadmin3 upgraded using the rpmfusion package, I got:

[root@hoho4 ocr]# ls -l /usr/share/pgadmin3
total 64
drwxr-xr-x  2 root root  4096 2009-01-23 19:09 branding
drwxr-xr-x 11 root root  4096 2009-01-23 19:09 docs
drwxr-xr-x 21 root root  4096 2009-01-23 19:09 i18n
-rw-r--r--  1 root root  1203 2008-06-04 15:05 pgadmin3.xpm
-rw-r--r--  1 root root 26556 2008-06-04 15:03 pgagent.sql
[root@hoho4 ocr]# /usr/bin/postmaster -V -v
postgres (PostgreSQL) 8.3.6
[root@hoho4 ocr]# 

The branding (!!) and docs directories seem to be missing from the current pgadmin3 rpmfusion package.

Maybe this bug should be addressed to the rpmfusion folks?
Comment 12 Devrim GUNDUZ 2009-02-17 12:41:57 EST
1.10 will be released in two weeks or so. 1.10 will again enter Fedora, so I'm inclined to ignore this bug report. If you want, feel free to submit it to rpmfusion folks, but I'm not sure they will want to work on a bug which will be removed in a few weeks.

Sincerely,Devrim
Comment 13 Robert Scheck 2009-02-17 13:28:56 EST
Removed branding directory was indentional (see RPM Fusion review request).
But once pgadmin3 enters Fedora again, I will obsolete it in RPM Fusion as
soon as possible. But yes, if the system never had a pgadmin3, there seem
to be some issues with the current RPM Fusion pgadmin3 package - came up to
me as well the last few days.

Devrim, maybe you can take some corrections from the reviewed spec file of
RPM Fusion and skip the seemingly broken stuff identifed by Bob and myself.
Comment 14 Robert Scheck 2009-03-18 09:42:33 EDT
Bob, can you please state the need for the branding directory? I think this
directory is not useful inside of Fedora at all.
Comment 15 Bob Gustafson 2009-03-18 10:48:10 EDT
I have pgadmin3 running on my FC9 and FC10 systems. If you (or anyone else) wishes to change the name of the 'branding' directory, it doesn't bother me.

I would like to keep the functionality of pgadmin3 though..
Comment 16 Robert Scheck 2009-03-18 10:55:50 EDT
I will re-add the "branding" directory for the next RPM Fusion build. But the
"docs" directory won't exist, as we otherwise would ship the content twice, once
for pgadmin3 and once in %doc. Next RPM Fusion build of pgadmin3 will handle it
that way, that pgadmin3 looks for the doc stuff in %doc. Okay so far?
Comment 17 Fedora Admin XMLRPC Client 2009-05-12 02:19:20 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 18 Devrim GUNDUZ 2009-06-29 11:08:48 EDT
1.10.0 is released under BSD license. I pushed the package to rawhide and F-10. I will request F-11 branch shortly.
Comment 19 Devrim GUNDUZ 2009-06-29 11:10:35 EDT
Package Change Request
======================
Package Name: pgadmin3
New Branches: F-11
Owners:  devrim

Package is relicenced under BSD, so we can push it to F-11, too.
Comment 20 Jason Tibbitts 2009-06-29 13:04:41 EDT
CVS done.
Comment 21 Fedora Update System 2009-06-29 13:54:25 EDT
pgadmin3-1.10.0-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/pgadmin3-1.10.0-1.fc10
Comment 22 Fedora Update System 2009-07-02 01:53:01 EDT
pgadmin3-1.10.0-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.