Bug 473763 - Monsterz failed to launch
Monsterz failed to launch
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: monsterz (Show other bugs)
10
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Rafał Psota
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-30 07:17 EST by Laurent Carlier
Modified: 2009-02-06 19:58 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-06 00:18:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Laurent Carlier 2008-11-30 07:17:49 EST
Description of problem:
Monsterz failed to launch, the window open then close.

Version-Release number of selected component (if applicable):
monsterz.x86_64 0.7.1-3.fc9

How reproducible:
everytime.

Steps to Reproduce:
1. Run monterz
2.
3.
  
Actual results:


Expected results:


Additional info:
When launching in a terminal the following Traceback is available:

Traceback (most recent call last):
  File "/usr/share/monsterz/monsterz.py", line 1994, in <module>
    main()
  File "/usr/share/monsterz/monsterz.py", line 1989, in main
    monsterz.go()
  File "/usr/share/monsterz/monsterz.py", line 1267, in go
    iterator()
  File "/usr/share/monsterz/monsterz.py", line 1377, in iterate_menu
    self.copyright_draw()
  File "/usr/share/monsterz/monsterz.py", line 1296, in copyright_draw
    system.blit(scroll, (13, 437))
  File "/usr/share/monsterz/monsterz.py", line 399, in blit
    self.background.blit(surf, coords)
pygame.error: Surfaces must not be locked during blit
Comment 1 Marcos Martins da Silva 2008-11-30 09:28:37 EST
I have just upgraded to Fedora 10 and the problem is the same. It is possible to run the game if you comments out lines 844 and 1296. Others calls to "blit" work flawlessly. This is a quick and dirty workaround because you loose the timebar.
Comment 2 Fedora Update System 2009-02-06 00:18:50 EST
monsterz-0.7.1-4.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 3 Fedora Update System 2009-02-06 00:25:11 EST
monsterz-0.7.1-4.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 4 Marcos Martins da Silva 2009-02-06 19:58:43 EST
Now it is working flawlessly on Fedora 10!! Thank you!

Note You need to log in before you can comment on or make changes to this bug.