Bug 473767 - Tablet PC crashes during logout/shutdown/restart on Fedora
Tablet PC crashes during logout/shutdown/restart on Fedora
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: linuxwacom (Show other bugs)
10
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Aristeu Rozanski
Fedora Extras Quality Assurance
:
: 474730 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-30 08:08 EST by mail
Modified: 2018-04-11 07:18 EDT (History)
5 users (show)

See Also:
Fixed In Version: 0.8.0.3-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-04 06:20:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (2.92 KB, text/plain)
2008-12-02 04:29 EST, mail
no flags Details
/var/log/messages - Result of running X with no xorg.conf file (65.18 KB, text/plain)
2008-12-02 04:32 EST, mail
no flags Details
/var/log/messages - Result of running X with xorg.conf file (62.35 KB, application/octet-stream)
2008-12-02 04:33 EST, mail
no flags Details
Xorg.0.log - Result of running X with no xorg.conf file (30.88 KB, text/plain)
2008-12-02 04:35 EST, mail
no flags Details
Xorg.0.log - Result of running X with xorg.conf file (50.41 KB, text/plain)
2008-12-02 04:36 EST, mail
no flags Details
xorg.conf on Toshiba M400 Tablet (1.58 KB, text/plain)
2008-12-02 16:57 EST, Wolfgang Hübner
no flags Details
sysreport -norpm from Toshiba M400 (334.23 KB, application/octet-stream)
2008-12-02 17:08 EST, Wolfgang Hübner
no flags Details

  None (edit)
Description mail 2008-11-30 08:08:03 EST
Sorry - I am not sure if I have the correct component - xorg-x11 or xorg-x11-drivers

Description of problem:

This machine is a Fujitsu Stylistic Tablet ST5112
The graphics card is Intel 945GM - so I am using the xorg intel driver.

If you attempt to logout or shutdown or restart Fedora, computer crashes.
Screen glows black and sometimes random vertical lines appear on display
I then have to turn off machine using hardware switch.

Version-Release number of selected component (if applicable):


How reproducible:
Easily


Steps to Reproduce:
1.Select either shutdown/logout/restart from Fedora menus
2.
3.
  
Actual results:
Computer crashes
Screen glows black.
Sometimes random vertical lines appear on display.

If I restart the machine and check the previous Xorg log there is a stack trace:

Backtrace:
0: /usr/bin/X(xorg_backtrace+0x26) [0x4e7a26]
1: /usr/bin/X(xf86SignalHandler+0x39) [0x47a679]
2: /lib64/libc.so.6 [0x3718032f60]
3: /usr/lib64/xorg/modules/input//wacom_drv.so [0x105cc45]
4: /usr/lib64/xorg/modules/input//wacom_drv.so [0x1065c55]
5: /usr/bin/X(DeleteInputDeviceRequest+0x3b) [0x4916cb]
6: /usr/bin/X(CloseDownDevices+0x29) [0x43fc69]
7: /usr/bin/X(main+0x4ad) [0x42cd6d]
8: /lib64/libc.so.6(__libc_start_main+0xe6) [0x371801e546]
9: /usr/bin/X [0x42c0f9]

Fatal server error:
Caught signal 11. Server aborting.

Expected results:
Machine shuts down/restarts/logs-out correctly

Additional info:

My current solution to shutdown my machine is :
1. ctl-alt-f6 to open a terminal
2. login and then manually shutdown using "shutdown -h now"
This works with no problem.
Comment 1 Matěj Cepl 2008-12-01 19:06:40 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available), /var/log/dmesg, /var/log/messages and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf (if you have one) whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 mail 2008-12-02 04:29:46 EST
Created attachment 325344 [details]
xorg.conf

My xorg.conf file.

After generating one with xorg - all I added was the wacom driver configuration.
This wacom part has not changed since Fedora 7.
Comment 3 mail 2008-12-02 04:32:08 EST
Created attachment 325345 [details]
/var/log/messages - Result of running X with no xorg.conf file

Contains results of starting and shutting down machine.
There was no xorg.conf file during this period.
Comment 4 mail 2008-12-02 04:33:39 EST
Created attachment 325346 [details]
/var/log/messages - Result of running X with xorg.conf file

Contains results of starting and shutting down machine.
There was my xorg.conf file during this period. (also attached).
Comment 5 mail 2008-12-02 04:35:38 EST
Created attachment 325347 [details]
Xorg.0.log - Result of running X with no xorg.conf file
Comment 6 mail 2008-12-02 04:36:11 EST
Created attachment 325348 [details]
Xorg.0.log - Result of running X with xorg.conf file
Comment 7 mail 2008-12-02 04:38:57 EST
I have run the tests as requested.

It is noted that when there was no xorg.conf file - I was able to shutdown the machine.
Comment 8 Wolfgang Hübner 2008-12-02 16:56:19 EST
Hello.

I have a similar Problem on a Toshiba M400 Tablet PC. It's also the wacom_drv.o that crashes with segfault.

When I switch to a console (i.e. <Alt>-<F2>) and do a "init 3", the following error appears:

Xorg[2555]: segfault at ff36 ip 007894dc sp bfec1a30 error 4 in wacom_drv.so (deleted)[786000+14000]

I have linuxwacom-0.8.0.3 installed on Fedora 10 as of 02 Dec. 2008.

My xorg.conf is attached above.

Regards
Wolfgang Hübner
Comment 9 Wolfgang Hübner 2008-12-02 16:57:07 EST
Created attachment 325433 [details]
xorg.conf on Toshiba M400 Tablet
Comment 10 Wolfgang Hübner 2008-12-02 17:08:48 EST
Created attachment 325436 [details]
sysreport -norpm from Toshiba M400
Comment 11 Peter Hutterer 2008-12-02 18:11:40 EST
Looks like a dupe of Bug 468264. What's the full version of your linuxwacom rpm? 0.8.0.3-6 or earlier?
Comment 12 mail 2008-12-03 04:43:29 EST
I had version 0.8.0.3-4.

I have just installed 0.8.0.3-6 (as per instructions on Bug 468264).

My problem appears to be fixed. I can now logout with no crashes.

Thankyou.
Comment 13 Wolfgang Hübner 2008-12-03 04:58:46 EST
I also had 0.8.0.3-4. 

The update to 0.8.0.3-6 fixed the problem on my laptop as well.

Thanx.
Comment 14 Matěj Cepl 2008-12-04 06:20:32 EST
Thanks for letting us know.
Comment 15 Ulrich Drepper 2008-12-07 20:25:59 EST
*** Bug 474730 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.