Bug 473769 - gnome-power-manager crashes when system starts ( gnome-power-man (xdm_t) "execute" do /dev/zero (zero_device_t) )
gnome-power-manager crashes when system starts ( gnome-power-man (xdm_t) "exe...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
10
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-30 08:40 EST by lukslab
Modified: 2009-08-20 09:20 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-20 09:20:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log created by SELinux (2.78 KB, text/plain)
2008-11-30 08:40 EST, lukslab
no flags Details

  None (edit)
Description lukslab 2008-11-30 08:40:10 EST
Created attachment 325125 [details]
Log created by SELinux

Description of problem:
Gnome-power-manager crashes when starting the system (on the login screen)
gnome-power-man (xdm_t) "execute" do /dev/zero (zero_device_t)
Version-Release number of selected component (if applicable):
gnome-power-manager-2.24.1-3.fc10

How reproducible:
Just starting the system

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
After confirming the bug in bug buddy system runs well without any other problems. But bug buddy notifies on every time system boots.
Comment 1 Richard Hughes 2008-12-01 08:23:20 EST
g-p-m doesn't access /dev/zero -- could this be PulseAudio?
Comment 2 lukslab 2008-12-06 08:02:40 EST
I don't think this could be PulseAudio. According to SELinux it is gnome-power-manager, but i'm not experienced enought to be sure. Here is the output from bug buddy:

Distribution: Fedora release 10 (Cambridge)
Gnome Release: 2.24.1 2008-11-06 (Red Hat, Inc)
BugBuddy Version: 2.24.1

System: Linux 2.6.27.5-117.fc10.i686 #1 SMP Tue Nov 18 12:19:59 EST 2008 i686
X Vendor: The X.Org Foundation
X Vendor Release: 10503000
Selinux: Enforcing
Accessibility: Disabled
GTK+ Theme: (null)
Icon Theme: (null)

Memory status: size: 0 vsize: 0 resident: 0 share: 0 rss: 0 rss_rlim: 0
CPU usage: start_time: 0 rtime: 0 utime: 0 stime: 0 cutime:0 cstime: 0 timeout: 0 it_real_value: 0 frequency: 0

Output of custom script "gnome-power-bugreport.sh":
Distro version:       Fedora release 10 (Cambridge)
Kernel version:       2.6.27.5-117.fc10.i686
g-p-m version:        2.24.1
HAL version:          0.5.12
System manufacturer:  missing
System version:       missing
System product:       missing
AC adapter present:   no
Battery present:      no
Laptop panel present: no
CPU scaling present:  no
Battery Information:
GNOME Power Manager Process Information:
gdm       2121  0.0  0.6  28808  3912 ?        Ss   13:57   0:00 /usr/bin/gnome-power-manager
gdm       2124  1.1  1.5  46928 10136 ?        S    13:57   0:00  \_ /usr/bin/gnome-power-manager
gdm       2139  9.7  2.6  41868 17020 ?        S    13:57   0:01      \_ bug-buddy --appname=gnome-power-manager --minidump=/tmp/6ec0af8e-5a41-eaba-6b7fdbcb-340a5e8d.dmp
gdm       2125  0.0  0.6  28808  3912 ?        Ss   13:57   0:00 /usr/bin/gnome-power-manager
gdm       2126  1.2  1.5  46928 10136 ?        S    13:57   0:00  \_ /usr/bin/gnome-power-manager
gdm       2140  9.6  2.6  41868 17020 ?        S    13:57   0:01      \_ bug-buddy --appname=gnome-power-manager --minidump=/tmp/07495207-af0b-6a85-451a6d70-25569add.dmp
gdm       2136  0.1  0.6  28808  3912 ?        Ss   13:57   0:00 /usr/bin/gnome-power-manager
gdm       2137  1.6  1.5  46928 10136 ?        S    13:57   0:00  \_ /usr/bin/gnome-power-manager
gdm       2262 10.7  2.4  38488 15684 ?        S    13:57   0:00      \_ bug-buddy --appname=gnome-power-manager --minidump=/tmp/48553474-16d2-c3e5-35f5cd1b-22804354.dmp
HAL Process Information:
68        1585  1.8  0.7   7076  4692 ?        Ss   13:56   0:00 hald
root      1651  0.1  0.1   3548  1144 ?        S    13:56   0:00  \_ hald-runner
root      1766  0.0  0.1   3624  1020 ?        S    13:56   0:00      \_ hald-addon-input: Listening on /dev/input/event2 /dev/input/event1 /dev/input/event0 /dev/input/event4
root      1771  0.0  0.1   3628  1032 ?        S    13:56   0:00      \_ hald-addon-storage: polling /dev/sr0 (every 2 sec)
root      1775  0.0  0.1   3628  1024 ?        S    13:56   0:00      \_ hald-addon-storage: no polling on /dev/fd0 because it is explicitly disabled
68        1783  0.0  0.1   3188   908 ?        S    13:56   0:00      \_ hald-addon-acpi: listening on acpi kernel interface /proc/acpi/event
Comment 3 Marek Grac 2009-02-11 03:47:25 EST
I believe that I have same problem (Lenovo X61; F10 with all updates). Login screen freezes with a grey border in the middle. Solution is to switch to text console - killall g-p-m. Select user. killall g-p-m. Type password. This only happends when computer is not on A/C. IMHO problem is quite new and occured after 30. Jan (last time I'm sure that I used it on battery power).

Willing to test, provide direct (ssh), semi-direct (irc) access :)
Comment 4 Richard Hughes 2009-04-15 12:14:54 EDT
Does this still happen with the version in fedora rawhide, or the version of the Fedora 11 beta live cd?
Comment 5 Marek Grac 2009-04-29 04:42:33 EDT
Seems to be fixed in F10, now

Note You need to log in before you can comment on or make changes to this bug.