Bug 47377 - KPPP & Script Debug window frozen in time ...connection incomplete.
KPPP & Script Debug window frozen in time ...connection incomplete.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: ppp (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-05 00:34 EDT by Need Real Name
Modified: 2007-04-18 12:34 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-13 05:28:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-07-05 00:34:03 EDT
Description of Problem:

Most of the time the connection will not complete on the first try.  
Also, at times, the KPPP window & the script debugging window will become 
permanent residents on the desktop while not displaying whether or not 
the connection was actually completed.  When this happens, one has to 
'su' & delete the PID file, then dial again, or log out, then back in, 
and redial.

How Reproducible:
Log in & dial using KPPP (w/script which says 'root.ok' fixed as 
indicated on RedHat's site.  This is not 100% reproducible, but between 
this & not completing connection to the point of timing out & having to 
redial, it is nearly 100% reproducible.

Steps to Reproduce:
1. Just dial the ISP
2. 
3. 

Actual Results:
Most of the time the connection will not complete on the first try.  
Also, at times, the KPPP window & the script debugging window will become 
permanent residents on the desktop while not displaying whether or not 
the connection was actually made.  When this happens, one has to 'su' & 
delete the PID file, then dial again, or log out, then back in, and 
redial.

Expected Results:
Expected... (1)/home/<user>/.kde/share/apps/kppp directory to be made on 
the USER's side with PID file therein... then a completed dial-in to the 
ISP the first time it is dialed --except, of course,  when there is a 
busy, or the line doesn't answer.

Additional Information:
 The multiple tries for a completed connection happen nearly every time 
the ISP is dialed.  When this happens, the terminal is waiting for the 
host PAP, and [presumeably] the IP address to be received.

The frozen KPPP & Script window happen frequently, though not on a 
regular schedule. However, as indicated, between this & the failed 1st 
dial-in attempt, the problem is very nearly 100% reproducible.

All updates, with the exception of the kernel, have hereby been applied, 
and this behaviour has not changed in the least.

Depending upon how much one must use the 'net, this could be considered a 
high-priority deal.  Half my work-load comes off the 'net, so this is a 
very major deal to me.

Machine in question:
Toshiba Satellite2100CDT
AMD K6-2 3D 400mhz processor
64MB RAM
4.03GB HD (RH Linux-dedicated)
Comment 1 Need Real Name 2001-07-06 13:43:25 EDT
One very important point which I forgot to mention in conjunction with the 
described behaviour under 'Actual Results': when the KPPP & Script window 
refuse to disappear, even the 'kill' command does not work (from terminal: su, 
ps aux, kill xxxx).  The windows absolutely will not go away.

My apologies for this oversight!
Comment 2 Phil Schaffner 2001-08-22 09:43:10 EDT
Frozen and greyed-out kppp window apparently occurs any time a ppp error happens
after a
connection is initiated, including bad password or unexpected termination as
when the line
drops (as happens frequently with my ISP and bad telco service).  The window can
be removed with "xkill" but the .pid file in the root .kde directory tree must
still be manually removed (after a su) in order to reinitiate kppp.  This
behavior occurs on multiple RH 7.1 Seawolf  machines with all current
patched/updates (including kernel) applied, and is a major annoyance.
Comment 3 Brad Smith 2001-10-29 22:02:13 EST
I  can su to root and then kill -9 all related processes to remove the
grayed-out kppp window. I can then start kppp again. The freeze happens, in my
case, when the remote host responds with an authentication error. I am testing
remote log-ins and the default configuration freezes the account after 5 errors.
Security is high these days.

Brad
Comment 4 Thomas Woerner 2004-08-13 05:28:19 EDT
Please verify this with a newer version of Red Hat Enterprise Linux or Fedora
Core and reopen it against the new version if it still occurs.

Closing as "not a bug" for now.

Note You need to log in before you can comment on or make changes to this bug.