Bug 473770 - xorg-x11-driver-ati does not use the video card LUT
xorg-x11-driver-ati does not use the video card LUT
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
10
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-30 08:45 EST by Alberto Ferrante
Modified: 2009-07-20 04:49 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-20 04:49:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf file (593 bytes, text/plain)
2008-12-05 10:49 EST, Allen
no flags Details
log file - X11 started with xorg.conf file (113.38 KB, text/plain)
2008-12-05 10:50 EST, Allen
no flags Details
log file - X11 started without xorg.conf file (116.34 KB, text/plain)
2008-12-05 10:51 EST, Allen
no flags Details
X11 log file with F10 driver and my current xorg.conf (50.41 KB, text/plain)
2008-12-06 08:41 EST, Alberto Ferrante
no flags Details
X11 log file with F10 driver and no xorg.conf (52.72 KB, text/plain)
2008-12-06 08:41 EST, Alberto Ferrante
no flags Details
My current xorg.conf (1.16 KB, text/plain)
2008-12-06 08:42 EST, Alberto Ferrante
no flags Details
X11 log file with F9 driver (6.8.0.19-fc9) and my current xorg.conf (67.75 KB, text/plain)
2008-12-06 08:42 EST, Alberto Ferrante
no flags Details

  None (edit)
Description Alberto Ferrante 2008-11-30 08:45:46 EST
Description of problem:
the ati X11 driver seems not to use the graphic card LUT. The LUT is correctly loaded with calibration info (e.g., by dispwin or xcalib), but this has no visual effect on the monitor. dispwin -V confirms that the LUT is correctly loaded. dispwin -r is executed without any error, but it has no visual effect (e.g., it does not darken or lighten the monitor) as it should have.

Version-Release number of selected component (if applicable):
6.9.0-54

How reproducible:
On a system with an ATI graphic card

Steps to Reproduce:
1. configure X11 to use the ATI driver
2. run dispwin -r

 
Actual results:
No change in the screen

Expected results:
The screen should darken and then lighten

Additional info:
Downgrading the driver to xorg-x11-drv-ati-6.8.0-19.fc9.i386 (last one available for Fedora 9) solves the problem.

Also the Vesa driver seems to have the same problem.
Comment 1 Matěj Cepl 2008-12-01 19:07:04 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf (if you have one) whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Allen 2008-12-05 10:49:53 EST
Created attachment 325865 [details]
xorg.conf file

I am having the same problem.  My install was an upgrade from Fedora 9.  Video card is ATI X550 series.  I am attaching the information you requested.

-Allen
Comment 3 Allen 2008-12-05 10:50:49 EST
Created attachment 325867 [details]
log file - X11 started with xorg.conf file
Comment 4 Allen 2008-12-05 10:51:38 EST
Created attachment 325868 [details]
log file - X11 started without xorg.conf file
Comment 5 Alberto Ferrante 2008-12-06 08:41:09 EST
Created attachment 325989 [details]
X11 log file with F10 driver and my current xorg.conf
Comment 6 Alberto Ferrante 2008-12-06 08:41:38 EST
Created attachment 325990 [details]
X11 log file with F10 driver and no xorg.conf
Comment 7 Alberto Ferrante 2008-12-06 08:42:04 EST
Created attachment 325991 [details]
My current xorg.conf
Comment 8 Alberto Ferrante 2008-12-06 08:42:54 EST
Created attachment 325992 [details]
X11 log file with F9 driver (6.8.0.19-fc9) and my current xorg.conf
Comment 9 Ottavio G. Rizzo 2009-01-18 07:41:52 EST
Same problem here: downgrading to 6.8 or upgrading to 6.10 solves the LUT problem, but the system cannot suspend to RAM.

I recompiled the package, and I found out that the bug is introduced somewhere by Patch0 (radeon-6.9.0-to-git.patch) and Patch1 (radeon-modeset.patch): no patch at all and the LUT is correctly loaded; those two patches, or all of them, and the LUT is not loaded.

Unfortunately Patch0 seems to be required by all other patches, Patch0 and Patch1 require each other, and they're not granular enough.

If you tell me where the patches come from (I could guess -to-git, but since it requires -modeset, my guess is wrong), I may try to do some regression test to find when the bug was introduced. Or at least it would be easier to report upstream.

Thanks

--Ottavio
Comment 10 François Cami 2009-02-14 08:07:45 EST
Alberto,
Does upgrading to xorg-x11-drv-ati-6.10.0-2.fc10 fix the problem ?
Thanks
Comment 11 Alberto Ferrante 2009-02-14 15:46:39 EST
Unfortunately not. Same behavior as 6.9.0-54.

Regards,
      Alberto
Comment 12 Allen 2009-05-27 10:25:04 EDT
Will this bug be fixed in the upcoming Fedora 11 release?
Thanks,
Allen
Comment 13 Matěj Cepl 2009-05-28 12:42:47 EDT
Hopefully, but not in F11 GA (or 0-day updates), but sometimes early in the life of F11.
Comment 14 Ottavio G. Rizzo 2009-06-17 11:05:04 EDT
I just installed F11: the bug is fixed, at least on my machine.

Ottavio
Comment 15 Matěj Cepl 2009-06-23 18:45:50 EDT
Reporter, could you confirm please comment 14, please?

Thank you
Comment 16 Alberto Ferrante 2009-07-07 07:55:36 EDT
I confirm that the bug is fixed in Fedora 11.

Regards,
   Alberto
Comment 17 Allen 2009-07-10 09:31:15 EDT
I upgraded to Fedora 11 yesterday ... yes, this bug is fixed in 11.

-Allen
Comment 18 Matěj Cepl 2009-07-20 04:49:24 EDT
I don't think anybody will fix this in F10. Closing as NEXTRELEASE then. Anybody who is affected by this bug, is advised to upgrade to F11.

Thanks for reporting this bug and patience with us.

Note You need to log in before you can comment on or make changes to this bug.