Bug 473771 - Broken webcam support
Broken webcam support
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: libv4l (Show other bugs)
10
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
: 474111 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-30 09:03 EST by Aioanei Rares
Modified: 2009-01-09 18:18 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-06 23:23:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log for libv4l (27.01 KB, application/octet-stream)
2008-11-30 11:32 EST, Aioanei Rares
no flags Details
Log for libv4l (0.5.5) not working (8.40 KB, application/octet-stream)
2008-11-30 11:33 EST, Aioanei Rares
no flags Details
Non-working (26.32 KB, application/octet-stream)
2008-12-01 13:19 EST, Aioanei Rares
no flags Details
Working (56.29 KB, application/octet-stream)
2008-12-01 13:20 EST, Aioanei Rares
no flags Details
The bug still exist (1.63 KB, application/zip)
2008-12-02 10:02 EST, lionghostshop
no flags Details

  None (edit)
Description Aioanei Rares 2008-11-30 09:03:10 EST
Description of problem:

After the last updates for F10, webcam in cheese and gyachi is broken.
In cheese, I cannot see any image anymore, and in gyachi I see my self in a 
split image, very small. In camstream it works though, so no sure if the bug report is filled against the correct component. Webcam is Microsoft VX-700
and this happens regardless of the kernel version (Fedora or vanilla).

Version-Release number of selected component (if applicable):

libv4l-0.5.6-1.fc10.x86_64

How reproducible:

Everytime

Steps to Reproduce:
1.Start the aforementioned applications.
2.
3.
  
Actual results:

Faulty webcam images, if any.

Expected results:

Normal webcam image.

Additional info:
Comment 1 Hans de Goede 2008-11-30 09:31:33 EST
(In reply to comment #0)
> Description of problem:
> 
> After the last updates for F10, webcam in cheese and gyachi is broken.
> In cheese, I cannot see any image anymore, and in gyachi I see my self in a 
> split image, very small. In camstream it works though, so no sure if the bug
> report is filled against the correct component. Webcam is Microsoft VX-700
> and this happens regardless of the kernel version (Fedora or vanilla).
> 

What driver does your cam use (attach lsmod output if you don't know)

Can you try downgrading libv4l to the on in F-10 final (version 0.5.4)
Comment 2 Aioanei Rares 2008-11-30 09:35:48 EST
(In reply to comment #1)
> (In reply to comment #0)
> > Description of problem:
> > 
> > After the last updates for F10, webcam in cheese and gyachi is broken.
> > In cheese, I cannot see any image anymore, and in gyachi I see my self in a 
> > split image, very small. In camstream it works though, so no sure if the bug
> > report is filled against the correct component. Webcam is Microsoft VX-700
> > and this happens regardless of the kernel version (Fedora or vanilla).
> > 
> 
> What driver does your cam use (attach lsmod output if you don't know)
> 
> Can you try downgrading libv4l to the on in F-10 final (version 0.5.4)

Module                  Size  Used by
tun                    19844  0 
vfat                   18944  0 
fat                    55352  1 vfat
usb_storage           107936  0 
fuse                   61248  2 
ipt_MASQUERADE         11648  1 
iptable_nat            14340  1 
nf_nat                 26516  2 ipt_MASQUERADE,iptable_nat
bridge                 56736  0 
stp                    11012  1 bridge
ipt_LOG                14084  3 
ppp_synctty            16128  0 
ppp_async              17536  1 
crc_ccitt              10496  1 ppp_async
ppp_generic            31400  6 ppp_synctty,ppp_async
slhc                   13568  1 ppp_generic
ipv6                  288160  14 
dm_multipath           24344  0 
kvm_amd                38156  0 
kvm                   148088  1 kvm_amd
uinput                 16384  0 
snd_hda_intel         526500  8 
snd_seq_dummy          11652  0 
snd_seq_oss            39360  0 
snd_seq_midi_event     15104  1 snd_seq_oss
snd_seq                62096  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device         15508  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            51456  0 
snd_mixer_oss          23424  1 snd_pcm_oss
uvcvideo               62344  0 
snd_pcm                84616  4 snd_hda_intel,snd_pcm_oss
snd_timer              30480  4 snd_seq,snd_pcm
snd_page_alloc         17424  2 snd_hda_intel,snd_pcm
compat_ioctl32         16768  1 uvcvideo
snd_hwdep              16520  1 snd_hda_intel
snd                    68984  22 snd_hda_intel,snd_seq_dummy,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_hwdep
videodev               40576  2 uvcvideo,compat_ioctl32
firewire_ohci          30724  0 
firewire_core          45632  1 firewire_ohci
ppdev                  16008  0 
i2c_nforce2            15880  0 
parport_pc             35096  0 
k8temp                 13312  0 
v4l1_compat            21124  2 uvcvideo,videodev
hwmon                  11320  1 k8temp
pcspkr                 11264  0 
forcedeth              62352  0 
parport                43168  2 ppdev,parport_pc
pata_amd               21508  0 
soundcore              15248  1 snd
crc_itu_t              10496  1 firewire_core
i2c_core               29856  1 i2c_nforce2
joydev                 19712  0 
ata_generic            14084  0 
pata_acpi              13184  0 

Actually, I don't know how to downgrade, but I will do so if you can help me.
Comment 3 Hans de Goede 2008-11-30 10:02:22 EST
Ok, so you've got a uvcvideo cam, not a lot of surprise there really.

> Actually, I don't know how to downgrade, but I will do so if you can help me.

Ok, download libv4l-0.5.4-1.fc10.XXXX.rpm from here:
http://koji.fedoraproject.org/koji/buildinfo?buildID=70037

Where XXXX is i386 or x86_64 depending on wether you did a 32 or 64 bit install.

Then as root do (from a terminal):
rpm -Uvh --oldpackage libv4l-0.5.4-1.fc10.XXXX.rpm

Again replacing the XXXX

If the downgrade fixes things, please run cheese from a terminal like this:
LIBV4L2_LOG_FILENAME=/tmp/log1 cheese

And attach /tmp/log1 here. Then please upgrade to libv4l-0.5.5 which you can find here:
http://koji.fedoraproject.org/koji/buildinfo?buildID=70394

This can be done the same way as the downgrade and test again, if things then fail run cheese again like this:
LIBV4L2_LOG_FILENAME=/tmp/log2 cheese

And attach /tmp/log2 here, if things still work with 0.5.5 please upgrade to 0.5.6 by doing "yum update libv4l", and assuming that re-breaks things again run cheese:
LIBV4L2_LOG_FILENAME=/tmp/log2 cheese

And attach /tmp/log2.
Comment 4 Aioanei Rares 2008-11-30 11:31:32 EST
(In reply to comment #3)
> Ok, so you've got a uvcvideo cam, not a lot of surprise there really.
> 
> > Actually, I don't know how to downgrade, but I will do so if you can help me.
> 
> Ok, download libv4l-0.5.4-1.fc10.XXXX.rpm from here:
> http://koji.fedoraproject.org/koji/buildinfo?buildID=70037
> 
> Where XXXX is i386 or x86_64 depending on wether you did a 32 or 64 bit
> install.
> 
> Then as root do (from a terminal):
> rpm -Uvh --oldpackage libv4l-0.5.4-1.fc10.XXXX.rpm
> 
> Again replacing the XXXX
> 
> If the downgrade fixes things, please run cheese from a terminal like this:
> LIBV4L2_LOG_FILENAME=/tmp/log1 cheese
> 
> And attach /tmp/log1 here. Then please upgrade to libv4l-0.5.5 which you can
> find here:
> http://koji.fedoraproject.org/koji/buildinfo?buildID=70394
> 
> This can be done the same way as the downgrade and test again, if things then
> fail run cheese again like this:
> LIBV4L2_LOG_FILENAME=/tmp/log2 cheese
> 
> And attach /tmp/log2 here, if things still work with 0.5.5 please upgrade to
> 0.5.6 by doing "yum update libv4l", and assuming that re-breaks things again
> run cheese:
> LIBV4L2_LOG_FILENAME=/tmp/log2 cheese
> 
> And attach /tmp/log2.

Ok, it works with 0.5.4, log1 is attached. With 0.5.5 it doesn't work anymore, log 2 attached; let me know if I can help further.
Comment 5 Aioanei Rares 2008-11-30 11:32:25 EST
Created attachment 325133 [details]
Log for libv4l

libv4l 0.5.4
Comment 6 Aioanei Rares 2008-11-30 11:33:10 EST
Created attachment 325134 [details]
Log for libv4l (0.5.5) not working

0.5.5
Comment 7 Hans de Goede 2008-11-30 14:59:44 EST
Thanks for the log files!

Unfortunately I still don't know what the cause of this is. So I've made a new version with more debugging, can you please install the version from here:
http://koji.fedoraproject.org/koji/taskinfo?taskID=964642

You need to first click on the build for your arch and there you will find the rpm file to download

And the run cheese twice, like this:
LIBV4L2_LOG_FILENAME=/tmp/log1 cheese
LIBV4L2_LOG_FILENAME=/tmp/log2 LIBV4LCONVERT_NO_UVC=1 cheese

I expect the second try to actually work, where as the first one should fail. If this is not the case please let me know.
Comment 8 Hans de Goede 2008-12-01 03:34:38 EST
As already discussed in private mail:

Sorry, I screwed up and that build did not include the patch it was supposed to include, can you please try again with this build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=964736

Sorry and Thanks,

Hans

p.s.

Please make any further comments in bugzilla, so that if others start reading this bug they can make sense of things.
Comment 9 Aioanei Rares 2008-12-01 13:18:58 EST
(In reply to comment #8)
> As already discussed in private mail:
> 
> Sorry, I screwed up and that build did not include the patch it was supposed to
> include, can you please try again with this build:
> http://koji.fedoraproject.org/koji/taskinfo?taskID=964736
> 
> Sorry and Thanks,
> 
> Hans
> 
> p.s.
> 
> Please make any further comments in bugzilla, so that if others start reading
> this bug they can make sense of things.

It works with NO_UVC=1, but I still need to go back to 0.5.4, since I want my girlfriend to see me with gyachi. Logs attached. Let me know please if I can help further.
Comment 10 Aioanei Rares 2008-12-01 13:19:52 EST
Created attachment 325277 [details]
Non-working
Comment 11 Aioanei Rares 2008-12-01 13:20:16 EST
Created attachment 325278 [details]
Working
Comment 12 Hans de Goede 2008-12-01 14:27:35 EST
Thanks,

This is interesting / good info. But I'm afraid I need more puzzle pieces to see the whole image :)

Can you please do:
yum install xawtv
v4l-info > log

And then attach "log"? Thanks!
Comment 13 Hans de Goede 2008-12-02 08:50:23 EST
*** Bug 474111 has been marked as a duplicate of this bug. ***
Comment 14 Hans de Goede 2008-12-02 08:50:56 EST
Scrap my last comment, can you please install an even more verbose libv4l from
here:
http://koji.fedoraproject.org/koji/taskinfo?taskID=970791

And again do the 2 runs and attach the logfiles ?

Thanks for your patience.
Comment 15 lionghostshop 2008-12-02 10:02:52 EST
Created attachment 325378 [details]
The bug still exist 

I installed libv4l-debuginfo-0.5.6-1.fc10.4.i386.rpm.
The bug still exists.
by LIBV4L2_LOG_FILENAME=/tmp/log2 LIBV4LCONVERT_NO_UVC=1 cheese.
I have attach the log file


------------
Can you please install this test build of libv4l:
http://koji.fedoraproject.org/koji/taskinfo?taskID=970791

You need to first click on the build for your arch and there you will find the
rpm file to download

And then run cheese twice from a terminal, like this:
LIBV4L2_LOG_FILENAME=/tmp/log1 cheese
LIBV4L2_LOG_FILENAME=/tmp/log2 LIBV4LCONVERT_NO_UVC=1 cheese

And then attach both /tmp/log1 and /tmp/log2 to bug 473771 ?

I expect the second try to actually work, where as the first one should fail.
If this is not the case please let me know.
Comment 16 Hans de Goede 2008-12-02 17:47:37 EST
As this bug has been reported to me by several channels now, and with several different cams, it has really got my attention. So today I've went out and bought myself an Microsoft VX-700. So i've managed to reproduce and fix this now.

You can download an updated package fixing this here:
http://koji.fedoraproject.org/koji/buildinfo?buildID=72926

Note to lionghostshop, you need the package without the -debuginfo in the name.

This updated package will be made available as a regular update asap.
Comment 17 Fedora Update System 2008-12-02 17:49:35 EST
libv4l-0.5.7-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/libv4l-0.5.7-1.fc10
Comment 18 Fedora Update System 2008-12-02 17:58:14 EST
libv4l-0.5.7-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/libv4l-0.5.7-1.fc9
Comment 19 Fedora Update System 2008-12-06 23:23:30 EST
libv4l-0.5.7-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2008-12-06 23:24:23 EST
libv4l-0.5.7-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.