Bug 473791 - Anaconda should allow user to disable SELinux during install
Anaconda should allow user to disable SELinux during install
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
10
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-30 11:11 EST by Marcelo
Modified: 2008-12-01 12:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-01 12:00:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcelo 2008-11-30 11:11:44 EST
Description of problem:
Anaconda does not offer an option for the user to disable SELinux at install time anymore. For now, SELinux is still too problematic and is the source of many weird and hard to debug problems for desktop users. Every time I install a new version of Fedora I give SELinux a try and then always regret later I did it.
I think the user should be allowed to disable it at install time, or at least he should be given a warn that SELinux is being set to enforce mode, clarified about the kind of problems that this may bring to him and advised on how to disable SELinux in case of problems.
I got five very weird problems in F10 because of SELinux until I've tracked the cause to it and disabled it. I didn't get SELinux Troubleshooter warnings in any of them. One of the problems happens before login (kdm won't allow regular users to login to kde if SELinux is in enforce mode), so SELinux Troubleshooter couldn't advise in this case anyway.
I can only imagine the number of problems novice users face because of 
SELinux without being able to solve them, either for not being aware of 
SELinux existence and "functionality" or for not knowing how to disable 
this thing.
Comment 1 Jeremy Katz 2008-12-01 12:00:39 EST
If you boot with 'selinux=0', then selinux will be preserved as disabled after the install.  Showing it as an option gives users who *don't* come into things with a preconceived notion of problems a question that they can't possibly answer.

Note You need to log in before you can comment on or make changes to this bug.