Bug 473816 - Thunderbird - Copies and Folders dialog expects taller window than it has.
Thunderbird - Copies and Folders dialog expects taller window than it has.
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-30 16:47 EST by Darren Fulton
Modified: 2009-01-21 10:50 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-21 10:50:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Picture of window that won't resize down small enough to work on netbook. (51.59 KB, image/png)
2008-12-02 22:54 EST, Darren Fulton
no flags Details
Thunderbird preferences displayed on 480 px high monitor does not display all content. (78.40 KB, image/png)
2008-12-02 23:17 EST, Darren Fulton
no flags Details
Thunderbird preferences displayed on ~520 px high monitor does display all content. (70.58 KB, image/png)
2008-12-02 23:20 EST, Darren Fulton
no flags Details
Screenshot of reproduction (314.65 KB, image/png)
2008-12-03 12:17 EST, Matěj Cepl
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 474603 None None None Never

  None (edit)
Description Darren Fulton 2008-11-30 16:47:17 EST
+++ This bug was initially created as a clone of Bug #473668 +++

Description of problem:
Some application windows, usually configuration menus in various programs included in Fedora 10 are too large to be fully displayed on devices with small screens.  These windows typically do not have vertical scroll bars.  Since the buttons to save, cancel, etc. are typically at the bottom of the window and the window is too tall to display the buttons, such programs are largely unusable.  

Version-Release number of selected component (if applicable):


How reproducible:
Very reproducible.

Steps to Reproduce:
1.  Install Fedora 10 on an OLPC XO or EEEPC 7xx netbook.
2.  Log into GNOME, KDE, or LXDE.
3.  Launch Ekiga, open "Configuration Assistant".  OR, launch Thunderbird, open Account Settings, click "Copies and Folders".  OR, launch KOrganizer, open Configure KOrganizer [window too wide also].  There are many other examples, including the gnome-mouse-properties dialog window.
  
Actual results:
Window too big to be useful.

Expected results:
Window displays at size equal to or less than the usable screen space available on the monitor and all data, options, and features are available.

Additional info:

--- Additional comment from pbrobinson@gmail.com on 2008-11-30 16:06:53 EDT ---

I actually reported this upstream to ekiga quite a while ago. I've attached the bug report number via the external bug reference.

--- Additional comment from dfulton@gmail.com on 2008-11-30 16:14:59 EDT ---

Thank you.  What shall we do about all of the other applications that have the same issue?  Should we open one ticket per application or should we open one ticket and list all of the offending applications within that ticket?

--
Darren Fulton

--- Additional comment from pbrobinson@gmail.com on 2008-11-30 16:41:17 EDT ---

A new bug report for every issue. There's only one application that can be assigned per bug,
Comment 1 Matěj Cepl 2008-12-01 19:24:34 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf (if you have one) whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Darren Fulton 2008-12-02 22:52:00 EST
Thank you for your response.  I am not using an xorg.conf file.  The problem is that these particular windows will not display at a small enough size to be usable.  I am attaching a screenshot of the Ekiga "Configuration Assistant" window next to KDE Screen Ruler to illustrate the issue.  If the window had a scroll bar, it probably would be fine.  Since it doesn't, it is unusable on devices with maximum resolution of $numberX480 or smaller.
Comment 3 Darren Fulton 2008-12-02 22:54:11 EST
Created attachment 325475 [details]
Picture of window that won't resize down small enough to work on netbook.
Comment 4 Darren Fulton 2008-12-02 23:17:14 EST
Created attachment 325478 [details]
Thunderbird preferences displayed on 480 px high monitor does not display all content.

Notice that you cannot see "Configure text format behavior" in this picture.  It does display when at the window is ~530 px high.  See next picture.
Comment 5 Darren Fulton 2008-12-02 23:20:20 EST
Created attachment 325479 [details]
Thunderbird preferences displayed on ~520 px high monitor does display all content.

Notice that you can see "Configure text format behavior" in this picture.  It didn't appear when the window was ~460 px high.  See previous picture.
Comment 6 Darren Fulton 2008-12-02 23:27:38 EST
(In reply to comment #2)
> Thank you for your response.  I am not using an xorg.conf file.  The problem is
> that these particular windows will not display at a small enough size to be
> usable.  I am attaching a screenshot of the Ekiga "Configuration Assistant"
> window next to KDE Screen Ruler to illustrate the issue.  If the window had a
> scroll bar, it probably would be fine.  Since it doesn't, it is unusable on
> devices with maximum resolution of $numberX480 or smaller.

I also attached 2 screenshots that show that the Thunderbird preferences window won't display all information when displayed at a height of less than ~512 pixels.  With a panel bar or two, the minimum screen resolution is about 600 px high, which is less than what is available on the Asus EeePC 700 series, the OLPC XO, etc.
Comment 7 Matěj Cepl 2008-12-03 12:17:14 EST
Created attachment 325565 [details]
Screenshot of reproduction

Actually, this has apparently nothing to do with size of the screen -- I have 1280x800 here, window is not squeezed or anything, and yet still the display is wrong.
Comment 8 Darren Fulton 2008-12-03 13:05:00 EST
Thank you.  I looked at your screenshot.  Is the problem in your case simply that the window is too narrow initially, but you can resize it horizontally and make it display properly?
Comment 9 Matěj Cepl 2008-12-03 13:12:49 EST
yes, it is
Comment 10 Darren Fulton 2008-12-05 12:37:14 EST
Changed summary from "Copies and Folders dialog expects wider window than it has"

Thunderbird - Copies and Folders dialog expects taller window than it has.
Comment 11 Darren Fulton 2009-01-21 08:38:28 EST
This article will be slightly interesting to anyone that has had difficulty using common programs on devices with small screens:

http://www.computerworld.com.au/article/273605/move_over_gnome_ubuntu_mobile_looks_qt_other_desktop_environments

From the article:
     Mandala said, adding one of the biggest challenges is reminding 
     developers to write applications for 800 by 600 screen resolutions
     found in smaller devices. 'The standard [resolution] for GNOME 
     [apps] is 800 by 600, but not all apps are. 

I think 800x600 might be too big and that applications ideally would function (not necessarily comfortably) at 800x480 or so.
Comment 12 Matěj Cepl 2009-01-21 10:50:38 EST
We filed this bug in the upstream database (https://bugzilla.mozilla.org/show_bug.cgi?id=474603) and believe that it is more appropriate to let it be resolved upstream.

Red Hat will continue to track the issue in the centralized upstream bug tracker, and will review any bug fixes that become available for consideration in future updates.

Thank you for the bug report.

Note You need to log in before you can comment on or make changes to this bug.