Bug 473820 - Window too large to fit on small device's screen
Window too large to fit on small device's screen
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-30 17:01 EST by Darren Fulton
Modified: 2008-12-06 12:36 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-06 12:36:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Firefox Preferences - Main - Add-ons section hidden due to small screen (70.12 KB, image/png)
2008-12-05 12:22 EST, Darren Fulton
no flags Details
Firefox Preferences - Privacy - Private data section hidden due to small screen (74.49 KB, image/png)
2008-12-05 12:24 EST, Darren Fulton
no flags Details
Firefox Preferences - Advanced - Network - Settings - Proxy section broken due to small screen (73.72 KB, image/png)
2008-12-05 12:26 EST, Darren Fulton
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 468246 None None None Never

  None (edit)
Description Darren Fulton 2008-11-30 17:01:58 EST
+++ This bug was initially created as a clone of Bug #473668 +++

Description of problem:
Some application windows, usually configuration menus in various programs included in Fedora 10 are too large to be fully displayed on devices with small screens.  These windows typically do not have vertical scroll bars.  Since the buttons to save, cancel, etc. are typically at the bottom of the window and the window is too tall to display the buttons, such programs are largely unusable.  

Version-Release number of selected component (if applicable):


How reproducible:
Very reproducible.

Steps to Reproduce:
1.  Install Fedora 10 on an OLPC XO or EEEPC 7xx netbook.
2.  Log into GNOME, KDE, or LXDE.
3.  Launch Ekiga, open "Configuration Assistant".  OR, launch Thunderbird, open Account Settings, click "Copies and Folders".  OR, launch KOrganizer, open Configure KOrganizer [window too wide also].  There are many other examples, including the gnome-mouse-properties dialog window.

In Firefox, under Preferences, some of the tabs require that the available screen space be taller than Height: 440 to fully display all of the information and allow it to be fully functional.
  
Actual results:
Window too big to be useful.  Window does not fully fit on screen.

Expected results:
Window displays at size equal to or less than the usable screen space available on the monitor and all data, options, and features are available.

Additional info:

--- Additional comment from pbrobinson@gmail.com on 2008-11-30 16:06:53 EDT ---

I actually reported this upstream to ekiga quite a while ago. I've attached the bug report number via the external bug reference.

--- Additional comment from dfulton@gmail.com on 2008-11-30 16:14:59 EDT ---

Thank you.  What shall we do about all of the other applications that have the same issue?  Should we open one ticket per application or should we open one ticket and list all of the offending applications within that ticket?

--
Darren Fulton

--- Additional comment from pbrobinson@gmail.com on 2008-11-30 16:41:17 EDT ---

A new bug report for every issue. There's only one application that can be assigned per bug,
Comment 1 Matěj Cepl 2008-12-05 09:31:35 EST
What particular issues you have with firefox?

> some of the tabs require that the available screen space be taller than Height: 440 to fully display all of the information and allow it to be fully functional.

This is not something I could try to reproduce. Please, be as specific as possible and possibly attach screenshots illustrating the problem.

Thank you
Comment 2 Darren Fulton 2008-12-05 12:22:10 EST
Created attachment 325884 [details]
Firefox Preferences - Main - Add-ons section hidden due to small screen
Comment 3 Darren Fulton 2008-12-05 12:24:01 EST
Created attachment 325885 [details]
Firefox Preferences - Privacy - Private data section hidden due to small screen
Comment 4 Darren Fulton 2008-12-05 12:26:15 EST
Created attachment 325886 [details]
Firefox Preferences - Advanced - Network - Settings - Proxy section broken due to small screen
Comment 5 Darren Fulton 2008-12-05 12:38:44 EST
Thank you.  I added screenshot attachments with descriptions.  Using the kruler screen ruler or xwininfo you can figure out how big a window is.  Some of these firefox preferences windows, when displayed at a small size (necessary for small devices), won't display all of the information.  Please view the screenshots and compare them to how the windows look on a larger screen and you will see the problem.  You can test it yourself by resizing the windows down.  Thank you.
Comment 6 Matěj Cepl 2008-12-05 16:37:15 EST
Are you using KDE? If not, what kind of window manager you have?
Comment 7 Darren Fulton 2008-12-05 16:44:30 EST
(In reply to comment #6)
> Are you using KDE? If not, what kind of window manager you have?

Running KDE and LXDE.  Same behavior in each.  I don't think it has to do with the window manager.
Comment 8 Matěj Cepl 2008-12-06 12:36:41 EST
We filed this bug in the upstream database (https://bugzilla.mozilla.org/show_bug.cgi?id=468246) and believe that it is more appropriate to let it be resolved upstream.

Red Hat will continue to track the issue in the centralized upstream bug tracker, and will review any bug fixes that become available for consideration in future updates.

Thank you for the bug report.

Note You need to log in before you can comment on or make changes to this bug.