Bug 473823 - Xorg server crash in radeon_drv when resuming from suspend or switching virtual terminals
Xorg server crash in radeon_drv when resuming from suspend or switching virtu...
Status: CLOSED DUPLICATE of bug 472353
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
10
All Linux
medium Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-30 17:10 EST by Risto Kankkunen
Modified: 2008-12-07 22:45 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-07 22:45:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (608 bytes, text/plain)
2008-11-30 17:15 EST, Risto Kankkunen
no flags Details
Xorg.0.log.old after VT switch with xorg-x11-drv-ati-6.9.0-60.fc10.i386 (62.99 KB, text/plain)
2008-11-30 17:19 EST, Risto Kankkunen
no flags Details
Xorg.0.log.old after VT switch with xorg-x11-drv-ati-6.9.0-54.fc10.i386 (62.99 KB, text/plain)
2008-11-30 17:21 EST, Risto Kankkunen
no flags Details
Xorg.0.log.old after VT switch without config file (66.15 KB, text/plain)
2008-11-30 17:56 EST, Risto Kankkunen
no flags Details

  None (edit)
Description Risto Kankkunen 2008-11-30 17:10:46 EST
Description of problem:

After upgrading from Fedora 9 to Fedora 10 using preupgrade resume from Suspend mode doesn't work: the computer resumes and shows GDM login screen but after logging in none of the suspended programs exist any more.

I finally found out a stack trace in /var/log/Xorg.log.old that seems to explain the behavior. Although it's not visible, Xorg apparently crashes while being resumed from Suspend and loses the programs in the X session. It then immediately restarts and the user sees the login screen.

Just recently I found out that the server crashes also when switching to/from another virtual terminal:

Backtrace:
0: /usr/bin/Xorg(xorg_backtrace+0x3b) [0x812bc5b]
1: /usr/bin/Xorg(xf86SigHandler+0x51) [0x80bcc81]
2: [0x110400]
3: /usr/lib/xorg/modules/drivers//radeon_drv.so [0x3774cb]
4: /usr/lib/xorg/modules/drivers//radeon_drv.so(radeon_update_dri_buffers+0x6f) 
[0x37760f]
5: /usr/lib/xorg/modules/drivers//radeon_drv.so(RADEONEnterVT+0xbb) [0x3490db]
6: /usr/bin/Xorg [0x80d1fd1]
7: /usr/bin/Xorg [0x80c4c74]
8: /usr/bin/Xorg(xf86Wakeup+0x3d3) [0x80bd993]
9: /usr/bin/Xorg(WakeupHandler+0x52) [0x8089c22]
10: /usr/bin/Xorg(WaitForSomething+0x1a3) [0x8128fa3]
11: /usr/bin/Xorg(Dispatch+0x7e) [0x8085bce]
12: /usr/bin/Xorg(main+0x47d) [0x806b71d]
13: /lib/libc.so.6(__libc_start_main+0xe5) [0x6ae6d5]
14: /usr/bin/Xorg [0x806ab01]

I suspect there is a common problem behind the both problems.

I noticed the problem with xorg-x11-drv-ati-6.9.0-54, the problem remains even after upgrading to xorg-x11-drv-ati-6.9.0-60.

How reproducible:
Always

Steps to Reproduce:
1. Open some programs in the X session
2. Press Control-Alt-F2
3. Press Alt-F1
  
Actual results:
GDM login, started programs gone

Expected results:
Started programs visible
Comment 1 Risto Kankkunen 2008-11-30 17:15:02 EST
Created attachment 325152 [details]
xorg.conf
Comment 2 Risto Kankkunen 2008-11-30 17:19:50 EST
Created attachment 325153 [details]
Xorg.0.log.old after VT switch with xorg-x11-drv-ati-6.9.0-60.fc10.i386
Comment 3 Risto Kankkunen 2008-11-30 17:21:53 EST
Created attachment 325154 [details]
Xorg.0.log.old after VT switch with xorg-x11-drv-ati-6.9.0-54.fc10.i386
Comment 4 Risto Kankkunen 2008-11-30 17:26:02 EST
The model of the laptop having this problem is Dell Latitude D600.
Comment 5 Risto Kankkunen 2008-11-30 17:56:32 EST
Created attachment 325157 [details]
Xorg.0.log.old after VT switch without config file

The problem persists even without /etc/X11/xorg.conf.
Comment 6 Matěj Cepl 2008-12-01 10:13:33 EST
Lovely backteace, thanks!
Comment 7 Sam Tygier 2008-12-03 07:26:41 EST
this is probably related to or a dupe of Bug 472353
Comment 8 Risto Kankkunen 2008-12-03 14:22:23 EST
(In reply to comment #7)
> this is probably related to or a dupe of Bug 472353

Thanks, Sam! Looks pretty identical. Sorry I didn't find that before submitting.

Do you know any workaround for this? A laptop without a working suspend is pretty useless. I'd switch back to Fedora 9, but I guess it's not that straight forward...
Comment 9 Ravikiran Rajagopal 2008-12-05 16:12:08 EST
I have the same problem as well. I am running F10 on a Thinkpad T42 with an RV350 card. My kernel is 2.6.27.7-135.fc10.i686 along with xorg-x11-drv-ati version 6.9.0-61.fc10.i386; I am using the kernel mentioned above (from koji) rather than the base one since the base one does not allow DRI. Interestingly enough, the backtrace is identical to yours, which seems to imply that 0x110400 is an address that is hard-coded somewhere. The same issue occurs with suspending using tuxonice as well.
Comment 10 Orion Poplawski 2008-12-07 22:45:52 EST

*** This bug has been marked as a duplicate of bug 472353 ***

Note You need to log in before you can comment on or make changes to this bug.