Bug 473858 - system-config-network gives parsing error if /etc/hosts contain entry like a.abcd.com
system-config-network gives parsing error if /etc/hosts contain entry like 10...
Status: CLOSED DUPLICATE of bug 473919
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-11-30 23:09 EST by Arvind Deshpande
Modified: 2008-12-01 10:24 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-12-01 10:24:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Arvind Deshpande 2008-11-30 23:09:19 EST
Description of problem:If /etc/hosts contain a line like a.abcd.com, starting "system-config-network" gives "Parsing error"

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. vi /etc/hosts
2. Enter a line like " a.abnad.com"
3. As a root invoke system-config-network
4. Notice the "Parsing error while processing /etc/hosts file at line no N"
Actual results:

Expected results: a.abnad.com is a valid name and IMHO starting UI should not result in an error.

Additional info: If you change
/usr/share/system-config-network/netconfpkg/NC_functions.py line no 250
From :'([a-zA-Z]|[0-9])+(-|[a-zA-Z]|-[0-9])*([a-zA-Z]|[0-9])+$')
To   :'([a-zA-Z]|[0-9])*(-|[a-zA-Z]|-[0-9])*([a-zA-Z]|[0-9])+$')

It does not produce an error any more.
Comment 1 Jiri Moskovcak 2008-12-01 10:24:43 EST

*** This bug has been marked as a duplicate of bug 473919 ***

Note You need to log in before you can comment on or make changes to this bug.