Bug 473892 - Init script for dund is missing.
Init script for dund is missing.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bluez (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-01 06:00 EST by Jan ONDREJ
Modified: 2009-08-05 19:15 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-24 13:09:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan ONDREJ 2008-12-01 06:00:26 EST
Description of problem:
After upgrade to F10, bluez-utils has been replaced by bluez package.
There is no /etc/rc.d/init.d/dund script in this new package and may be also sysconfig scripts are missing.
Dund is not running after upgrade. Is there any other way to do this?
May be a new place for sysconfig files can be /etc/sysconfig/bluetooth,
but an requirement for starting dund from an init script is still present.

Version-Release number of selected component (if applicable):
bluez-4.17-2.fc10.i386


How reproducible:
Always.


Actual results:
No dund is running after upgrade.


Expected results:
An running dund.
Comment 1 David Woodhouse 2009-04-28 06:53:46 EDT
We didn't include the initscript because we weren't aware that anyone was successfully using dund in this mode. If you make it run, does it actually work for you? In what mode are you using it?
Comment 2 Jan ONDREJ 2009-04-28 07:32:11 EDT
I am using dund with nokia phone, connecting to internet over bluetooth.

Worked well with older bluez and is working well too with current, just I need to start dund manually.

My /etc/sysconfig/dund file:
DUNDARGS='--listen --channel 4 call dun'

Do you need more information?
Comment 3 Bastien Nocera 2009-04-29 06:29:47 EDT
Split it off in a separate -compat sub-package. Could you please test this build, and let us know whether it works for you:
http://koji.fedoraproject.org/koji/taskinfo?taskID=1328268
Comment 4 Jan ONDREJ 2009-04-29 06:55:02 EDT
Can you request a build for Fedora 10?
My system is an Fedora 10 and I can't update to an unstable system.
Then I can test your package.
Comment 5 Bastien Nocera 2009-04-29 07:26:08 EDT
No, I need it tested before backporting it. You should be able to install that package easily on F10 though.
Comment 6 Nerijus Baliūnas 2009-04-29 10:02:09 EDT
I installed bluez-compat-4.37-2.fc12.i586.rpm and ran service dund start, and after that I can connect to internet over bluetooth with my Palm.
Comment 7 Jan ONDREJ 2009-04-29 12:51:28 EDT
Also works perfectly for me.

bluez-hcidump-1.42-2.fc10.i386
bluez-compat-4.37-2.fc12.i586
bluez-4.37-2.fc12.i586
bluez-gnome-1.8-12.fc10.i386
bluez-libs-4.37-2.fc12.i586
bluez-libs-devel-4.37-2.fc12.i586
Comment 8 Nerijus Baliūnas 2009-08-05 19:15:43 EDT
There is no bluez-compat package available in F11. Could you please backport it?

Note You need to log in before you can comment on or make changes to this bug.