Bug 473912 - kchmviewer cannot display chm file contents
kchmviewer cannot display chm file contents
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kchmviewer (Show other bugs)
rawhide
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Patrice Dumas
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-01 07:56 EST by Deepak Shrestha
Modified: 2008-12-24 13:46 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-24 13:41:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Deepak Shrestha 2008-12-01 07:56:34 EST
Description of problem:

kchmviewer only displays the table of contents in left pane but cannot show the page in right pane.

Version-Release number of selected component (if applicable):
kchmviewer-4.0-0.4.beta3.fc10.1.i386

How reproducible:
often

Steps to Reproduce:
1. yum install kchmviewer  (in Fedora 10)
2. installs current package kchmviewer-4.0-0.4.beta3.fc10.1.i386
3. run kchmviewer and open the chm file
  
Actual results:
topic pages are not displayed in right pane. same chm file is well displayed by xchm.

Expected results:
should open chm files as the name suggests.

Additional info:
Comment 1 Patrice Dumas 2008-12-01 08:03:37 EST
Could you please give a chm file that you can legally give and that shows the bug?
Comment 2 Jose Pedro Oliveira 2008-12-02 12:00:53 EST
From: http://www.kchmviewer.net/

Dec 01, 2008   Version 4.0 released.

The major feature of this release is parsing binary table of contents and indexes, which speeds up loading CHM files up to five times. Two most annoying bugs were fixed as well. This release will only for Qt4 or KDE4.
...
Comment 3 Deepak Shrestha 2008-12-03 02:59:46 EST
(In reply to comment #1)
> Could you please give a chm file that you can legally give and that shows the
> bug?

Hi,

The chm file I have is about 10MB. If its OK for you I can send it in your mail.
Comment 4 Patrice Dumas 2008-12-03 05:42:26 EST
You can try, but I think it is too big. 

As jpo mentionned, though, there is a new version, so maybe you can also wait for me to update kchmviewer (I am likely to do that in the coming days, and for sure in the week end).
Comment 5 Deepak Shrestha 2008-12-03 08:47:20 EST
(In reply to comment #4)
> You can try, but I think it is too big. 

Yes I guess so. I guess you can try any chm file you have.

> 
> As jpo mentionned, though, there is a new version, so maybe you can also wait
> for me to update kchmviewer (I am likely to do that in the coming days, and for
> sure in the week end).

Sure, no problem. As the package name suggests that it is still in beta.
What about this one? should I close this topic? I just reported this bug as suggested to me on fedora list.

Thanks
Comment 6 Patrice Dumas 2008-12-03 09:30:53 EST
Don't close, but just wait a bit for the update, to see if it solves your issue.
Comment 7 Patrice Dumas 2008-12-03 19:39:55 EST
I have rebuilt locally kchmviewer, but I have trouble (In reply to comment #3)
> (In reply to comment #1)
> > Could you please give a chm file that you can legally give and that shows the
> > bug?
> 
> Hi,
> 
> The chm file I have is about 10MB. If its OK for you I can send it in your
> mail.

You could also use:
split --bytes=5MB  original_file.chm split_file.chm

and send by mail 
split_file.chmaa
split_file.chmab
Comment 8 Deepak Shrestha 2008-12-04 02:52:47 EST
(In reply to comment #7)
> I have rebuilt locally kchmviewer, but I have trouble (In reply to comment #3)
> > (In reply to comment #1)
> > > Could you please give a chm file that you can legally give and that shows the
> > > bug?
> > 
> > Hi,
> > 
> > The chm file I have is about 10MB. If its OK for you I can send it in your
> > mail.
> 
> You could also use:
> split --bytes=5MB  original_file.chm split_file.chm
> 
> and send by mail 
> split_file.chmaa
> split_file.chmab

Hi,

I have sent you the file split into three part (rar format). Hope it helps. :-)
Comment 9 Patrice Dumas 2008-12-04 05:13:33 EST
(In reply to comment #8)

> I have sent you the file split into three part (rar format). Hope it helps. :-)

I got it, thanks. I can reproduce your issue, and it seems to be fine 
with 4.0, so I will do an update.
Comment 10 Fedora Update System 2008-12-04 06:07:31 EST
kchmviewer-4.0-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/kchmviewer-4.0-1.fc9
Comment 11 Fedora Update System 2008-12-04 06:08:15 EST
kchmviewer-4.0-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/kchmviewer-4.0-1.fc10
Comment 12 Fedora Update System 2008-12-06 23:28:51 EST
kchmviewer-4.0-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update kchmviewer'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-10873
Comment 13 Fedora Update System 2008-12-06 23:32:04 EST
kchmviewer-4.0-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kchmviewer'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-10905
Comment 14 Deepak Shrestha 2008-12-07 07:59:10 EST
(In reply to comment #13)
> kchmviewer-4.0-1.fc10 has been pushed to the Fedora 10 testing repository.  If
> problems still persist, please make note of it in this bug report.
>  If you want to test the update, you can install it with 
>  su -c 'yum --enablerepo=updates-testing update kchmviewer'.  You can provide
> feedback for this update here:
> http://admin.fedoraproject.org/updates/F10/FEDORA-2008-10905

yum gives "No Packages marked for Update" when trying to update.
Comment 15 Patrice Dumas 2008-12-08 07:22:32 EST
(In reply to comment #14)
> (In reply to comment #13)
> > kchmviewer-4.0-1.fc10 has been pushed to the Fedora 10 testing repository.  If
> > problems still persist, please make note of it in this bug report.
> >  If you want to test the update, you can install it with 
> >  su -c 'yum --enablerepo=updates-testing update kchmviewer'.  You can provide
> > feedback for this update here:
> > http://admin.fedoraproject.org/updates/F10/FEDORA-2008-10905
> 
> yum gives "No Packages marked for Update" when trying to update.

did you enable the updates-testing repo, with:
yum --enablerepo=updates-testing update kchmviewer
Comment 16 Deepak Shrestha 2008-12-08 23:19:07 EST
> did you enable the updates-testing repo, with:
> yum --enablerepo=updates-testing update kchmviewer

Yes. I tried removing the installed kchmviewer too and trying to reinstall with '--enablerepo=updates-testing' hoping new package will be installed but yum still comes up with old pacakage 'kchmviewer-4.0-0.4.beta3.fc10.1.i386'. Tried update after that (with updates-testing enabled) still "No Packages marked for Update". :-)
Comment 17 Patrice Dumas 2008-12-12 15:09:00 EST
Strange, it is on
http://download.fedora.redhat.com/pub/fedora/linux/updates/testing/10/i386/kchmviewer-4.0-1.fc10.i386.rpm
with timestamp 04-Dec-2008.

Maybe you use a stale mirror?
Comment 18 Deepak Shrestha 2008-12-14 23:07:48 EST
(In reply to comment #17)
> Strange, it is on
> http://download.fedora.redhat.com/pub/fedora/linux/updates/testing/10/i386/kchmviewer-4.0-1.fc10.i386.rpm
> with timestamp 04-Dec-2008.
> 
> Maybe you use a stale mirror?

now yum found the new package. probably it took some time to reflect the changes in repo.

installed the new kchmviewer package 'kchmviewer-4.0-1.fc10.i386' and its working fine.

Problem solved.
Comment 19 Fedora Update System 2008-12-24 13:41:48 EST
kchmviewer-4.0-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2008-12-24 13:46:42 EST
kchmviewer-4.0-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.