Bug 47399 - error booting grub floppy
error booting grub floppy
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: grub (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-05 07:04 EDT by Gene Czarcinski
Modified: 2015-01-07 18:47 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-14 13:00:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2001-07-05 07:04:25 EDT
Description of Problem:
The grub info documentation says that you can create a grub floppy by
dd'ing stage1 and stage2 to a floppy disk.  However, booting this floppy
gives an error during stage2.

How Reproducible:
always

Steps to Reproduce:
1. fdformat /dev/fd0H1440
2. dd if=/boot/grub/i386-redhat/stage1 of=/dev/fd0 bs=515 count=1
3. dd if=/boot/grub/i386-redhat/stage2 of=/dev/fd0 bs=512 skip=1
4. boot the floppy

Actual Results:
error in stage2

Expected Results:
grub running

Additional Information:
Comment 1 Steve Bonneville 2001-07-06 10:53:05 EDT
The info documentation actually says:

dd if=stage2 of=/dev/fd0 bs=512 seek=1
                                ^^^^
This worked for me.
Comment 2 Gene Czarcinski 2001-07-07 02:40:29 EDT
pilot error
Comment 3 Gene Czarcinski 2001-07-14 13:00:44 EDT
I am reopening this because there is a "bug" of sorts.

Sometime after closing this report previously, I tried to build another grub
boot floppy using the dd of stage1 and stage2 and again I came up with something
that got an error only this time I very importantly used the seek=1 for stage2.

After some experimenting and comparing stuff with hexdump, I have found the
problem:  to create a stage1/stage2 grub boot floppy, you MUST use a stage2
which is NOT being used by grub on a harddisk.  That is, you must use a stage2
from a system where grub is not installed and lilo or a boot-floppy-only is used.

Proposed solution:

1. update the (info) documentation to reflect this situation.

2. Change the grub rpm to install a second copy of stage2 as something like
"stage2.4.floppy".

3. Optionally, create a man page such as grub.floppy to explain this.
Comment 4 Jeremy Katz 2001-07-19 16:23:29 EDT
Pristine grub stages are now properly in /usr/share/grub/i386-redhat...   also,
you might want to try /sbin/grub-install /dev/fd0 since it's easier =)

Applies to grub-0.90-6 and up

Note You need to log in before you can comment on or make changes to this bug.