Bug 474013 - logrotate documentation does not discuss script arguments
logrotate documentation does not discuss script arguments
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: logrotate (Show other bugs)
5.2
i686 Linux
low Severity low
: rc
: ---
Assigned To: Jan Kaluža
qe-baseos-daemons
: ManPageChange
Depends On:
Blocks: 602643 604981
  Show dependency treegraph
 
Reported: 2008-12-01 14:25 EST by Michael Francis McEniry
Modified: 2013-04-15 05:00 EDT (History)
4 users (show)

See Also:
Fixed In Version: logrotate-3.7.4-12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 602643 604981 (view as bug list)
Environment:
Last Closed: 2011-05-18 10:57:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Francis McEniry 2008-12-01 14:25:19 EST
Description of problem:
The documentation for logrotate does not discuss how it provides arguments to prerotate/postrotate scripts.

Version-Release number of selected component (if applicable):
3.7.4-9


The man page for logrotate does not mention arguments passed to the prerotate and postrotate scripts. However, bugs 241766 and 445554 indicate that logrotate passes as arguments to the script the matching log files that (are about to be / have just been) rotated.

What is the official behavior? If multiple log files are matched in a block, then how does logrotate pass those as arguments? Is the behavior altered by wildcards versus explicit names? Is the behavior altered by sharedscripts versus nosharedscripts?
Comment 1 David Tonhofer 2010-04-24 12:00:22 EDT
Seconding this bug. The man page should actually *also* say that a bash script is actually accepted between the "prerotate/postrotate" and "endscript" tags (Or is it a sh script? how about on a Debian system? Can another shell be chosen?) It is all very experimentalist.

Still open for logrotate-3.7.4-9
Comment 4 RHEL Product and Program Management 2011-01-11 15:39:31 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 5 RHEL Product and Program Management 2011-01-11 18:00:41 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 10 errata-xmlrpc 2011-05-18 10:57:36 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0816.html

Note You need to log in before you can comment on or make changes to this bug.