Bug 474064 - Default /etc/screenrc not tweaking all xterms
Default /etc/screenrc not tweaking all xterms
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: screen (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Miroslav Lichvar
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-01 18:13 EST by Tom Sorensen
Modified: 2013-04-12 15:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The default configuration file contains several tweaks for the xterm terminal emulator, such as displaying the list of windows in the title bar. However, due to the strict use of "xterm" in patterns to match the terminal name, these options were not applied to other xterm variants like xterm-256color or xterm-88color. This update corrects the relevant patterns to match all xterm names, resolving this issue.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-30 04:07:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0401 normal SHIPPED_LIVE screen bug fix update 2011-03-30 04:07:03 EDT

  None (edit)
Description Tom Sorensen 2008-12-01 18:13:15 EST
Description of problem:
The default /etc/screenrc has several tweaks for specific terminals. In several cases these tweaks are redundant or contradictory (see below), and they are not applied to all the terminals they should be.

Version-Release number of selected component (if applicable):
screen-4.0.3-1.el5

How reproducible:
100%

Steps to Reproduce:
1. Connect to system remotely or use local xterm
2. TERM=xterm-256color
3. screen
4. ^Aw
  
Actual results:
Window list is displayed on last line of terminal

Expected results:
Window list should be displayed in title bar.

Additional info:
There are a large number of term-specific tweaks in the supplied screenrc that are applied unevenly. In general anything applied to "xterm" should instead be applied to "xterm*" since xterm-88color, xterm-256color, etc. have the same capabilities, just more colors.

There are also duplicate statements (the terminfo xterm cs=... is repeated twice, as an example) and some contradictions (hs is disabled at least twice for xterm, then enabled with new escape sequences for enter, delete, and leave -- this is what makes the "change window title" example above work for xterm, but not xterm-*).
Comment 3 Jaromir Hradilek 2011-02-04 08:37:51 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The default configuration file contains several tweaks for the xterm terminal emulator, such as displaying the list of windows in the title bar. However, due to the strict use of "xterm" in patterns to match the terminal name, these options were not applied to other xterm variants like xterm-256color or xterm-88color. This update corrects the relevant patterns to match all xterm names, resolving this issue.
Comment 5 errata-xmlrpc 2011-03-30 04:07:21 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0401.html

Note You need to log in before you can comment on or make changes to this bug.