Bug 474088 - gcalctool ignores Degrees/Gradians/Radians radio buttons, assumes radians
gcalctool ignores Degrees/Gradians/Radians radio buttons, assumes radians
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gcalctool (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-02 00:43 EST by Matt Hirsch
Modified: 2009-07-18 11:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-18 11:54:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Hirsch 2008-12-02 00:43:49 EST
Description of problem:
The gcalctool in Fedora 10 ignores the Degrees/Gradians/Radians radio buttons and returns a result to trigonometric functions assuming that the input/output values are radians.

Version-Release number of selected component (if applicable):
gcalctool-5.24.1-2.fc10.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Start gcalctool
2. Change to scientific mode
3. Select Degrees radio button
4. Press Sin
5. Enter 90)
6. Press Enter
  
Actual results:
0.893996664

Expected results:
0

Additional info:
This worked in the F9 version of gcalctool. Also, I don't see gcalctool listed in the package list above, so I selected gcalculator.
Comment 1 Matt Hirsch 2008-12-02 00:44:46 EST
Of course, that should be

Expected results:
1.0
Comment 2 Tomas Mraz 2008-12-02 03:37:26 EST
(In reply to comment #0)
> This worked in the F9 version of gcalctool. Also, I don't see gcalctool listed
> in the package list above, so I selected gcalculator.

You did not look carefully enough. :)
Comment 3 Matt Hirsch 2008-12-02 11:01:26 EST
Ok, sorry about that.

I have a second computer with F10 x86_64 and gcalctool. I tried it out this morning, and on this one gcalctool is "stuck" in degrees mode. So maybe the bug is that the mode cannot be changed, not that it sticks specifically to radians.
Comment 4 Christopher Beland 2009-07-17 21:15:00 EDT
I was unable to reproduce this problem with gcalctool-5.26.2-1.fc11.i586.

If you are still running Fedora 10, you should be able to update to gcalctool-5.24.3-1.fc10.  Do you still experience the problem with that version?

If so: if you move ~/.gconf/apps/gcalctool/%gconf.xml aside and then start gcalctool, does that help?
Comment 5 Matt Hirsch 2009-07-17 23:48:37 EDT
The problem is gone with the latest version of gcalctool. Thanks.
Comment 6 Christopher Beland 2009-07-18 11:54:22 EDT
Excellent.

Note You need to log in before you can comment on or make changes to this bug.