Bug 474098 - man, immutable+append not documented
man, immutable+append not documented
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: e2fsprogs (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Eric Sandeen
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-02 03:19 EST by Petr Sklenar
Modified: 2008-12-02 06:52 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-02 06:52:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Sklenar 2008-12-02 03:19:36 EST
Description of problem:
most used function of chattr is +i and its not documented neither in man chattr nor man lsattr. 
"+a" is not documented as well.

chattr +i immutable.file 
[root@xen47 chattr]# lsattr 
----i-------- ./immutable.file


Version-Release number of selected component (if applicable):
e2fsprogs-1.39-15.el5

How reproducible:
alwways

Steps to Reproduce:
1.man chattr, search "i" or "a"
2.man lsattr, search "i" or "a"
3.
  
Actual results:
not in man

Expected results:
describtion in man

Additional info:
[root@xen47 chattr]# chattr +i immutable.file 
[root@xen47 chattr]# lsattr 
----i-------- ./immutable.file
Comment 1 Radek Bíba 2008-12-02 04:10:34 EST
man chattr:
ATTRIBUTES
A file with the ‘a’ attribute set can only be open in append mode for writing.  Only the superuser or a  process  possessing the CAP_LINUX_IMMUTABLE capability can set or clear this attribute.
...
A file with the ‘i’ attribute cannot be modified: it cannot be deleted or renamed, no link can be created to this file and no data can be written to the file.  Only the superuser or a process possessing the CAP_LINUX_IMMUTABLE capability can set or clear this attribute.

man lsattr:
DESCRIPTION
...See chattr(1) for a description of the attributes and what they mean.


If you think it's not enough, please propose a change.
Comment 2 Petr Sklenar 2008-12-02 06:52:19 EST
OK i am sorry I didn't see it among highlighted options,
its not a bug

Note You need to log in before you can comment on or make changes to this bug.