Bug 474135 - dual head dual dvi on i965 broken in fc10
dual head dual dvi on i965 broken in fc10
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
10
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-02 07:29 EST by Jes Sorensen
Modified: 2009-09-06 12:23 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-06 07:32:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
used to work xorg.conf file (1.77 KB, text/plain)
2008-12-02 07:29 EST, Jes Sorensen
no flags Details
Xorg.log (87.79 KB, text/plain)
2009-01-07 09:21 EST, Jes Sorensen
no flags Details

  None (edit)
Description Jes Sorensen 2008-12-02 07:29:27 EST
Created attachment 325366 [details]
used to work xorg.conf file

Description of problem:
Dual-head with Intel 965 gfx has stopped working when upgrading from fc9 to fc10. This is using a dual DVI riser card.

Version-Release number of selected component (if applicable):
xorg-x11-drv-i810-2.5.0-3.fc10.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Run FC9
2. Upgrade to FC10
3. Boot system
  
Actual results:


Expected results:


Additional info:
It looks like X simply decided to see my TMDS-2 port :-(

00:02.0 VGA compatible controller: Intel Corporation 82Q963/Q965 Integrated Graphics Controller (rev 02)
00:02.1 Display controller: Intel Corporation 82Q963/Q965 Integrated Graphics Controller (rev 02)

jes@eye3:~> xrandr
Screen 0: minimum 320 x 200, current 1280 x 1024, maximum 2560 x 1024
VGA disconnected (normal left inverted right x axis y axis)
TMDS-1 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 376mm x 301mm
   1280x1024      60.0*+
   1280x960       60.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
jes@eye3:~>
Comment 1 Jes Sorensen 2008-12-02 07:34:59 EST
Found a temporary workaround. Reverting back to the old driver:
xorg-x11-drv-i810-2.3.2-3.fc9.x86_64.rpm

bring back sanity:

jes@eye3:~> xrandr
Screen 0: minimum 320 x 200, current 2560 x 1024, maximum 2560 x 1024
VGA disconnected (normal left inverted right x axis y axis)
TMDS-1 connected 1280x1024+1280+0 (normal left inverted right x axis y axis) 376mm x 301mm
   1280x1024      60.0*+
   1280x960       60.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
TMDS-2 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 376mm x 301mm
   1280x1024      60.0*+
   1280x960       60.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
jes@eye3:~>
Comment 2 Matěj Cepl 2008-12-03 12:23:27 EST
Could we get /var/log/Xorg.0.log as well, please?

Thank you
Comment 3 Jes Sorensen 2009-01-07 09:21:07 EST
Created attachment 328377 [details]
Xorg.log

Here you go - I updated the driver in the mean time for testing, but the problem is the same.

Jes
Comment 4 Erik Jacobson 2009-01-29 12:00:53 EST
I ran in to a similar problem doing some testing on opensuse 11.1.
I was asked to open a freedesktop.org bug, which I did.

https://bugs.freedesktop.org/show_bug.cgi?id=19770

My hardware was a Dell Optiplex 745, Q965 chipset, two DVI displays connected.
One to the mainboard, one to the ADD2 card.  I had the same issue with xrandr
not showing the ADD2-attached display.
Comment 5 Erik Jacobson 2009-01-29 12:15:38 EST
Sorry, both DVI on ADD2 but only one seen.  System doesn't have mainboard
DVI connector (just VGA).
Comment 6 Vedran Miletić 2009-09-06 04:14:31 EDT
Jes, Erik: Does this still happen of Fedora 11 and Fedora 12 Snap1? fd.o bugzilla 19770 claims it's fixed.
Comment 7 Jes Sorensen 2009-09-06 06:36:35 EDT
Hi,

I think it's working. The F10->F11 settings changed a fair bit, but I have it working in F11 now.

It would be fine with me if you want to put this one to observe or close it.

Cheers,
Jes
Comment 8 Vedran Miletić 2009-09-06 07:32:16 EDT
Thanks for testing.

Note You need to log in before you can comment on or make changes to this bug.