Bug 474139 - unfinished transactions will cause removing half of system
unfinished transactions will cause removing half of system
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
10
All Linux
high Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-02 07:58 EST by Marcela Mašláňová
Modified: 2014-01-21 18:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-21 12:48:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from stderr (105.73 KB, text/plain)
2008-12-02 07:59 EST, Marcela Mašláňová
no flags Details

  None (edit)
Description Marcela Mašláňová 2008-12-02 07:58:51 EST
Yum offered me to run 'yum-complete-transaction'. I tried it, but it decided remove  half of my system. Now is yum trying to remove half of system, when I want remove one package. The problem is not occurring every time. Also I try run yum clean all, but that doesn't help.

Reproducer:
1. yum remove cronie (it's really important not to use yum -y :-) )
2. press N
3. output is attachment

rpm -q rpm
rpm-4.6.0-0.rc1.7.x86_64
rpm -q yum
yum-3.2.20-3.fc10.noarch
Comment 1 Marcela Mašláňová 2008-12-02 07:59:56 EST
Created attachment 325367 [details]
output from stderr
Comment 2 James Antill 2008-12-02 10:33:55 EST
 The yum-complete-transaction problem, might be interesting and is likely to be fixed ... but this isn't, it's a simple list of requirements.

---> Package cronie.x86_64 0:1.2-5.fc11 set to be erased                                                              
--> Processing Dependency: cronie for package: crontabs                                                               
--> Running transaction check                                                                                         
---> Package crontabs.noarch 0:1.10-26.fc11 set to be erased                                                          
--> Processing Dependency: crontabs for package: rpm                                               

...so here because you removed cronie, crontabs is going away (as it requires something cronie provides) and because crontabs is being removed rpm is going away (as it requires something crontabs provides) ... at which point a lot of stuff will go with rpm, and the box is useless.
Comment 3 seth vidal 2009-01-21 12:48:14 EST
I'd need more info - but I'm doubtful about the yum-complete-transaction issue.

Given the circumstances, though, I'm going to close this.

Note You need to log in before you can comment on or make changes to this bug.