Bug 47416 - Violent crashes on 2.2.19-6.2.1 SMP
Violent crashes on 2.2.19-6.2.1 SMP
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
i686 Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-05 08:05 EDT by Le Tanou Jerome
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-05 13:15:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (6.47 KB, text/plain)
2001-07-05 08:23 EDT, Le Tanou Jerome
no flags Details

  None (edit)
Description Le Tanou Jerome 2001-07-05 08:05:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; Win 9x 4.90)

Description of problem:
This server (Dell PowerEdge 300 Bi-PIII 800 1GB Memory) turned without 
problem on 2.2.19-6.2.1 SMP since June 10.
And since July 3 we had 2 violent crash.

Here's the log for the 07/03:

Jul  3 14:04:02 samba kernel: kmem_free: Bad obj addr (objp=e11b9800, 
name=dentry_cache)
Jul  3 14:04:02 samba kernel: Unable to handle kernel NULL pointer 
dereference at virtual address 00000000
Jul  3 14:04:02 samba kernel: current->tss.cr3 = 3590c000, %%cr3 = 3590c000
Jul  3 14:04:02 samba kernel: *pde = 00000000
Jul  3 14:04:02 samba kernel: Oops: 0002
Jul  3 14:04:02 samba kernel: CPU:    0
Jul  3 14:04:02 samba kernel: EIP:    0010:[kmem_cache_free+371/408]
Jul  3 14:04:02 samba kernel: EFLAGS: 00010286
Jul  3 14:04:02 samba kernel: eax: 0000003e   ebx: e11b9800   ecx: 
0000004a   edx: 00000026
Jul  3 14:04:02 samba kernel: esi: f7fff620   edi: 00000286   ebp: 
0004a5c3   esp: f5919e54
Jul  3 14:04:02 samba kernel: ds: 0018   es: 0018   ss: 0018
Jul  3 14:04:02 samba kernel: Process smbd (pid: 5391, process nr: 326, 
stackpage=f5919000)
Jul  3 14:04:02 samba kernel: Stack: 0000febb 00000001 e11b987c f0422310 
c0134deb f7fff620 e11b9800 f5919eb0
Jul  3 14:04:02 samba kernel:        f5919eb0 c020d984 0000febb 0000febb 
c0135f3c ffff517f 0000503a 00000000
Jul  3 14:04:02 samba kernel:        c0241c18 c020d984 c0241c18 dfbdff60 
dfbdff60 00000000 c8ac8280 c1050dd0
Jul  3 14:04:02 samba kernel: Call Trace: [<0000febb>] [<00000001>] 
[prune_dcache+275/340] [<0000febb>] [<0000febb>] 
try_to_free_inodes+316/396] [<0000503a>]
Jul  3 14:04:02 samba kernel:        [<00000000>] [<00000000>] 
[grow_inodes+30/440] [<00010004>] [<00000000>] [<00000000>] [<00000001>] 
[<00001280>]
Jul  3 14:04:02 samba kernel:        [get_new_inode+197/312] [<00000000>] 
[<0040233c>] [iget4+126/136] [<0040233c>] [<00000000>] [<00000000>] 
[<0040233c>]
Jul  3 14:04:02 samba kernel:        [iget+19/24] [<0040233c>] 
[<00000000>] [<00000000>] [ext2_lookup+84/124] [<0040233c>] 
[real_lookup+80/160] [<00000000>]
Jul  3 14:04:02 samba kernel:        [<00000001>] lookup_dentry+296/488] 
[<00000001>] [<0000000c>] [__namei+40/88] [<00000001>] 
[sys_newstat+42/140] [<00000001>]
Jul  3 14:04:02 samba kernel:        [system_call+52/56] [<0000006a>] 
[_stext+43/170] [<0000002b>] [<0000006a>] [<00000023>] [<00000202>] 
[<0000002b>]
Jul  3 14:04:02 samba kernel: Code: c7 05 00 00 00 00 00 00 00 00 eb 10 90 
56 53 68 de e2 1c c0
Jul  3 14:11:45 samba kernel: Unable to handle kernel NULL pointer 
dereference at virtual address 00000000
Jul  3 14:11:45 samba kernel: current->tss.cr3 = 06856000, %%cr3 = 06856000
Jul  3 14:11:45 samba kernel: *pde = 00000000
Jul  3 14:11:45 samba kernel: Oops: 0000
Jul  3 14:11:45 samba kernel: CPU:    1
Jul  3 14:11:45 samba kernel: EIP:    0010:[d_lookup+92/216]
Jul  3 14:11:45 samba kernel: EFLAGS: 00010207
Jul  3 14:11:45 samba kernel: eax: f7eef000   ebx: ffffffe8   ecx: 
00000011   edx: f7e00000
Jul  3 14:11:45 samba kernel: esi: 826b64c2   edi: d2fdc034   ebp: 
00000000   esp: d80e9f3c
Jul  3 14:11:45 samba kernel: ds: 0018   es: 0018   ss: 0018
Jul  3 14:11:45 samba kernel: Process smbd (pid: 6950, process nr: 107, 
stackpage=d80e9000)
Jul  3 14:11:45 samba kernel: Stack: d2fdc034 00000001 f7eef000 d2fdc014 
826b64c2 00000020 c01300ec d986bb20
Jul  3 14:11:45 samba kernel:        d80e9f84 d80e9f84 c0130367 d986bb20 
d80e9f84 00000001 d2fdc000 d2fdc000
Jul  3 14:11:45 samba kernel:        d80e8000 bfffde14 d2fdc014 00000020 
826b64c2 c0130464 d2fdc000 d986bb20
Jul  3 14:11:45 samba kernel: Call Trace: [<00000001>] [<00000020>] 
[cached_lookup+16/84][lookup_dentry+275/488] [<00000001>] [<00000020>] 
[__namei+40/88]
Jul  3 14:11:45 samba kernel:        [<00000001>] sys_newstat+42/140] 
[<00000001>] [system_call+52/56] [<0000006a>] [<0000002b>] [<0000002b>] 
[<0000006a>]
Jul  3 14:11:45 samba kernel:        [<00000023>] [<00000202>] [<0000002b>]
Jul  3 14:11:45 samba kernel: Code: 8b 6d 00 8b 74 24 18 39 73 48 75 5c 8b 
74 24 24 39 73 0c 75

And here's the log for the 07/05:

Jul  5 10:17:33 samba kernel: free_one_pmd: bad directory entry 00000002
Jul  5 10:38:47 samba kernel: free_one_pmd: bad directory entry 00000002
Jul  5 10:39:09 samba kernel: kmem_free: Bad obj addr (objp=e42b1800, 
name=dentry_cache)
Jul  5 10:39:09 samba kernel: Unable to handle kernel NULL pointer 
dereference at virtual address 00000000
Jul  5 10:39:09 samba kernel: current->tss.cr3 = 0cc99000, %%cr3 = 0cc99000
Jul  5 10:39:09 samba kernel: *pde = 00000000
Jul  5 10:39:09 samba kernel: Oops: 0002
Jul  5 10:39:09 samba kernel: CPU:    1
Jul  5 10:39:09 samba kernel: EIP:    0010:[kmem_cache_free+371/408]
Jul  5 10:39:09 samba kernel: EFLAGS: 00010286
Jul  5 10:39:09 samba kernel: eax: 0000003e   ebx: e42b1800   ecx: 
0000004a   edx: 00000046
Jul  5 10:39:09 samba kernel: esi: f7fff620   edi: 00000286   ebp: 
0011a5c3   esp: cd5b9f38
Jul  5 10:39:09 samba kernel: ds: 0018   es: 0018   ss: 0018
Jul  5 10:39:09 samba kernel: Process umount (pid: 30551, process nr: 467, 
stackpage=cd5b9000)
Jul  5 10:39:09 samba kernel: Stack: f05c9200 00000815 e42b187c e42b1800 
c0134f37 f7fff620 e42b1800 f05c9200
Jul  5 10:39:09 samba kernel:        00000815 fffffffe c012cd4a f05c9200 
00000815 fffffffa f296e188 00000815
Jul  5 10:39:09 samba kernel:        c012ce84 00000815 00000000 00000000 
00000000 cd5b8000 08040815 f0574360
Jul  5 10:39:09 samba kernel: Call Trace: [<00000815>] 
[shrink_dcache_sb+267/296] [<000008
15>] [do_umount+78/304] [<00000815>] [<00000815>] [umount_dev+88/160]
Jul  5 10:39:09 samba kernel:        [<00000815>] [<00000000>] 
[<00000000>] [<00000000>] [sys_umount+191/220] [<00000815>] [<00000000>] 
[sys_oldumount+12/16]
Jul  5 10:39:09 samba kernel:        [<00000000>] [system_call+52/56] 
[<00000065>] [<00000016>] [<0000002b>] [<0000002b>] [<00000016>] 
[<00000023>]
Jul  5 10:39:09 samba kernel:        [<00000206>] [<0000002b>]
Jul  5 10:39:09 samba kernel: Code: c7 05 00 00 00 00 00 00 00 00 eb 10 90 
56 53 68 de e2 1c c0


How reproducible:
Didn't try


Additional info:

For information, this server is a samba server for approximately 450
stations, so the number of smbd process is approximately 450 smbd (about 
2MB memory for each smbd process) and there's a big activity.
Comment 1 Arjan van de Ven 2001-07-05 08:13:28 EDT
Is this machine doing NFS as well ?
Comment 2 Le Tanou Jerome 2001-07-05 08:23:41 EDT
Created attachment 22747 [details]
dmesg
Comment 3 Le Tanou Jerome 2001-07-05 08:25:10 EDT
No, we don't use NFS.
It only do samba (2.0.9) server (nmbd smbd) and printer server.

There's a RAID subsystem of 7x36Go RAID 5 with 1x36GO spare
Comment 4 Le Tanou Jerome 2001-07-05 12:19:50 EDT
I have just seen that there are new packages kernel-*-2.2.19-6.2.7 dated June 25.

What are the corrections brought with regard to the old packages kernel-*-2.2.19-6.2.1 dated April 25 ?

There is no indication on your site : http://www.redhat.com/support/errata/rh62-errata-general.html

Comment 5 Arjan van de Ven 2001-07-05 13:15:42 EDT
I have no idea why the page isn't updated; I'll email the person responsible for
that page.

The changes are:
* Fixed ibcs
* reverted new xircom carbus driver as new one didn't work for everybody
* VPN masquerading code added
* Fixed race in NFS layer
Comment 6 Le Tanou Jerome 2001-07-16 05:29:31 EDT
On July 5 we replaced all the memory and recompiled the kernel from packages 2.2.19-6.2.7.
And since this date, we have no more crash. We think of a defective memory, so we close this incident which was not apparently a bug.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.