Bug 47417 - Bad parsing of /etc/profile.d for tcsh
Bad parsing of /etc/profile.d for tcsh
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: setup (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-05 08:07 EDT by Milan Kerslager
Modified: 2014-03-16 22:21 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-05 08:10:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Kerslager 2001-07-05 08:07:44 EDT
Parsing /etc/profile.d is intended for log-in shell. So appropriate section
shoud be in /etc/csh.login and not in /etc/csh.cshrc.
Yes, (t)csh interprets these files in reverse order, but we can't change
this. What we *should* honour is the same behaviour for all shells when
sourcin startup scripts.
Comment 1 Milan Kerslager 2001-07-05 08:10:34 EDT
And please write down to this scripts that they are for shell initialization and
other is meaned for login set-up (/etc/profile, /etc/bashrc, /etc/csh.*).
Comment 2 Bill Nottingham 2001-07-10 16:11:13 EDT
Will be fixed in 2.5.0-1; thanks!

Note You need to log in before you can comment on or make changes to this bug.