Bug 474200 - activating ypbind breaks ssh
activating ypbind breaks ssh
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ypbind (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Vitezslav Crhonek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-02 13:50 EST by Ed Friedman
Modified: 2008-12-03 06:57 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-03 06:57:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Friedman 2008-12-02 13:50:58 EST
Description of problem: When ypbind is turned on, ssh in to the computer is impossible and ssh out of the computer is impossible with the default settings.


Version-Release number of selected component (if applicable):
ypbind-1.20.4-8.fc10.i386

How reproducible:
Always

Steps to Reproduce:
1.Turn on sshd service
2.Turn on ypbind
3.Try ssh'ing in or out of the computer
  
Actual results:
When ssh'ing out of computer, it takes 7 minutes and 35 seconds to connect to the outside computer, and then the connection is closed immediately after entering the password.  If GSSAPIAuthentication is turned off in ssh_config, it takes 50 seconds to connect to the outside computer and the connection is made correctly after entering the password

When ssh'ing in to the computer, it takes 2 minutes to connect, but after the correct password is given, it immediately closes the connection.  If GSSAPIAuthentication is turned off in sshd_config, it takes 1 minute and 50 seconds to connect, and after the correct password is given it immediately closes the connection.

Expected results:
Ssh'ing out should immediately connect to the outside computer (and it does when ypbind is turned off in this case).  Ssh'ing in should give the login prompt immediately and allow access (and it does when ypbind is turned off).

Additional info:
This could be a ypbind or an openssh problem.  The reason I believe it is a ypbind problem is that while the computer is hanging when ssh'ing out of the computer, every 25 seconds an error message appears that says "do_ypcall: clnt_call: RPC: Timed out".  This same error message also appears when issuing the "yum -y update" command.
Comment 1 Ed Friedman 2008-12-02 13:54:29 EST
Please delete this error report.  Modifying iptables fixed the problem.

Note You need to log in before you can comment on or make changes to this bug.