Bug 474228 - ManagementAgent hangs on reconnect
ManagementAgent hangs on reconnect
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: grid (Show other bugs)
1.0
All Linux
urgent Severity urgent
: 1.1
: ---
Assigned To: Matthew Farrellee
Jeff Needle
:
: 476890 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-02 16:15 EST by Matthew Farrellee
Modified: 2009-02-04 11:04 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-04 11:04:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Farrellee 2008-12-02 16:15:28 EST
This consistently fails on RHEL4 and periodically on RHEL5

# rpm -q condor-qmf-plugins qmf
condor-qmf-plugins-7.2.0-0.7
qmf-0.3.722122-4

To reproduce:

 - start broker: qpidd --trace
 - start master: env _CONDOR_MASTER_INSTANCE_LOCK=none _CONDOR_QMF_BROKER_HOST=<***BROKER HOST***> QMF_DEBUG_LEVEL=4 _CONDOR_ALL_DEBUG=D_FULLDEBUG condor_master -t -f
 - restart broker: ^C + qpidd --trace
 - observe master's agent hang ("QMF Agent attempting to connect to the broker...")

Expected output:

QMF Agent attempting to connect to the broker...
    Connection established
SENT AttachRequest: reqBroker=1 reqAgent=20
RCVD AttachResponse: broker=1 agent=20
SENT PackageInd: package=mrg.grid
SENT ClassInd: package=mrg.grid class=master
RCVD SchemaRequest: package=mrg.grid class=master
SENT SchemaInd: package=mrg.grid class=master
Objects managed: 1
Comment 1 Matthew Farrellee 2008-12-08 14:47:54 EST
This appears to be resolved with the include of qpid-boost fix in 7.2.0-0.8
Comment 3 Ted Ross 2009-01-15 12:57:07 EST
*** Bug 476890 has been marked as a duplicate of this bug. ***
Comment 5 errata-xmlrpc 2009-02-04 11:04:09 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0036.html

Note You need to log in before you can comment on or make changes to this bug.