Bug 474257 - Evolution cannot filter Exchange folders
Evolution cannot filter Exchange folders
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
: 472838 474520 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-02 19:29 EST by Bojan Smojver
Modified: 2008-12-17 13:18 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-03 06:11:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 552583 None None None Never

  None (edit)
Description Bojan Smojver 2008-12-02 19:29:41 EST
Description of problem:
If filters are defined in such a way that they move messages to Exchange folders, the filtering will fail, saying that such folder does not exist.


Version-Release number of selected component (if applicable):
2.24.2-1.fc10

How reproducible:
Always.

Steps to Reproduce:
1. Define a filter that moves messages to one of the Exchange folders.
2. Press Ctrl+Y to filter.
  
Actual results:
An error is displayed, saying that the folder doesn't exist.

Expected results:
This worked in Evo 2.22. In fact, old rules continued to work until the account was recreated at which point the rules were redone. After that, they stopped working.

Additional info:
Comment 1 Milan Crha 2008-12-03 06:11:44 EST
Thanks for the bug report, this seems to be the upstream bug [1]. We are trying to get this fixed soon. It'll be included in 2.24.3 release, maybe sooner (no promises here). I'm sorry for the inconvenience.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=552583
Comment 2 Bojan Smojver 2008-12-03 16:02:05 EST
Thanks.

I find Evo 2.24 of really poor quality - it has vast number of problems. Just yesterday, I was playing with the Exchange setup and switched authentication to "Secure Password". After that, my calendar and address book stopped working. And I'm sure this Exchange supports NTLM (which doesn't?). Just ranting...
Comment 3 Milan Crha 2008-12-04 05:27:40 EST
*** Bug 472838 has been marked as a duplicate of this bug. ***
Comment 4 Milan Crha 2008-12-04 05:31:17 EST
*** Bug 474520 has been marked as a duplicate of this bug. ***
Comment 5 Kevin R. Page 2008-12-17 12:15:16 EST
Given that bug #472838 and bug #474520 have been marked as dups, perhaps this is in turn a dup of bug #476288 ?

Anyway, following the advice in bug #476288 I updated to evolution-2.24.2-2.fc10 from updates-testing, and the problems I was experiencing went away. The changelog says it's carrying an update for this bugs upstream parent - bug watchers here may want to test this update.
Comment 6 Milan Crha 2008-12-17 13:18:39 EST
Yes, it's the other issue, caused by the same thing. The difference with this bug is that it points to the upstream bug, thus one can look for the progress there too.

Anyway, you've right I should mention here that the update is available in a testing repo. I'm sorry I forgot to do that.

Note You need to log in before you can comment on or make changes to this bug.