Bug 474265 - MacBook Pro v2 with X1600 hangs on transition from RHGB to X with kernel mode-setting enabled on up-to-date installation
MacBook Pro v2 with X1600 hangs on transition from RHGB to X with kernel mode...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
x86_64 Linux
low Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-02 20:30 EST by Jeff Cook
Modified: 2008-12-16 05:32 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-16 05:32:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log of failed boot. (30.57 KB, text/plain)
2008-12-02 20:30 EST, Jeff Cook
no flags Details

  None (edit)
Description Jeff Cook 2008-12-02 20:30:32 EST
Created attachment 325460 [details]
Log of failed boot.

Description of problem:

Transition from fancy Plymouth start screen to X causes system to hang and become unresponsive to any input on a MacBook Pro with X1600, RadeonHD, and kernel mode-setting enabled. The screen looks like it's melting and that's bad. Have to perform hard shutdown to regain system, and must boot with the nomodeset kernel option to obtain a usable system. Plymouth and KMS worked fine from a straight F10 install; problem originated after performing an update via yum.

Version-Release number of selected component (if applicable):

Name       : xorg-x11-drv-radeonhd
Arch       : x86_64
Version    : 1.2.3
Release    : 1.5.20081112git.fc10

Name       : kernel
Arch       : x86_64
Version    : 2.6.27.5
Release    : 117.fc10

Name       : xorg-x11-server-Xorg
Arch       : x86_64
Version    : 1.5.3
Release    : 5.fc10

How reproducible:

Use an up-to-date Fedora 10 installation on a MacBook Pro v2 with X1600, RadeonHD, and kernel mode-setting.
Try to boot.
Experience failure.

I've attached an Xorg log of such a failed boot. The final line repeats for 85MB in this case ... naturally, I've truncated it.
Comment 1 Jeff Cook 2008-12-16 05:32:51 EST
An update to F10's radeonhd pushed out earlier last week corrected this issue. Kernel mode-setting is working well for me once more. : )

Note You need to log in before you can comment on or make changes to this bug.